aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-08-26 17:09:37 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-08-26 17:09:37 +0000
commit2d49c7eaf8df486500e5016b02f719eea578d045 (patch)
treece877c25be5f6e0ca1e0f2265f69ab77f6122195 /games
parentf2d233dcb4dd2dc8fcf1f43c6e7073fe55a538c4 (diff)
downloadports-2d49c7eaf8df486500e5016b02f719eea578d045.tar.gz
ports-2d49c7eaf8df486500e5016b02f719eea578d045.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/openastromenace/Makefile30
-rw-r--r--games/openastromenace/files/patch-AstroMenaceSource-Core-RendererInterface-RendererInterface.h11
2 files changed, 27 insertions, 14 deletions
diff --git a/games/openastromenace/Makefile b/games/openastromenace/Makefile
index 126fdb056c05..6f13f543d74c 100644
--- a/games/openastromenace/Makefile
+++ b/games/openastromenace/Makefile
@@ -9,10 +9,12 @@ PORTNAME= openastromenace
PORTVERSION= 1.2.0
PORTREVISION= 11
CATEGORIES= games
-MASTER_SITES= SF
-DISTFILES= openamenace-src-${PORTVERSION}${EXTRACT_SUFX} \
- oamenace-data-${PORTVERSION}${EXTRACT_SUFX} \
- oamenace-lang-${LANGPACK}-${PORTVERSION}${EXTRACT_SUFX}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/$/:source,data/}
+DISTFILES= openamenace-src-${PORTVERSION}${EXTRACT_SUFX}:source \
+ oamenace-data-1.2.0.tar.bz2:data \
+ oamenace-lang-${LANGPACK}-${PORTVERSION}${EXTRACT_SUFX}:data
+MASTER_SITE_SUBDIR= openastromenace/openastromenace/1.2.0/:source \
+ openastromenace/openastromenace%20vfs/1.2.0/:data
MAINTAINER= proler@gmail.com
COMMENT= Hardcore 3D space shooter with spaceship upgrade possibilities
@@ -20,8 +22,6 @@ COMMENT= Hardcore 3D space shooter with spaceship upgrade possibilities
LIB_DEPENDS+= vorbisfile:${PORTSDIR}/audio/libvorbis \
jpeg:${PORTSDIR}/graphics/jpeg
-BROKEN= does not compile
-
USE_BZIP2= yes
USE_GL= gl glu
USE_OPENAL= al alut
@@ -31,20 +31,22 @@ USE_CMAKE= yes
WRKSRC= ${WRKDIR}/OpenAstroMenaceSVN
USE_DOS2UNIX= yes
-OPTIONS= EN "English language pack" on \
- DE "German language pack" off \
- RU "Russian language pack" off
+OPTIONS_SINGLE= LANG
+OPTIONS_SINGLE_LANG= EN DE RU
+OPTIONS_DEFAULT=EN
+
+EN_DESC= "English language pack"
+DE_DESC= "German language pack"
+RU_DESC= "Russian language pack"
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_EN)
+.if ${PORT_OPTIONS:MEN}
LANGPACK= en
-.elif defined(WITH_DE)
+.elif ${PORT_OPTIONS:MDE}
LANGPACK= de
-.elif defined(WITH_RU)
+.elif ${PORT_OPTIONS:MRU}
LANGPACK= ru
-.else
-IGNORE= cannot be build without/with multiple language packs. Please rerun 'make config' and select single language pack
.endif
.if !defined(WITHOUT_NOUVEAU)
diff --git a/games/openastromenace/files/patch-AstroMenaceSource-Core-RendererInterface-RendererInterface.h b/games/openastromenace/files/patch-AstroMenaceSource-Core-RendererInterface-RendererInterface.h
new file mode 100644
index 000000000000..2ff76d1da8a5
--- /dev/null
+++ b/games/openastromenace/files/patch-AstroMenaceSource-Core-RendererInterface-RendererInterface.h
@@ -0,0 +1,11 @@
+--- AstroMenaceSource/Core/RendererInterface/RendererInterface.h.orig 2012-08-25 13:33:11.000000000 +0400
++++ AstroMenaceSource/Core/RendererInterface/RendererInterface.h 2012-08-25 13:36:09.000000000 +0400
+@@ -37,7 +37,7 @@
+ #include "../Base.h"
+ #include "../Math/Math.h"
+ #include "../Texture/Texture.h"
+-
++#define PFNGLCLIENTACTIVETEXTUREPROC PFNGLACTIVETEXTUREPROC
+
+
+ struct eDevCaps \ No newline at end of file