aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2012-12-13 01:02:50 +0000
committerBarbara Guida <bar@FreeBSD.org>2012-12-13 01:02:50 +0000
commita6622323f6e8d97085d64ba0f73bad722a4bac80 (patch)
treeb9394ba1977b34dc61764666a7a3bdf1a1427f7a /games
parent8f09a27c97c269bad1ade41ca7c50acd6c6cda55 (diff)
downloadports-a6622323f6e8d97085d64ba0f73bad722a4bac80.tar.gz
ports-a6622323f6e8d97085d64ba0f73bad722a4bac80.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/vavoom-extras/Makefile8
-rw-r--r--games/vavoom/Makefile20
2 files changed, 10 insertions, 18 deletions
diff --git a/games/vavoom-extras/Makefile b/games/vavoom-extras/Makefile
index 6801c9a0434a..a4b0c28774c7 100644
--- a/games/vavoom-extras/Makefile
+++ b/games/vavoom-extras/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vavoom
-# Date created: 2007-06-05
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME= vavoom-extras
PORTVERSION= 1.30
@@ -18,7 +14,7 @@ MASTER_SITES= SF/vavoom/Resources/vmodels-doom/1.4.3:vmd \
SF/vavoom/Resources/vtextures/1.1:vt11 \
http://doomtextures.freelanzer.com/:dt
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bar@FreeBSD.org
COMMENT= Doom, Doom II, Heretic, Hexen, and Strife source port (extras)
RUN_DEPENDS= vavoom:${PORTSDIR}/games/vavoom
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index bfde4a3d89b9..5aef54371c98 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vavoom
-# Date created: 18 Jan 2004
-# Whom: Igor Pokrovsky <tiamat@comset.net>
-#
+# Created by: Igor Pokrovsky <tiamat@comset.net>
# $FreeBSD$
-#
PORTNAME= vavoom
PORTVERSION= 1.33
@@ -11,10 +7,10 @@ PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Vavoom-source/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bar@FreeBSD.org
COMMENT= Doom, Doom II, Heretic, Hexen, and Strife source port
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
USE_BZIP2= yes
@@ -47,7 +43,7 @@ CMAKE_ARGS+= -DWITH_ALLEGRO=N
.endif
.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
CMAKE_ARGS+= -DWITH_FLAC=Y
.else
CMAKE_ARGS+= -DWITH_FLAC=N
@@ -64,14 +60,14 @@ PLIST_SUB+= LAUNCHER="@comment "
.endif
.if ${PORT_OPTIONS:MMAD}
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+LIB_DEPENDS+= mad:${PORTSDIR}/audio/libmad
CMAKE_ARGS+= -DWITH_LIBMAD=Y
.else
CMAKE_ARGS+= -DWITH_LIBMAD=N
.endif
.if ${PORT_OPTIONS:MMIKMOD}
-LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
+LIB_DEPENDS+= mikmod:${PORTSDIR}/audio/libmikmod
CMAKE_ARGS+= -DWITH_MIKMOD=Y
.else
CMAKE_ARGS+= -DWITH_MIKMOD=N
@@ -87,7 +83,7 @@ CMAKE_ARGS+= -DWITH_OPENAL=N
.if ${PORT_OPTIONS:MOPENGL}
USE_GL= yes
. if ${PORT_OPTIONS:MALLEGRO}
-LIB_DEPENDS+= agl.0:${PORTSDIR}/graphics/allegrogl
+LIB_DEPENDS+= agl:${PORTSDIR}/graphics/allegrogl
BROKEN= please use SDL instead of ALLEGRO, for OPENGL support
. endif
CMAKE_ARGS+= -DWITH_OPENGL=Y
@@ -100,7 +96,7 @@ CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
CMAKE_ARGS+= -DWITH_VORBIS=Y
.else
CMAKE_ARGS+= -DWITH_VORBIS=N