aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-04-13 23:43:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-04-13 23:43:09 +0000
commitf6eb86479ed1eeaad43dec727a4cce4d7ead659f (patch)
tree9546be0ef74776f2b5d57b59982d13ebeb9cd0f4 /games
parent7314e59338c911e995b3d7b166c14981aaed9419 (diff)
downloadports-f6eb86479ed1eeaad43dec727a4cce4d7ead659f.tar.gz
ports-f6eb86479ed1eeaad43dec727a4cce4d7ead659f.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/linwarrior/Makefile16
-rw-r--r--games/linwarrior/distinfo6
-rw-r--r--games/linwarrior/files/patch-Makefile14
-rw-r--r--games/linwarrior/pkg-plist62
4 files changed, 72 insertions, 26 deletions
diff --git a/games/linwarrior/Makefile b/games/linwarrior/Makefile
index b30bdcff59fb..ea4800849f4b 100644
--- a/games/linwarrior/Makefile
+++ b/games/linwarrior/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= linwarrior
-PORTVERSION= 20091108
-PORTREVISION= 1
+PORTVERSION= 20100320
CATEGORIES= games
MASTER_SITES= http://www.hackcraft.de/games/linwarrior_3d/downloads/ \
http://mirror.amdmi3.ru/distfiles/
@@ -38,13 +37,18 @@ DESKTOP_ENTRIES="LinWarrior 3D" \
EXTRA_PATCHES= ${FILESDIR}/extra-patch-source-cMech.cpp
.endif
+post-extract:
+ @${FIND} ${WRKSRC} -type d -exec chmod a+rx {} \;
+ @${FIND} ${WRKSRC} -type f -exec chmod a+r {} \;
+
post-patch:
- @${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' ${WRKSRC}/source/cMech.cpp \
- ${WRKSRC}/source/cWeapon.cpp ${WRKSRC}/source/main.cpp
+ @${REINPLACE_CMD} -e '/hash_set/ d' ${WRKSRC}/source/cAlert.h
+ @${FIND} ${WRKSRC}/source -name '*.cpp' -print0 | ${XARGS} -0 \
+ ${REINPLACE_CMD} -e 's|data/|${DATADIR}/|'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dist/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}/sound
- ${INSTALL_DATA} ${WRKSRC}/data/sound/*.wav ${DATADIR}/sound
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} '*' ${DATADIR}/
.include <bsd.port.post.mk>
diff --git a/games/linwarrior/distinfo b/games/linwarrior/distinfo
index d4bc13bf2df4..e1efe83f7f55 100644
--- a/games/linwarrior/distinfo
+++ b/games/linwarrior/distinfo
@@ -1,3 +1,3 @@
-MD5 (linwarrior_20091108.tar.gz) = c87b00f00443b016a145eeda3a9c2f39
-SHA256 (linwarrior_20091108.tar.gz) = 3edec4ecacc4c7136621de5c83d387db925f5e3035d2e78ed67d16996778e02a
-SIZE (linwarrior_20091108.tar.gz) = 5232855
+MD5 (linwarrior_20100320.tar.gz) = 0b18e08579ab48c65523379d2beac1cf
+SHA256 (linwarrior_20100320.tar.gz) = dc80a8ff355447f351f7af79c7e6a82839653738687d49345a591065cae9eee0
+SIZE (linwarrior_20100320.tar.gz) = 4558140
diff --git a/games/linwarrior/files/patch-Makefile b/games/linwarrior/files/patch-Makefile
index 1e9ed1bc442c..d2e0356d2c21 100644
--- a/games/linwarrior/files/patch-Makefile
+++ b/games/linwarrior/files/patch-Makefile
@@ -1,15 +1,15 @@
---- Makefile.orig 2009-11-08 15:59:15.000000000 +0300
-+++ Makefile 2009-12-01 15:07:51.000000000 +0300
+--- Makefile.orig 2010-02-05 22:50:30.000000000 +0300
++++ Makefile 2010-04-04 06:18:24.000000000 +0400
@@ -2,7 +2,7 @@
# Makefile with auto-dependency generation
# Add Include directories here.
--INCLUDES = -I psi3d -I source -I .
-+INCLUDES = -I psi3d -I source -I . `${SDL_CONFIG} --cflags`
+-INCLUDES = -I .
++INCLUDES = -I . `${SDL_CONFIG} --cflags`
# Automatic searching for source files.
# Objects to compile are all sources (cpp) and put the .o below build-dir.
-@@ -20,18 +20,18 @@
+@@ -20,18 +20,17 @@
LIMITER=$(dir \file)
CFLAGS+= -static-libgcc
else
@@ -27,16 +27,14 @@
# Creation of dependency information when compiling.
-CFLAGS += -Wp,-M,-MP,-MT,$@,-MF,dep/$(subst /,-,$@).d
-+CFLAGS +=
# Print warnings when compiling.
CFLAGS += -Wall
-@@ -40,7 +40,7 @@
+@@ -40,7 +39,6 @@
CFLAGS += $(INCLUDES)
# Optimizations.
-CFLAGS += -O1 -funroll-loops
-+CFLAGS +=
# Default makefile Target.
all: $(TARGET)
diff --git a/games/linwarrior/pkg-plist b/games/linwarrior/pkg-plist
index bb1ead914707..c1244421e1ad 100644
--- a/games/linwarrior/pkg-plist
+++ b/games/linwarrior/pkg-plist
@@ -1,11 +1,55 @@
bin/linwarrior
-%%DATADIR%%/sound/ambient.wav
-%%DATADIR%%/sound/explosion.wav
-%%DATADIR%%/sound/homingmissile.wav
-%%DATADIR%%/sound/machinegun.wav
-%%DATADIR%%/sound/plasmagun.wav
-%%DATADIR%%/sound/pow.wav
-%%DATADIR%%/sound/raybeam.wav
-%%DATADIR%%/sound/sparkgun.wav
-@dirrm %%DATADIR%%/sound
+%%DATADIR%%/device/camo.tga
+%%DATADIR%%/device/pow.txt
+%%DATADIR%%/device/pow.wav
+%%DATADIR%%/device/wanzer/gorilla/gorilla_ii.md5mesh
+%%DATADIR%%/device/wanzer/gorilla/gorilla_ii.mm3d
+%%DATADIR%%/device/wanzer/lemur/lemur.md5mesh
+%%DATADIR%%/device/wanzer/lemur/lemur.mm3d
+%%DATADIR%%/planet/ambient/ambient.wav
+%%DATADIR%%/planet/background/earth.tga
+%%DATADIR%%/planet/background/haze.tga
+%%DATADIR%%/planet/background/ice.tga
+%%DATADIR%%/planet/background/lavos.tga
+%%DATADIR%%/planet/background/moon.tga
+%%DATADIR%%/planet/background/mountain.tga
+%%DATADIR%%/planet/background/sun.tga
+%%DATADIR%%/urban/house/brickstone.tga
+%%DATADIR%%/urban/house/roof.tga
+%%DATADIR%%/urban/scraper/concrete.tga
+%%DATADIR%%/urban/scraper/scraper.tga
+%%DATADIR%%/urban/street/junction.tga
+%%DATADIR%%/urban/street/ns_road.tga
+%%DATADIR%%/urban/street/place.tga
+%%DATADIR%%/urban/street/we_edge.tga
+%%DATADIR%%/urban/street/we_road.tga
+%%DATADIR%%/urban/street/we_way.tga
+%%DATADIR%%/urban/street/ws_corner.tga
+%%DATADIR%%/urban/street/ws_join.tga
+%%DATADIR%%/weapon/explosion/explosion.wav
+%%DATADIR%%/weapon/flint.tga
+%%DATADIR%%/weapon/flitter.tga
+%%DATADIR%%/weapon/hmissile/homingmissile.wav
+%%DATADIR%%/weapon/mgun/machinegun.wav
+%%DATADIR%%/weapon/pgun/plasmagun.wav
+%%DATADIR%%/weapon/rbeam/raybeam.wav
+%%DATADIR%%/weapon/sgun/sparkgun.wav
+@dirrm %%DATADIR%%/weapon/sgun
+@dirrm %%DATADIR%%/weapon/rbeam
+@dirrm %%DATADIR%%/weapon/pgun
+@dirrm %%DATADIR%%/weapon/mgun
+@dirrm %%DATADIR%%/weapon/hmissile
+@dirrm %%DATADIR%%/weapon/explosion
+@dirrm %%DATADIR%%/weapon
+@dirrm %%DATADIR%%/urban/street
+@dirrm %%DATADIR%%/urban/scraper
+@dirrm %%DATADIR%%/urban/house
+@dirrm %%DATADIR%%/urban
+@dirrm %%DATADIR%%/planet/background
+@dirrm %%DATADIR%%/planet/ambient
+@dirrm %%DATADIR%%/planet
+@dirrm %%DATADIR%%/device/wanzer/lemur
+@dirrm %%DATADIR%%/device/wanzer/gorilla
+@dirrm %%DATADIR%%/device/wanzer
+@dirrm %%DATADIR%%/device
@dirrm %%DATADIR%%