aboutsummaryrefslogtreecommitdiff
path: root/german/citrix_xenapp/Makefile
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2002-09-14 08:09:35 +0000
committerMartin Blapp <mbr@FreeBSD.org>2002-09-14 08:09:35 +0000
commit1501be706e19139c7cb232af58ba40e838fcae1f (patch)
tree0d89fccec593906451f48c209066fd563f47bd60 /german/citrix_xenapp/Makefile
parent6cf01597c2a254296ecfa6f1539d3ed45648f256 (diff)
downloadports-1501be706e19139c7cb232af58ba40e838fcae1f.tar.gz
ports-1501be706e19139c7cb232af58ba40e838fcae1f.zip
Notes
Diffstat (limited to 'german/citrix_xenapp/Makefile')
-rw-r--r--german/citrix_xenapp/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/german/citrix_xenapp/Makefile b/german/citrix_xenapp/Makefile
index ceca1fb83975..33edc932d39a 100644
--- a/german/citrix_xenapp/Makefile
+++ b/german/citrix_xenapp/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= citrix_ica
-PORTVERSION= 6.20.986
+PORTVERSION= 6.30.1054
CATEGORIES= german net comms linux
MASTER_SITES=
-DISTNAME= linuxx86
+DISTNAME= ${PORTNAME}-linuxx86-de
MAINTAINER= mbr@FreeBSD.org
@@ -19,7 +19,6 @@ ONLY_FOR_ARCHS= i386
RESTRICTED= "License prohibits redistribution"
IS_INTERACTIVE= "Noisy license agreement ignores stdin"
-DIST_SUBDIR= citrix_ica
NO_WRKSUBDIR= Yes
NO_BUILD= Yes
@@ -36,8 +35,22 @@ NSCP= /usr/local/libexec/netscape \
.include <bsd.port.pre.mk>
-.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE='The distribution file for this port may not be automatically fetched due to licensing restrictions. You MUST fetch the file manually after reading and agreeing to the license at: http://www.citrix.com/download/bin/license.asp?client=linux Once ${DISTFILES} has been downloaded, move it to ${DISTDIR}/${DIST_SUBDIR} and then restart this build.'
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+IGNORE='The distribution file for this port may not be automatically fetched due to licensing restrictions.'
+.endif
+
+do-fetch:
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+ @${ECHO} ""
+ @${ECHO} "You have to fetch the file manually after reading and"
+ @${ECHO} "agreeing to the license at:"
+ @${ECHO} ""
+ @${ECHO} "http://www.citrix.com/download/bin/license.asp?client=linux"
+ @${ECHO} ""
+ @${ECHO} "Once linuxx86.tar.gz has been downloaded move it to"
+ @${ECHO} "${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} and restart the build."
+ @${ECHO} ""
+ @${FALSE}
.endif
do-install: