aboutsummaryrefslogtreecommitdiff
path: root/german/tipp10
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-21 11:51:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-21 11:51:10 +0000
commit4e44e25db876a797565d7d5e00a3fb5a12973e52 (patch)
tree6b227481b4f9a1e7acad74efd4ca65d79c5f8549 /german/tipp10
parentcaff9abab6ee6802349157c9fef40d86c07d2edc (diff)
downloadports-4e44e25db876a797565d7d5e00a3fb5a12973e52.tar.gz
ports-4e44e25db876a797565d7d5e00a3fb5a12973e52.zip
Notes
Diffstat (limited to 'german/tipp10')
-rw-r--r--german/tipp10/Makefile40
-rw-r--r--german/tipp10/distinfo3
-rw-r--r--german/tipp10/files/patch-widget-keyboard.cpp12
-rw-r--r--german/tipp10/pkg-descr20
-rw-r--r--german/tipp10/pkg-plist79
5 files changed, 154 insertions, 0 deletions
diff --git a/german/tipp10/Makefile b/german/tipp10/Makefile
new file mode 100644
index 000000000000..40377c62db89
--- /dev/null
+++ b/german/tipp10/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: tipp10
+# Date created: 2007-11-26
+# Whom: Heiner <h.eichmann@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tipp10
+PORTVERSION= 2.0.1
+CATEGORIES= german
+MASTER_SITES= http://www.tipp10.de/download/
+DISTNAME= tipp10_source_v2-0-1
+
+MAINTAINER= h.eichmann@gmx.de
+COMMENT= A 10 finger touch typing learning program
+
+RUN_DEPENDS= ${LOCALBASE}/lib/qt4/plugins/sqldrivers/libqsqlsqlite2.so:${PORTSDIR}/databases/qt4-sqlite-plugin \
+ ${LOCALBASE}/lib/qt4/plugins/sqldrivers/libqsqlsqlite.so:${PORTSDIR}/databases/qt4-sqlite3-plugin
+
+USE_ZIP= yes
+USE_QT_VER= 4
+QT_COMPONENTS= qmake sql corelib network script qtestlib rcc uic moc gui
+WRKSRC= ${WRKDIR}/source
+
+do-configure:
+ @cd ${WRKSRC} \
+ && ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
+
+do-install:
+ ${INSTALL_DATA} -d ${DATADIR}/help/img
+ ${INSTALL_DATA} -d ${DATADIR}/help/content
+ ${INSTALL_PROGRAM} ${WRKSRC}/tipp10 ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/tipp10v2.template ${WRKSRC}/license.txt ${WRKSRC}/wrong.wav ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/help/content/* ${DATADIR}/help/content
+ ${INSTALL_DATA} ${WRKSRC}/help/img/* ${DATADIR}/help/img
+ ${INSTALL_DATA} ${WRKSRC}/help/index.html ${DATADIR}/help
+ ${INSTALL_DATA} ${WRKSRC}/help/Thumbs.db ${DATADIR}/help
+ ${LN} -s ${DATADIR}/tipp10 ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/german/tipp10/distinfo b/german/tipp10/distinfo
new file mode 100644
index 000000000000..0ba52ee8f7d5
--- /dev/null
+++ b/german/tipp10/distinfo
@@ -0,0 +1,3 @@
+MD5 (tipp10_source_v2-0-1.zip) = 2e07a5222bdd43f85295288b86daed1d
+SHA256 (tipp10_source_v2-0-1.zip) = 8fe9f116d4df31f3ab4a22f104526783a72f8162c59d9156ef308e46a6885983
+SIZE (tipp10_source_v2-0-1.zip) = 1441904
diff --git a/german/tipp10/files/patch-widget-keyboard.cpp b/german/tipp10/files/patch-widget-keyboard.cpp
new file mode 100644
index 000000000000..e794f25ac18f
--- /dev/null
+++ b/german/tipp10/files/patch-widget-keyboard.cpp
@@ -0,0 +1,12 @@
+--- widget/keyboard.cpp.orig Tue Nov 27 22:06:05 2007
++++ widget/keyboard.cpp Tue Nov 27 22:07:15 2007
+@@ -293,7 +293,8 @@
+ // Emit the help text of current key(s)
+ emit statusRefreshed(statusText);
+ // Call the paint event (refresh the keyboard)
+- repaint();
++ if (keyColoring || keyColoringStart)
++ repaint();
+ }
+ }
+
diff --git a/german/tipp10/pkg-descr b/german/tipp10/pkg-descr
new file mode 100644
index 000000000000..2c67336f5b83
--- /dev/null
+++ b/german/tipp10/pkg-descr
@@ -0,0 +1,20 @@
+TIPP10 is a free 10 finger touch typing trainer, published under the GPL.
+
+The highlight: TIPP10 works intelligent. The dictation reacts on
+individual errors of the user. Keys, which are wrongly typed often,
+will be dictated more often.
+
+Visual help, various keyboard layouts, numerous settings and the
+possibility to create own exercise dictates are easing the learning
+process.
+
+Main features:
+- Intelligent exercise lessons
+- Free and own lessons
+- Scrolling text and virtual keyboard for help
+- Extensive customization
+- Performance appraisal
+- Support of alternate keyboard layouts
+- Multi platform
+
+WWW:www.tipp10.de
diff --git a/german/tipp10/pkg-plist b/german/tipp10/pkg-plist
new file mode 100644
index 000000000000..cf5fc2bb7272
--- /dev/null
+++ b/german/tipp10/pkg-plist
@@ -0,0 +1,79 @@
+bin/tipp10
+share/tipp10/help/Thumbs.db
+share/tipp10/help/content/about.html
+share/tipp10/help/content/behaviour.html
+share/tipp10/help/content/characteristics.html
+share/tipp10/help/content/evaluation.html
+share/tipp10/help/content/help.html
+share/tipp10/help/content/helpdocs.html
+share/tipp10/help/content/installation.html
+share/tipp10/help/content/introduction.html
+share/tipp10/help/content/lessons.html
+share/tipp10/help/content/lessonsettings.html
+share/tipp10/help/content/license.html
+share/tipp10/help/content/runprogram.html
+share/tipp10/help/content/settings.html
+share/tipp10/help/content/support.html
+share/tipp10/help/content/training.html
+share/tipp10/help/content/update.html
+share/tipp10/help/img/Thumbs.db
+share/tipp10/help/img/arrow_left.png
+share/tipp10/help/img/arrow_right.png
+share/tipp10/help/img/h_comparison_table.png
+share/tipp10/help/img/h_desktop_mac.png
+share/tipp10/help/img/h_evaluation_attention.png
+share/tipp10/help/img/h_evaluation_chars.png
+share/tipp10/help/img/h_evaluation_formula_error.png
+share/tipp10/help/img/h_evaluation_formula_grade.png
+share/tipp10/help/img/h_evaluation_lessons.png
+share/tipp10/help/img/h_evaluation_lessons_filter.png
+share/tipp10/help/img/h_evaluation_progress.png
+share/tipp10/help/img/h_evaluation_progress_sort.png
+share/tipp10/help/img/h_evaluation_tabs.png
+share/tipp10/help/img/h_fingers.png
+share/tipp10/help/img/h_installer_exit.png
+share/tipp10/help/img/h_installer_language.png
+share/tipp10/help/img/h_installer_license.png
+share/tipp10/help/img/h_introduction.png
+share/tipp10/help/img/h_key_blue.png
+share/tipp10/help/img/h_key_green.png
+share/tipp10/help/img/h_key_greydark.png
+share/tipp10/help/img/h_key_greylight.png
+share/tipp10/help/img/h_key_red.png
+share/tipp10/help/img/h_key_yellow.png
+share/tipp10/help/img/h_lesson_open_theme.png
+share/tipp10/help/img/h_lesson_own_menu.png
+share/tipp10/help/img/h_lesson_own_menu_edit.png
+share/tipp10/help/img/h_lesson_own_new.png
+share/tipp10/help/img/h_lesson_own_ws.png
+share/tipp10/help/img/h_lesson_tabs.png
+share/tipp10/help/img/h_lesson_training_done.png
+share/tipp10/help/img/h_main_duration.png
+share/tipp10/help/img/h_main_empty.png
+share/tipp10/help/img/h_main_linux_cut.png
+share/tipp10/help/img/h_main_settings.png
+share/tipp10/help/img/h_program_shortcut.png
+share/tipp10/help/img/h_settings_database.png
+share/tipp10/help/img/h_settings_font.png
+share/tipp10/help/img/h_settings_mac.png
+share/tipp10/help/img/h_settings_other.png
+share/tipp10/help/img/h_settings_training.png
+share/tipp10/help/img/h_terminal_mac.png
+share/tipp10/help/img/h_training_first_char.png
+share/tipp10/help/img/h_training_progress.png
+share/tipp10/help/img/h_training_start.png
+share/tipp10/help/img/h_training_without_keyboard.png
+share/tipp10/help/img/h_update.png
+share/tipp10/help/img/h_update_mac.png
+share/tipp10/help/img/h_update_proxy.png
+share/tipp10/help/img/logo.png
+share/tipp10/help/img/tt_logo.png
+share/tipp10/help/index.html
+share/tipp10/license.txt
+share/tipp10/tipp10
+share/tipp10/tipp10v2.template
+share/tipp10/wrong.wav
+@dirrm share/tipp10/help/img
+@dirrm share/tipp10/help/content
+@dirrm share/tipp10/help
+@dirrm share/tipp10