aboutsummaryrefslogtreecommitdiff
path: root/german
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-07-20 14:01:55 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-07-20 14:01:55 +0000
commit37a620312fae731882018f194ae58d22324a7aca (patch)
tree9d0ae071eb35114f45b707a78a0e611567dde8c2 /german
parent0b8b10d0be9168451de5daaccffc0acff8ed5f3f (diff)
downloadports-37a620312fae731882018f194ae58d22324a7aca.tar.gz
ports-37a620312fae731882018f194ae58d22324a7aca.zip
Notes
Diffstat (limited to 'german')
-rw-r--r--german/Makefile1
-rw-r--r--german/hunspell/Makefile60
-rw-r--r--german/hunspell/distinfo2
-rw-r--r--german/hunspell/pkg-descr3
4 files changed, 66 insertions, 0 deletions
diff --git a/german/Makefile b/german/Makefile
index eb3ec7eca8f0..e38d1cff1f5f 100644
--- a/german/Makefile
+++ b/german/Makefile
@@ -21,6 +21,7 @@
SUBDIR += eric4
SUBDIR += geonext
SUBDIR += gimp-help
+ SUBDIR += hunspell
SUBDIR += ispell
SUBDIR += ispell-alt
SUBDIR += ispell-neu
diff --git a/german/hunspell/Makefile b/german/hunspell/Makefile
new file mode 100644
index 000000000000..368f4e0ccd56
--- /dev/null
+++ b/german/hunspell/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: hunspell
+# Date created: 2011-07-20
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hunspell
+PORTVERSION= 20110609
+CATEGORIES= german textproc
+MASTER_SITES= http://www.j3e.de/ispell/igerman98/dict/
+DISTNAME= igerman98-${PORTVERSION}
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Hunspell german dictionnary
+
+BUILD_DEPENDS= buildhash:${PORTSDIR}/textproc/ispell
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/igerman98-${PORTVERSION}
+USE_GMAKE= yes
+
+ALL_TARGET= hunspell-all
+
+PLIST_FILES= share/hunspell/de_DE.aff \
+ share/hunspell/de_DE.dic \
+ share/hunspell/de_CH.aff \
+ share/hunspell/de_CH.dic \
+ share/hunspell/de_AU.aff \
+ share/hunspell/de_AU.dic
+PLIST_DIRS= share/hunspell
+
+DEALIASES= de_BE de_LU
+CHALIASES= de_LI
+
+.for ALIAS in ${DEALIASES}
+PLIST_FILES+= share/hunspell/${ALIAS}.aff \
+ share/hunspell/${ALIAS}.dic
+.endfor
+.for ALIAS in ${CHALIASES}
+PLIST_FILES+= share/hunspell/${ALIAS}.aff \
+ share/hunspell/${ALIAS}.dic
+.endfor
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/hunspell
+ @${INSTALL_DATA} ${WRKSRC}/hunspell/*.aff \
+ ${WRKSRC}/hunspell/*.dic \
+ ${PREFIX}/share/hunspell/
+ @cd ${PREFIX}/share/hunspell; \
+ for alias in ${DEALIASES}; do \
+ ${LN} -s de_DE.aff $${alias}.aff ; \
+ ${LN} -s de_DE.dic $${alias}.dic ; \
+ done; \
+ for alias in ${CHALIASES}; do \
+ ${LN} -s de_CH.aff $${alias}.aff ; \
+ ${LN} -s de_CH.dic $${alias}.dic ; \
+ done;
+
+.include <bsd.port.mk>
diff --git a/german/hunspell/distinfo b/german/hunspell/distinfo
new file mode 100644
index 000000000000..26d55c671a7e
--- /dev/null
+++ b/german/hunspell/distinfo
@@ -0,0 +1,2 @@
+SHA256 (igerman98-20110609.tar.bz2) = 5ecdf27715bb149155a11fee1922718b4efa1a4d21c2e691c6fc55afeafb7982
+SIZE (igerman98-20110609.tar.bz2) = 472203
diff --git a/german/hunspell/pkg-descr b/german/hunspell/pkg-descr
new file mode 100644
index 000000000000..84f623934b10
--- /dev/null
+++ b/german/hunspell/pkg-descr
@@ -0,0 +1,3 @@
+Hunspell german dictionnary
+
+WWW: http://www.j3e.de/ispell/igerman98/