aboutsummaryrefslogtreecommitdiff
path: root/graphics/Cgraph/files
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-12-24 07:10:15 +0000
committerSteve Price <steve@FreeBSD.org>1998-12-24 07:10:15 +0000
commite615b3dbed0e8a847a5d25b29db336dab9de4d4e (patch)
tree243a1baef8dc67a7671e65a451a2e5f7e70d3077 /graphics/Cgraph/files
parent16a24fb1cda0b19f4b085b2861d8c92bc3808149 (diff)
downloadports-e615b3dbed0e8a847a5d25b29db336dab9de4d4e.tar.gz
ports-e615b3dbed0e8a847a5d25b29db336dab9de4d4e.zip
Notes
Diffstat (limited to 'graphics/Cgraph/files')
-rw-r--r--graphics/Cgraph/files/Makefile.lib20
-rw-r--r--graphics/Cgraph/files/patch-aa11
-rw-r--r--graphics/Cgraph/files/patch-ee10
3 files changed, 41 insertions, 0 deletions
diff --git a/graphics/Cgraph/files/Makefile.lib b/graphics/Cgraph/files/Makefile.lib
new file mode 100644
index 000000000000..6d0547251126
--- /dev/null
+++ b/graphics/Cgraph/files/Makefile.lib
@@ -0,0 +1,20 @@
+# makefile for Cgraph sources
+
+LIBDIR = ${PREFIX}/lib
+
+SHLIB_MAJOR= 2
+SHLIB_MINOR= 4
+LIB= cgraph
+
+SRCS= bgdash.c bginit.c bgshow.c bgstart.c\
+ glcmp.c gxaxs.c gxlog.c gyaxs.c gylog.c\
+ gfont.c gcord.c gmlin.c gorig.c gprim.c\
+ grmle.c grset.c gmark.c ggraycolor.c gstrk.c\
+ gaxlabel.c gbott.c cgsave.c cgprint.c\
+ gtext.c gtrnc.c gmesh.c gstyl.c gwdth.c\
+ cg_newfuncs.c
+
+beforeinstall:
+ ${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 444 ${.CURDIR}/cgraph.h ${PREFIX}/include
+
+.include <bsd.lib.mk>
diff --git a/graphics/Cgraph/files/patch-aa b/graphics/Cgraph/files/patch-aa
new file mode 100644
index 000000000000..d2b1ea0418c5
--- /dev/null
+++ b/graphics/Cgraph/files/patch-aa
@@ -0,0 +1,11 @@
+--- gfont.c.orig Fri Sep 25 17:49:17 1998
++++ gfont.c Fri Sep 25 17:49:30 1998
+@@ -5,7 +5,7 @@
+ /* 9-09-87 starting */
+ /******************************************************************/
+
+-/* Modified on 5/13/92 to work on NeXt's
++/* Modified on 5/13/92 to work on NeXt's */
+
+
+ #include <string.h>
diff --git a/graphics/Cgraph/files/patch-ee b/graphics/Cgraph/files/patch-ee
new file mode 100644
index 000000000000..d37095814736
--- /dev/null
+++ b/graphics/Cgraph/files/patch-ee
@@ -0,0 +1,10 @@
+--- ../examples/loglog/TFopt-lrLog.c.orig Fri Sep 25 18:05:29 1998
++++ ../examples/loglog/TFopt-lrLog.c Fri Sep 25 18:05:38 1998
+@@ -14,7 +14,6 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <string.h>
+-#include <streams/streams.h>
+ #include <cgraph.h>
+
+ #define PI 3.141592654