aboutsummaryrefslogtreecommitdiff
path: root/graphics/Coin/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-17 15:15:23 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-17 15:15:23 +0000
commitf9b0106c7434be146379dd05080c2b0cae561167 (patch)
tree4e36790a2b4e1999feb89e7e2fa32f42a964e59e /graphics/Coin/Makefile
parentd0ad4477853b851610571c9b47e80bec02f0b9e0 (diff)
Teach 'coin-config --ldflags' to use -Wl,-rpath,/usr/local/lib instead
of -R/usr/local/lib. This is required on -current but should work fine elsewhere.
Notes
Notes: svn path=/head/; revision=365193
Diffstat (limited to 'graphics/Coin/Makefile')
-rw-r--r--graphics/Coin/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index 37c788b55df0..c1538c3c37d5 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Coin
PORTVERSION= 3.1.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/Coin3D/coin/downloads/
@@ -29,4 +29,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|DATA install-data-local|DATA|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+post-build:
+ @${REINPLACE_CMD} -e '/^ldflags=/s|-R|-Wl,-rpath,|' ${WRKSRC}/coin-default.cfg
+
.include <bsd.port.mk>