aboutsummaryrefslogtreecommitdiff
path: root/graphics/Coin
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-01 15:49:02 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-01 15:49:02 +0000
commitedcc4789b27bfe123b470914fc4ff5a0237e557e (patch)
tree3e3885573fdc4efa3aa9b80c7f706cee944927dd /graphics/Coin
parent71c8a0aee7aada9576bbc33ad0eac6401ef67327 (diff)
downloadports-edcc4789b27bfe123b470914fc4ff5a0237e557e.tar.gz
ports-edcc4789b27bfe123b470914fc4ff5a0237e557e.zip
Notes
Diffstat (limited to 'graphics/Coin')
-rw-r--r--graphics/Coin/Makefile9
-rw-r--r--graphics/Coin/files/patch-include-Inventor-SbBasic.h10
-rw-r--r--graphics/Coin/pkg-plist1
3 files changed, 15 insertions, 5 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index ac3beb2ab66d..fade18fd9501 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Coin
PORTVERSION= 3.1.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://ftp.coin3d.org/coin/src/all/ \
ftp://ftp.coin3d.org/pub/coin/src/all/
@@ -11,7 +11,9 @@ MASTER_SITES= http://ftp.coin3d.org/coin/src/all/ \
MAINTAINER= cristianorolim@hotmail.com
COMMENT= C++ 3D graphics library based on the Open Inventor 2.1 API
-LIB_DEPENDS= simage.27:${PORTSDIR}/graphics/simage
+LICENSE= BSD
+
+LIB_DEPENDS= libsimage.so:${PORTSDIR}/graphics/simage
USE_GCC= any
USE_OPENAL= al
@@ -24,9 +26,6 @@ CONFIGURE_ARGS= --with-pthread=yes --enable-threadsafe \
USE_LDCONFIG= yes
MAKE_ENV= LANG=C
-MAN1= coin-config.1
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|DATA install-data-local|DATA|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
diff --git a/graphics/Coin/files/patch-include-Inventor-SbBasic.h b/graphics/Coin/files/patch-include-Inventor-SbBasic.h
new file mode 100644
index 000000000000..05a007397909
--- /dev/null
+++ b/graphics/Coin/files/patch-include-Inventor-SbBasic.h
@@ -0,0 +1,10 @@
+--- include/Inventor/SbBasic.h.orig 2010-03-02 21:20:09.000000000 +0800
++++ include/Inventor/SbBasic.h 2013-12-01 05:17:51.275860731 +0800
+@@ -25,6 +25,7 @@
+ \**************************************************************************/
+
+ #include <Inventor/C/basic.h>
++#include <Inventor/C/errors/debugerror.h>
+
+ /* ********************************************************************** */
+ /* Trap people trying to use Inventor headers while compiling C source code.
diff --git a/graphics/Coin/pkg-plist b/graphics/Coin/pkg-plist
index 426d117d672a..7224090964e3 100644
--- a/graphics/Coin/pkg-plist
+++ b/graphics/Coin/pkg-plist
@@ -827,6 +827,7 @@ lib/libCoin.la
lib/libCoin.so
lib/libCoin.so.61
libdata/pkgconfig/Coin.pc
+man/man1/coin-config.1.gz
%%DATADIR%%/conf/coin-default.cfg
%%DATADIR%%/draggerDefaults/centerballDragger.iv
%%DATADIR%%/draggerDefaults/directionalLightDragger.iv