aboutsummaryrefslogtreecommitdiff
path: root/graphics/GraphicsMagick/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-21 02:09:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-21 02:09:56 +0000
commitf029750e165881de0f74d5516b47463e7337cd7a (patch)
treed97b05a3ace1ade7159c3f271a5b1946652dd0b0 /graphics/GraphicsMagick/Makefile
parent1291dfce6c6b91a30c6c36ad1e1d440065aee7f2 (diff)
- Update to 1.3.23
- Convert to new options helper - Convert to new options dependency helper - Convert to new test framework - Sort LIB_DEPENDS - Sort CONFIGURE_ARGS - Use PORTDATA and PORTDOCS - Remove PORTSCOUT - Cosmetic change - Update pkg-descr - Take maintainership Changes: http://www.graphicsmagick.org/NEWS.html
Notes
Notes: svn path=/head/; revision=402119
Diffstat (limited to 'graphics/GraphicsMagick/Makefile')
-rw-r--r--graphics/GraphicsMagick/Makefile130
1 files changed, 50 insertions, 80 deletions
diff --git a/graphics/GraphicsMagick/Makefile b/graphics/GraphicsMagick/Makefile
index 4d8d61fcf077..806146833853 100644
--- a/graphics/GraphicsMagick/Makefile
+++ b/graphics/GraphicsMagick/Makefile
@@ -2,74 +2,73 @@
# $FreeBSD$
PORTNAME= GraphicsMagick
-PORTVERSION= 1.3.22
+PORTVERSION= 1.3.23
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= SF \
- ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.3/
+ ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/${PORTVERSION:R}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Fast image processing tools based on ImageMagick
-LIB_DEPENDS= libjbig.so:${PORTSDIR}/graphics/jbigkit \
- libjasper.so:${PORTSDIR}/graphics/jasper \
- liblcms2.so:${PORTSDIR}/graphics/lcms2 \
- libpng.so:${PORTSDIR}/graphics/png \
- libtiff.so:${PORTSDIR}/graphics/tiff \
- libfreetype.so:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libjbig.so:${PORTSDIR}/graphics/jbigkit \
+ libjasper.so:${PORTSDIR}/graphics/jasper \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libpng.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
-PORTSCOUT= limit:^1\.3\.
+OPTIONS_DEFINE= DOCS DPS FPX OPENMP Q8BIT SSE TEST WEBP X11
+OPTIONS_DEFAULT=OPENMP WEBP X11
+DPS_DESC= Display Ghostscript support
+Q8BIT_DESC= Use 8-bit pixels (speed) instead of 16-bit (quality)
+TEST_DESC= Run bundled self-tests after build
-USES= ghostscript iconv jpeg libtool tar:bzip2
-USE_GNOME= libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PTHREAD_LIBS="-lpthread"
-CONFIGURE_ARGS= --without-perl --enable-shared --enable-static \
- --with-quantum-depth="${QD}" \
- --with-windows-font-dir="${WINDOWS_FONT_DIR}"
+CONFIGURE_ARGS= --enable-shared --enable-static \
+ --with-windows-font-dir=${WINDOWS_FONT_DIR} --without-perl
+CONFIGURE_ENV= PTHREAD_LIBS=-lpthread
INSTALL_TARGET= install-strip
+TEST_TARGET= check
+USE_GNOME= libxml2
USE_LDCONFIG= yes
+#USES= ghostscript iconv jpeg libtool localbase tar:bzip2
+USES= ghostscript iconv jpeg libtool tar:bzip2
-PLIST_SUB= Q="${QD}"
+PORTDATA= *
+PORTDOCS= *
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+# The OPENMP option may select gcc as compiler but on architectures
+# that have switched to libc++ clang should be used for C++ code.
+#CXX= c++
-OPTIONS_DEFINE= DOCS DPS FPX OPENMP Q8BIT SSE TESTS WEBP X11
-OPTIONS_DEFAULT= OPENMP WEBP X11
+# Use fonts installed by x11-fonts/webfonts by default
+WINDOWS_FONT_DIR?= ${LOCALBASE}/share/fonts/webfonts
-DPS_DESC= Display Ghostscript support (must also select X11)
-FPX_LIB_DEPENDS+= libfpx.so.[2-9]:${PORTSDIR}/graphics/libfpx
+DPS_CONFIGURE_WITH= dps
+DPS_IMPLIES= X11
+DPS_LIB_DEPENDS= libdps.so:${PORTSDIR}/x11/dgs
+DPS_USE= XORG=xt
FPX_CONFIGURE_WITH= fpx
-OPENMP_USES= compiler:openmp
-OPENMP_CONFIGURE_ON= --with-threads --enable-openmp --disable-openmp-slow
+FPX_LIB_DEPENDS= libfpx.so:${PORTSDIR}/graphics/libfpx
OPENMP_CONFIGURE_OFF= --without-threads --disable-openmp
-Q8BIT_DESC= Use 8-bit pixels (speed) instead of 16 (quality)
-TESTS_DESC= Run bundled self-tests after build
-TESTS_BUILD_DEPENDS= webfonts>0:${PORTSDIR}/x11-fonts/webfonts
-TESTS_RUN_DEPENDS= webfonts>0:${PORTSDIR}/x11-fonts/webfonts
-WEBP_LIB_DEPENDS= libwebp.so:${PORTSDIR}/graphics/webp
+OPENMP_CONFIGURE_ON= --with-threads --enable-openmp --disable-openmp-slow
+OPENMP_USES= compiler:openmp
+Q8BIT_CONFIGURE_OFF= --with-quantum-depth=16
+Q8BIT_CONFIGURE_ON= --with-quantum-depth=8
+Q8BIT_PLIST_SUB= Q=8
+Q8BIT_PLIST_SUB_OFF= Q=16
+TEST_BUILD_DEPENDS= webfonts>=0:${PORTSDIR}/x11-fonts/webfonts
+TEST_RUN_DEPENDS= webfonts>=0:${PORTSDIR}/x11-fonts/webfonts
WEBP_CONFIGURE_WITH= webp
-X11_LIB_DEPENDS= libwmflite.so:${PORTSDIR}/graphics/${LIBWMF_PORT}
-X11_USE= XORG=xext
+WEBP_LIB_DEPENDS= libwebp.so:${PORTSDIR}/graphics/webp
X11_CONFIGURE_WITH= x
+X11_LIB_DEPENDS= libwmflite.so:${PORTSDIR}/graphics/libwmf
+X11_LIB_DEPENDS_OFF= libwmflite.so:${PORTSDIR}/graphics/libwmf-nox11
+X11_USE= XORG=xext
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MX11} && ${PORT_OPTIONS:MDPS}
-LIB_DEPENDS+= libdps.so:${PORTSDIR}/x11/dgs
-USE_XORG= xt
-CONFIGURE_ARGS+=--with-dps
-.else
-CONFIGURE_ARGS+=--without-dps
-.endif
-
-.if ${PORT_OPTIONS:MQ8BIT}
-QD= 8
-.else
-QD= 16
-.endif
-
.if ${PORT_OPTIONS:MSSE}
.if ${MACHINE_CPU:Msse}
CFLAGS+= -msse
@@ -82,39 +81,10 @@ CFLAGS+= -msse3
.endif
.endif
-.if ${PORT_OPTIONS:MX11}
-LIBWMF_PORT= libwmf
-.else
-LIBWMF_PORT= libwmf-nox11
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WINDOWS_FONT_DIR)
-# Use fonts installed by x11-fonts/webfonts by default
-WINDOWS_FONT_DIR=${LOCALBASE}/share/fonts/webfonts
-.endif
-
-.if ${PORT_OPTIONS:MTESTS}
-post-build:: regression-test
-.else
-post-build::
- #
- # You are strongly advised to run ``make test'' now
- # and report any failures to ${MAINTAINER}.
- #
-.endif
+post-install-Q8BIT-off:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/GraphicsMagick/modules-Q16/coders ${STAGEDIR}${PREFIX}/lib/GraphicsMagick/modules-Q16/filters
-post-install:
-.for i in coders filters
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/GraphicsMagick/modules-Q${QD}/${i}
-.endfor
+post-install-Q8BIT-on:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/GraphicsMagick/modules-Q8/coders ${STAGEDIR}${PREFIX}/lib/GraphicsMagick/modules-Q8/filters
-regression-test: do-build
- (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
- ${MAKEFILE} ${MAKE_ARGS} check)
-
-.include <bsd.port.post.mk>
-# The OPENMP option may select gcc as compiler but on architectures
-# that have switched to libc++ clang should be used for C++ code.
-CXX= c++
+.include <bsd.port.mk>