aboutsummaryrefslogtreecommitdiff
path: root/graphics/GraphicsMagick12
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-05-20 07:00:32 +0000
committerRene Ladan <rene@FreeBSD.org>2014-05-20 07:00:32 +0000
commita1bb21b193870c11d35eee643725b0e86ea0739e (patch)
tree57168984113fdd946061901cba7f7fd0be81ee44 /graphics/GraphicsMagick12
parent822e586f282cc2a31453dd3b1501f64743144654 (diff)
downloadports-a1bb21b193870c11d35eee643725b0e86ea0739e.tar.gz
ports-a1bb21b193870c11d35eee643725b0e86ea0739e.zip
Notes
Diffstat (limited to 'graphics/GraphicsMagick12')
-rw-r--r--graphics/GraphicsMagick12/Makefile140
-rw-r--r--graphics/GraphicsMagick12/distinfo2
-rw-r--r--graphics/GraphicsMagick12/files/extra-patch-Makefile.in21
-rw-r--r--graphics/GraphicsMagick12/files/patch-Makefile.in20
-rw-r--r--graphics/GraphicsMagick12/files/patch-coders__jp2.c38
-rw-r--r--graphics/GraphicsMagick12/files/patch-coders__png.c232
-rw-r--r--graphics/GraphicsMagick12/files/patch-configure.in29
-rw-r--r--graphics/GraphicsMagick12/pkg-descr10
-rw-r--r--graphics/GraphicsMagick12/pkg-plist258
9 files changed, 0 insertions, 750 deletions
diff --git a/graphics/GraphicsMagick12/Makefile b/graphics/GraphicsMagick12/Makefile
deleted file mode 100644
index c250a7399131..000000000000
--- a/graphics/GraphicsMagick12/Makefile
+++ /dev/null
@@ -1,140 +0,0 @@
-# Created by: Ron van Daal
-# $FreeBSD$
-
-PORTNAME= GraphicsMagick
-PORTVERSION= 1.2.10
-PORTREVISION= 4
-CATEGORIES= graphics
-MASTER_SITES= SF \
- ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.2/
-PORTSCOUT= limit:^1\.2\.
-PKGNAMESUFFIX= 12
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Fast image processing tools based on ImageMagick
-
-DEPRECATED= Unmaintained upstream, no ports depending on it. Use graphics/GraphicsMagick13 instead
-EXPIRATION_DATE= 2014-05-20
-
-CONFLICTS= GraphicsMagick-1.[13].* GraphicsMagick13-*
-
-LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- libpng15.so:${PORTSDIR}/graphics/png \
- libjbig.so:${PORTSDIR}/graphics/jbigkit \
- libxml2.so:${PORTSDIR}/textproc/libxml2 \
- libjasper.so:${PORTSDIR}/graphics/jasper \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
- liblcms.so:${PORTSDIR}/graphics/lcms \
- libtiff.so:${PORTSDIR}/graphics/tiff
-
-OPTIONS_DEFINE= Q8BIT FPX OPENMP SSE TESTS X11 DOCS
-
-Q8BIT_DESC= Use 8-bit pixels (speed) instead of 16 (quality)
-DPS_DESC= Enable Display Ghostscript support
-NODPS_DESC= Disable Display Ghostscript support
-TESTS_DESC= Run bundled self-tests after build
-
-OPTIONS_DEFAULT=FPX DPS OPENMP X11 TESTS DOCS
-OPTIONS_SINGLE= X11
-OPTIONS_SINGLE_X11= DPS NODPS
-
-USES= iconv
-USE_AUTOTOOLS= libtool libltdl
-USE_BZIP2= yes
-USE_GHOSTSCRIPT=yes
-GNU_CONFIGURE= yes
-
-CONFIGURE_ARGS= --without-perl --enable-shared --enable-static \
- --with-ltdl-include=${LOCALBASE}/include \
- --with-ltdl-lib=${LOCALBASE}/lib
-USE_LDCONFIG= yes
-
-ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
-
-CFLAGS+= -DPNG_DEPSTRUCT=
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
-LDFLAGS+= -L${LOCALBASE}/lib
-
-test check:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS} == ""
-# Get rid of the Makefile targets that install the documentation
-# and HTML files into DOCSDIR
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in
-.endif
-
-.if ${PORT_OPTIONS:MSSE}
-.if ${MACHINE_CPU:Msse}
-CFLAGS+= -msse
-.endif
-.if ${MACHINE_CPU:Msse2}
-CFLAGS+= -msse2
-.endif
-.if ${MACHINE_CPU:Msse3}
-CFLAGS+= -msse3
-.endif
-.endif
-
-.if ${PORT_OPTIONS:MFPX}
-LIB_DEPENDS+= libfpx.so:${PORTSDIR}/graphics/libfpx
-CONFIGURE_ARGS+= --with-fpx
-.else
-CONFIGURE_ARGS+= --without-fpx
-.endif
-
-.if ${PORT_OPTIONS:MDPS}
-LIB_DEPENDS+= libdps.so:${PORTSDIR}/x11/dgs
-CONFIGURE_ARGS+= --with-dps
-.else
-CONFIGURE_ARGS+= --without-dps
-.endif
-
-.if ${PORT_OPTIONS:MOPENMP}
-.if ${OSVERSION} < 700042
-IGNORE= does not support OpenMP on FreeBSD version ${OSVERSION}
-.endif
-
-LDFLAGS+= ${PTHREAD_LIBS}
-CONFIGURE_ARGS+= --with-threads --enable-openmp
-.else
-CONFIGURE_ARGS+= --without-threads --disable-openmp
-.endif
-
-.ifndef WINDOWS_FONT_DIR
-# Use fonts installed by x11-fonts/webfonts by default
-WINDOWS_FONT_DIR=${LOCALBASE}/lib/X11/fonts/webfonts
-.endif
-
-.if defined(WITH_WINDOWS_FONT_DIR)
-CONFIGURE_ARGS+= --with-windows-font-dir="${WINDOWS_FONT_DIR}"
-.endif
-
-.if ${PORT_OPTIONS:MX11} == ""
-CONFIGURE_ARGS+=--without-x
-LIB_DEPENDS+= libwmflite.so:${PORTSDIR}/graphics/libwmf-nox11
-.else
-LIB_DEPENDS+= libwmflite.so:${PORTSDIR}/graphics/libwmf
-.endif
-
-.if ${PORT_OPTIONS:MQ8BIT}
-CONFIGURE_ARGS+= --with-quantum-depth=8
-PLIST_SUB+= Q=8
-.else
-CONFIGURE_ARGS+= --with-quantum-depth=16
-PLIST_SUB+= Q=16
-.endif
-
-.if ${PORT_OPTIONS:MTESTS}
-post-build:: test
-.else
-post-build::
- #
- # You are strongly advised to run ``make test'' now
- # and report any failures to ${MAINTAINER}.
- #
-.endif
-
-.include <bsd.port.mk>
diff --git a/graphics/GraphicsMagick12/distinfo b/graphics/GraphicsMagick12/distinfo
deleted file mode 100644
index 30bd44478ecc..000000000000
--- a/graphics/GraphicsMagick12/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (GraphicsMagick-1.2.10.tar.bz2) = 35e28738a145ccbd3952b7a2a5cc4d1a3763dea5beb14b2b7d76b3c086a8d2a9
-SIZE (GraphicsMagick-1.2.10.tar.bz2) = 5943291
diff --git a/graphics/GraphicsMagick12/files/extra-patch-Makefile.in b/graphics/GraphicsMagick12/files/extra-patch-Makefile.in
deleted file mode 100644
index ad07b13772c7..000000000000
--- a/graphics/GraphicsMagick12/files/extra-patch-Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.in.orig 2008-11-19 17:40:16.000000000 -0500
-+++ Makefile.in 2008-11-19 17:40:58.000000000 -0500
-@@ -9322,7 +9322,7 @@
- info-am:
-
- install-data-am: install-codersLTLIBRARIES install-configlibDATA \
-- install-configshareDATA install-data-local install-docDATA \
-+ install-configshareDATA install-data-local \
- install-filtersLTLIBRARIES install-includeHEADERS \
- install-ltdlincludeHEADERS install-magickincHEADERS \
- install-magickppincHEADERS install-magickpptopincHEADERS \
-@@ -9671,8 +9671,7 @@
- $(UTILITIES_INSTALL_EXEC_LOCAL_TARGETS)
-
- install-data-local: $(MAGICK_INSTALL_DATA_LOCAL_TARGETS) \
-- $(PERLMAGICK_INSTALL_DATA_LOCAL_TARGETS) \
-- $(HTML_INSTALL_DATA_TARGETS)
-+ $(PERLMAGICK_INSTALL_DATA_LOCAL_TARGETS)
-
- uninstall-local: $(MAGICK_UNINSTALL_LOCAL_TARGETS) \
- $(PERLMAGICK_UNINSTALL_LOCAL_TARGETS) \
diff --git a/graphics/GraphicsMagick12/files/patch-Makefile.in b/graphics/GraphicsMagick12/files/patch-Makefile.in
deleted file mode 100644
index 7c5d272c8bd3..000000000000
--- a/graphics/GraphicsMagick12/files/patch-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig 2008-05-18 17:22:51.000000000 -0400
-+++ Makefile.in 2008-06-06 18:41:23.620488084 -0400
-@@ -1775,7 +1775,7 @@
- MagickLibConfigPath = @MagickLibConfigPath@
- MagickLibPath = @MagickLibPath@
- MagickShareConfigPath = @MagickShareConfigPath@
--MagickSharePath = @MagickSharePath@
-+MagickSharePath = ${DATADIR}
- MogrifyDelegate = @MogrifyDelegate@
- NM = @NM@
- NMEDIT = @NMEDIT@
-@@ -4382,7 +4382,7 @@
- @WITH_PERL_DYNAMIC_FALSE@@WITH_PERL_STATIC_TRUE@@WITH_PERL_TRUE@PERLSTATICNAME = PerlMagick
-
- # Pkgconfig directory
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
-
- # Files to install in Pkgconfig directory
- pkgconfig_DATA = \
diff --git a/graphics/GraphicsMagick12/files/patch-coders__jp2.c b/graphics/GraphicsMagick12/files/patch-coders__jp2.c
deleted file mode 100644
index 6a2fddd2901b..000000000000
--- a/graphics/GraphicsMagick12/files/patch-coders__jp2.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- ./coders/jp2.c.orig 2010-02-23 16:23:04.000000000 -0500
-+++ ./coders/jp2.c 2010-02-23 16:23:24.000000000 -0500
-@@ -681,7 +681,7 @@
-
- entry=SetMagickInfo("J2C");
- entry->description=AcquireString("JPEG-2000 Code Stream Syntax");
-- entry->module="JP2";
-+ entry->module=AcquireString("JP2");
- entry->magick=(MagickHandler) IsJPC;
- entry->adjoin=False;
- entry->seekable_stream=True;
-@@ -694,7 +694,7 @@
-
- entry=SetMagickInfo("JP2");
- entry->description=AcquireString("JPEG-2000 JP2 File Format Syntax");
-- entry->module="JP2";
-+ entry->module=AcquireString("JP2");
- entry->magick=(MagickHandler) IsJP2;
- entry->adjoin=False;
- entry->seekable_stream=True;
-@@ -707,7 +707,7 @@
-
- entry=SetMagickInfo("JPC");
- entry->description=AcquireString("JPEG-2000 Code Stream Syntax");
-- entry->module="JP2";
-+ entry->module=AcquireString("JP2");
- entry->magick=(MagickHandler) IsJPC;
- entry->adjoin=False;
- entry->seekable_stream=True;
-@@ -720,7 +720,7 @@
-
- entry=SetMagickInfo("PGX");
- entry->description=AcquireString("JPEG-2000 VM Format");
-- entry->module="JP2";
-+ entry->module=AcquireString("JP2");
- entry->magick=(MagickHandler) IsJPC;
- entry->adjoin=False;
- entry->seekable_stream=True;
diff --git a/graphics/GraphicsMagick12/files/patch-coders__png.c b/graphics/GraphicsMagick12/files/patch-coders__png.c
deleted file mode 100644
index dcf0b339174d..000000000000
--- a/graphics/GraphicsMagick12/files/patch-coders__png.c
+++ /dev/null
@@ -1,232 +0,0 @@
---- coders/png.c.orig 2010-01-06 23:01:31.000000000 +0100
-+++ coders/png.c 2012-05-10 04:50:59.000000000 +0200
-@@ -75,6 +75,7 @@
- #if defined(HasPNG)
- #include "png.h"
- #include "zlib.h"
-+#include "pngpriv.h"
-
- #if PNG_LIBPNG_VER > 95
- /*
-@@ -1292,7 +1293,7 @@
- " libpng-%.1024s error: %.1024s", PNG_LIBPNG_VER_STRING,
- message);
- (void) ThrowException2(&image->exception,CoderError,message,image->filename);
-- longjmp(ping->jmpbuf,1);
-+ longjmp(png_jmpbuf(ping),1);
- }
-
- static void PNGWarningHandler(png_struct *ping,png_const_charp message)
-@@ -1593,7 +1594,7 @@
- ThrowReaderException(ResourceLimitError,MemoryAllocationFailed,image);
- }
- png_pixels=(unsigned char *) NULL;
-- if (setjmp(ping->jmpbuf))
-+ if (setjmp(png_jmpbuf(ping)))
- {
- /*
- PNG image is corrupt.
-@@ -1955,13 +1956,13 @@
- Image has a transparent background.
- */
- transparent_color.red=
-- (Quantum)(ping_info->trans_values.red & bit_mask);
-+ (Quantum)(ping_info->trans_color.red & bit_mask);
- transparent_color.green=
-- (Quantum) (ping_info->trans_values.green & bit_mask);
-+ (Quantum) (ping_info->trans_color.green & bit_mask);
- transparent_color.blue=
-- (Quantum) (ping_info->trans_values.blue & bit_mask);
-+ (Quantum) (ping_info->trans_color.blue & bit_mask);
- transparent_color.opacity=
-- (Quantum) (ping_info->trans_values.gray & bit_mask);
-+ (Quantum) (ping_info->trans_color.gray & bit_mask);
- if (ping_info->color_type == PNG_COLOR_TYPE_GRAY)
- {
- transparent_color.red=transparent_color.opacity;
-@@ -2469,7 +2470,7 @@
- index=indexes[x];
- if (index < ping_info->num_trans)
- q->opacity=
-- ScaleCharToQuantum(255-ping_info->trans[index]);
-+ ScaleCharToQuantum(255-ping_info->trans_alpha[index]);
- else
- q->opacity=OpaqueOpacity;
- q++;
-@@ -6054,7 +6055,7 @@
- AcquireSemaphoreInfo(&png_semaphore);
- #endif
-
-- if (setjmp(ping->jmpbuf))
-+ if (setjmp(png_jmpbuf(ping)))
- {
- /*
- PNG write failed.
-@@ -6258,13 +6259,13 @@
- /*
- Identify which colormap entry is transparent.
- */
-- ping_info->trans=MagickAllocateMemory(unsigned char *,number_colors);
-- if (ping_info->trans == (unsigned char *) NULL)
-+ ping_info->trans_alpha=MagickAllocateMemory(unsigned char *,number_colors);
-+ if (ping_info->trans_alpha == (unsigned char *) NULL)
- ThrowWriterException(ResourceLimitError,MemoryAllocationFailed,
- image);
- assert(number_colors <= 256);
- for (i=0; i < (long) number_colors; i++)
-- ping_info->trans[i]=255;
-+ ping_info->trans_alpha[i]=255;
- for (y=0; y < (long) image->rows; y++)
- {
- register const PixelPacket
-@@ -6284,7 +6285,7 @@
-
- index=indexes[x];
- assert((unsigned long) index < number_colors);
-- ping_info->trans[index]=(png_byte) (255-
-+ ping_info->trans_alpha[index]=(png_byte) (255-
- ScaleQuantumToChar(p->opacity));
- }
- p++;
-@@ -6292,14 +6293,14 @@
- }
- ping_info->num_trans=0;
- for (i=0; i < (long) number_colors; i++)
-- if (ping_info->trans[i] != 255)
-+ if (ping_info->trans_alpha[i] != 255)
- ping_info->num_trans=(unsigned short) (i+1);
- if (ping_info->num_trans == 0)
- ping_info->valid&=(~PNG_INFO_tRNS);
- if (!(ping_info->valid & PNG_INFO_tRNS))
- ping_info->num_trans=0;
- if (ping_info->num_trans == 0)
-- MagickFreeMemory(ping_info->trans);
-+ MagickFreeMemory(ping_info->trans_alpha);
- /*
- Identify which colormap entry is the background color.
- */
-@@ -6441,12 +6442,12 @@
- (p->opacity != OpaqueOpacity))
- {
- ping_info->valid|=PNG_INFO_tRNS;
-- ping_info->trans_values.red=ScaleQuantumToShort(p->red)&mask;
-- ping_info->trans_values.green=ScaleQuantumToShort(p->green)&mask;
-- ping_info->trans_values.blue=ScaleQuantumToShort(p->blue)&mask;
-- ping_info->trans_values.gray=
-+ ping_info->trans_color.red=ScaleQuantumToShort(p->red)&mask;
-+ ping_info->trans_color.green=ScaleQuantumToShort(p->green)&mask;
-+ ping_info->trans_color.blue=ScaleQuantumToShort(p->blue)&mask;
-+ ping_info->trans_color.gray=
- (png_uint_16) ScaleQuantumToShort(PixelIntensity(p))&mask;
-- ping_info->trans_values.index=(unsigned char)
-+ ping_info->trans_color.index=(unsigned char)
- (ScaleQuantumToChar(MaxRGB-p->opacity));
- }
- }
-@@ -6467,7 +6468,7 @@
- {
- if (p->opacity != OpaqueOpacity)
- {
-- if (!RGBColorMatchExact(ping_info->trans_values,*p))
-+ if (!RGBColorMatchExact(ping_info->trans_color,*p))
- {
- break; /* Can't use RGB + tRNS for multiple
- transparent colors. */
-@@ -6480,7 +6481,7 @@
- }
- else
- {
-- if (RGBColorMatchExact(ping_info->trans_values,*p))
-+ if (RGBColorMatchExact(ping_info->trans_color,*p))
- break; /* Can't use RGB + tRNS when another pixel
- having the same RGB samples is
- transparent. */
-@@ -6498,10 +6499,10 @@
- ping_info->color_type &= 0x03; /* changes 4 or 6 to 0 or 2 */
- if (image->depth == 8)
- {
-- ping_info->trans_values.red&=0xff;
-- ping_info->trans_values.green&=0xff;
-- ping_info->trans_values.blue&=0xff;
-- ping_info->trans_values.gray&=0xff;
-+ ping_info->trans_color.red&=0xff;
-+ ping_info->trans_color.green&=0xff;
-+ ping_info->trans_color.blue&=0xff;
-+ ping_info->trans_color.gray&=0xff;
- }
- }
- }
-@@ -6517,7 +6518,7 @@
- {
- ping_info->color_type=PNG_COLOR_TYPE_GRAY;
- if (save_image_depth == 16 && image->depth == 8)
-- ping_info->trans_values.gray*=0x0101;
-+ ping_info->trans_color.gray*=0x0101;
- }
- if (image->depth > QuantumDepth)
- image->depth=QuantumDepth;
-@@ -6701,13 +6702,13 @@
- ping_info->num_trans=0;
- if (ping_info->num_trans != 0)
- {
-- ping_info->trans=MagickAllocateMemory(unsigned char *,
-+ ping_info->trans_alpha=MagickAllocateMemory(unsigned char *,
- number_colors);
-- if (ping_info->trans == (unsigned char *) NULL)
-+ if (ping_info->trans_alpha == (unsigned char *) NULL)
- ThrowWriterException(ResourceLimitError,
- MemoryAllocationFailed,image);
- for (i=0; i < (long) number_colors; i++)
-- ping_info->trans[i]=(png_byte) trans[i];
-+ ping_info->trans_alpha[i]=(png_byte) trans[i];
- }
- }
-
-@@ -6726,10 +6727,10 @@
- image->depth=8;
- if ((save_image_depth == 16) && (image->depth == 8))
- {
-- ping_info->trans_values.red*=0x0101;
-- ping_info->trans_values.green*=0x0101;
-- ping_info->trans_values.blue*=0x0101;
-- ping_info->trans_values.gray*=0x0101;
-+ ping_info->trans_color.red*=0x0101;
-+ ping_info->trans_color.green*=0x0101;
-+ ping_info->trans_color.blue*=0x0101;
-+ ping_info->trans_color.gray*=0x0101;
- }
- }
-
-@@ -6756,8 +6757,8 @@
- " Setting up bKGD chunk");
- png_set_bKGD(ping,ping_info,&background);
-
-- ping_info->trans_values.gray=(png_uint_16)(maxval*
-- ping_info->trans_values.gray/MaxRGB);
-+ ping_info->trans_color.gray=(png_uint_16)(maxval*
-+ ping_info->trans_color.gray/MaxRGB);
- }
- }
- if (logging)
-@@ -7332,7 +7333,7 @@
- #endif
- if (ping_info->valid & PNG_INFO_tRNS)
- {
-- MagickFreeMemory(ping_info->trans);
-+ MagickFreeMemory(ping_info->trans_alpha);
- ping_info->valid&=(~PNG_INFO_tRNS);
- }
- png_destroy_write_struct(&ping,&ping_info);
-@@ -8416,10 +8416,10 @@
- {
- (void) LogMagickEvent(CoderEvent,GetMagickModule(),
- " TERM delay: %lu",
-- (png_uint_32) (mng_info->ticks_per_second*final_delay/100));
-+ (uint64_t) (mng_info->ticks_per_second*final_delay/100));
- if (image->iterations == 0)
- (void) LogMagickEvent(CoderEvent,GetMagickModule(),
-- " TERM iterations: %lu",PNG_MAX_UINT);
-+ " TERM iterations: %lu", (uint64_t)PNG_MAX_UINT);
- else
- (void) LogMagickEvent(CoderEvent,GetMagickModule(),
- " Image iterations: %lu",
diff --git a/graphics/GraphicsMagick12/files/patch-configure.in b/graphics/GraphicsMagick12/files/patch-configure.in
deleted file mode 100644
index e8e1402cef44..000000000000
--- a/graphics/GraphicsMagick12/files/patch-configure.in
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.orig 2010-01-05 20:20:45.000000000 +0100
-+++ configure 2013-12-13 12:20:04.000000000 +0100
-@@ -24299,7 +24299,7 @@
- fi
-
-
-- ac_fn_c_check_header_compile "$LINENO" "freetype/freetype.h" "ac_cv_header_freetype_freetype_h" "$FT2BUILD_H
-+ ac_fn_c_check_header_compile "$LINENO" "freetype.h" "ac_cv_header_freetype_freetype_h" "$FT2BUILD_H
- "
- if test "x$ac_cv_header_freetype_freetype_h" = x""yes; then :
- have_freetype_h='yes'
-@@ -25089,7 +25089,7 @@
- #
-
- # Subdirectory under lib to place GraphicsMagick lib files
--MagickLibSubdir="${PACKAGE_NAME}-${PACKAGE_VERSION}"
-+MagickLibSubdir="${PACKAGE_NAME}"
-
- cat >>confdefs.h <<_ACEOF
- #define MagickLibSubdir "$MagickLibSubdir"
-@@ -25193,7 +25193,7 @@
-
- #
- # Path to GraphicsMagick share files
--MagickShareSubdir="${PACKAGE_NAME}-${PACKAGE_VERSION}"
-+MagickShareSubdir="${PACKAGE_NAME}"
- MagickSharePath="${DATA_DIR}/${MagickShareSubdir}"
- MagickSharePathDefine="${MagickSharePath}/"
- case "${build_os}" in
diff --git a/graphics/GraphicsMagick12/pkg-descr b/graphics/GraphicsMagick12/pkg-descr
deleted file mode 100644
index cdc7ca9c509b..000000000000
--- a/graphics/GraphicsMagick12/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-This is a port of GraphicsMagick(TM), the "swiss army knife" of image
-processing. It provides a robust collection of tools and libraries which
-support reading, writing, and manipulating an image in over 88 major
-formats including formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF, SVG
-and TIFF.
-
-The program is the fork of a better-known ImageMagick (5.5.2), which
-emphasizes end-user and API-stabilities.
-
-WWW: http://www.graphicsmagick.org/
diff --git a/graphics/GraphicsMagick12/pkg-plist b/graphics/GraphicsMagick12/pkg-plist
deleted file mode 100644
index 3122f39119b0..000000000000
--- a/graphics/GraphicsMagick12/pkg-plist
+++ /dev/null
@@ -1,258 +0,0 @@
-bin/GraphicsMagick++-config
-bin/GraphicsMagick-config
-bin/GraphicsMagickWand-config
-bin/gm
-include/GraphicsMagick/Magick++.h
-include/GraphicsMagick/Magick++/Blob.h
-include/GraphicsMagick/Magick++/CoderInfo.h
-include/GraphicsMagick/Magick++/Color.h
-include/GraphicsMagick/Magick++/Drawable.h
-include/GraphicsMagick/Magick++/Exception.h
-include/GraphicsMagick/Magick++/Geometry.h
-include/GraphicsMagick/Magick++/Image.h
-include/GraphicsMagick/Magick++/Include.h
-include/GraphicsMagick/Magick++/Montage.h
-include/GraphicsMagick/Magick++/Pixels.h
-include/GraphicsMagick/Magick++/STL.h
-include/GraphicsMagick/Magick++/TypeMetric.h
-include/GraphicsMagick/magick/PreRvIcccm.h
-include/GraphicsMagick/magick/api.h
-include/GraphicsMagick/magick/attribute.h
-include/GraphicsMagick/magick/blob.h
-include/GraphicsMagick/magick/channel.h
-include/GraphicsMagick/magick/color.h
-include/GraphicsMagick/magick/colorspace.h
-include/GraphicsMagick/magick/command.h
-include/GraphicsMagick/magick/composite.h
-include/GraphicsMagick/magick/compress.h
-include/GraphicsMagick/magick/constitute.h
-include/GraphicsMagick/magick/decorate.h
-include/GraphicsMagick/magick/delegate.h
-include/GraphicsMagick/magick/deprecate.h
-include/GraphicsMagick/magick/draw.h
-include/GraphicsMagick/magick/effect.h
-include/GraphicsMagick/magick/enhance.h
-include/GraphicsMagick/magick/error.h
-include/GraphicsMagick/magick/forward.h
-include/GraphicsMagick/magick/fx.h
-include/GraphicsMagick/magick/gem.h
-include/GraphicsMagick/magick/image.h
-include/GraphicsMagick/magick/list.h
-include/GraphicsMagick/magick/log.h
-include/GraphicsMagick/magick/magic.h
-include/GraphicsMagick/magick/magick.h
-include/GraphicsMagick/magick/magick_config.h
-include/GraphicsMagick/magick/magick_types.h
-include/GraphicsMagick/magick/memory.h
-include/GraphicsMagick/magick/module.h
-include/GraphicsMagick/magick/monitor.h
-include/GraphicsMagick/magick/montage.h
-include/GraphicsMagick/magick/operator.h
-include/GraphicsMagick/magick/paint.h
-include/GraphicsMagick/magick/pixel_cache.h
-include/GraphicsMagick/magick/profile.h
-include/GraphicsMagick/magick/quantize.h
-include/GraphicsMagick/magick/registry.h
-include/GraphicsMagick/magick/render.h
-include/GraphicsMagick/magick/resize.h
-include/GraphicsMagick/magick/resource.h
-include/GraphicsMagick/magick/shear.h
-include/GraphicsMagick/magick/signature.h
-include/GraphicsMagick/magick/symbols.h
-include/GraphicsMagick/magick/timer.h
-include/GraphicsMagick/magick/transform.h
-include/GraphicsMagick/magick/utility.h
-include/GraphicsMagick/magick/version.h
-include/GraphicsMagick/magick/widget.h
-include/GraphicsMagick/magick/xwindow.h
-include/GraphicsMagick/wand/drawing_wand.h
-include/GraphicsMagick/wand/magick_wand.h
-include/GraphicsMagick/wand/pixel_wand.h
-include/GraphicsMagick/wand/wand_api.h
-lib/GraphicsMagick/config/delegates.mgk
-lib/GraphicsMagick/config/type-ghostscript.mgk
-lib/GraphicsMagick/config/type-solaris.mgk
-lib/GraphicsMagick/config/type-windows.mgk
-lib/GraphicsMagick/config/type.mgk
-lib/libGraphicsMagick++.a
-lib/libGraphicsMagick++.la
-lib/libGraphicsMagick++.so
-lib/libGraphicsMagick++.so.2
-lib/libGraphicsMagick.a
-lib/libGraphicsMagick.la
-lib/libGraphicsMagick.so
-lib/libGraphicsMagick.so.2
-lib/libGraphicsMagickWand.a
-lib/libGraphicsMagickWand.la
-lib/libGraphicsMagickWand.so
-lib/libGraphicsMagickWand.so.1
-libdata/pkgconfig/GraphicsMagick++.pc
-libdata/pkgconfig/GraphicsMagick.pc
-libdata/pkgconfig/GraphicsMagickWand.pc
-man/man1/GraphicsMagick++-config.1.gz
-man/man1/GraphicsMagick-config.1.gz
-man/man1/GraphicsMagickWand-config.1.gz
-man/man1/gm.1.gz
-man/man4/miff.4.gz
-man/man5/quantize.5.gz
-%%DATADIR%%/config/colors.mgk
-%%DATADIR%%/config/log.mgk
-%%DATADIR%%/config/magic.mgk
-%%DATADIR%%/config/modules.mgk
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.2001
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.2002
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.2003
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.2004
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.2005
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.2006
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.2007
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.2008
-%%PORTDOCS%%%%DOCSDIR%%/Copyright.txt
-%%PORTDOCS%%%%DOCSDIR%%/NEWS.txt
-%%PORTDOCS%%%%DOCSDIR%%/images/ball.png
-%%PORTDOCS%%%%DOCSDIR%%/images/examples.jpg
-%%PORTDOCS%%%%DOCSDIR%%/images/gm-125x80t.png
-%%PORTDOCS%%%%DOCSDIR%%/images/gm-188x120t.png
-%%PORTDOCS%%%%DOCSDIR%%/images/gm-282x180t.png
-%%PORTDOCS%%%%DOCSDIR%%/images/right_triangle.png
-%%PORTDOCS%%%%DOCSDIR%%/images/right_triangle_option.png
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/www/AUTHORS.html
-%%PORTDOCS%%%%DOCSDIR%%/www/BENCHMARKS.html
-%%PORTDOCS%%%%DOCSDIR%%/www/BUGS.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Changelog.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Copyright.html
-%%PORTDOCS%%%%DOCSDIR%%/www/FAQ.html
-%%PORTDOCS%%%%DOCSDIR%%/%%WWWDIR%%.html
-%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-unix.html
-%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-windows.html
-%%PORTDOCS%%%%DOCSDIR%%/www/ImageMagickObject.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Blob.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.fig
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.svg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ChangeLog.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/CoderInfo.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Color.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Documentation.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Drawable.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Drawable_example_1.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Enumerations.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Exception.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/FormatCharacters.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Future.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Geometry.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.fig
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ImageDesign.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ImageMagick.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Install.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Magick++.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Montage.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/NEWS.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/PixelPacket.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Pixels.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/STL.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/TypeMetric.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/gm-188x120t.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/index.html
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/montage-sample-framed.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/right_triangle.png
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.fig
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.fig
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-sample-framed.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-sample-plain.jpg
-%%PORTDOCS%%%%DOCSDIR%%/www/NEWS.html
-%%PORTDOCS%%%%DOCSDIR%%/www/PLATFORMS.html
-%%PORTDOCS%%%%DOCSDIR%%/www/README.html
-%%PORTDOCS%%%%DOCSDIR%%/www/animate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/animate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/annotate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/attribute.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/blob.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/channel.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/color.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/composite.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/constitute.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/decorate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/deprecate.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/display.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/draw.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/effect.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/enhance.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/error.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/fx.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/image.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/list.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/magick.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/memory.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/monitor.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/montage.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/operator.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/paint.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/pixel_cache.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/profile.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/quantize.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/registry.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/render.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/resize.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/resource.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/segment.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/shear.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/signature.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/transform.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/types.html
-%%PORTDOCS%%%%DOCSDIR%%/www/api/widget.html
-%%PORTDOCS%%%%DOCSDIR%%/www/body.html
-%%PORTDOCS%%%%DOCSDIR%%/www/color.html
-%%PORTDOCS%%%%DOCSDIR%%/www/composite.html
-%%PORTDOCS%%%%DOCSDIR%%/www/conjure.html
-%%PORTDOCS%%%%DOCSDIR%%/www/contribute.html
-%%PORTDOCS%%%%DOCSDIR%%/www/convert.html
-%%PORTDOCS%%%%DOCSDIR%%/www/cvs.html
-%%PORTDOCS%%%%DOCSDIR%%/www/development.html
-%%PORTDOCS%%%%DOCSDIR%%/www/display.html
-%%PORTDOCS%%%%DOCSDIR%%/www/download.html
-%%PORTDOCS%%%%DOCSDIR%%/www/formats.html
-%%PORTDOCS%%%%DOCSDIR%%/www/gm.html
-%%PORTDOCS%%%%DOCSDIR%%/www/header.html
-%%PORTDOCS%%%%DOCSDIR%%/www/identify.html
-%%PORTDOCS%%%%DOCSDIR%%/www/import.html
-%%PORTDOCS%%%%DOCSDIR%%/www/index.html
-%%PORTDOCS%%%%DOCSDIR%%/www/links.html
-%%PORTDOCS%%%%DOCSDIR%%/www/magick.css
-%%PORTDOCS%%%%DOCSDIR%%/www/miff.html
-%%PORTDOCS%%%%DOCSDIR%%/www/mission.html
-%%PORTDOCS%%%%DOCSDIR%%/www/mogrify.html
-%%PORTDOCS%%%%DOCSDIR%%/www/montage.html
-%%PORTDOCS%%%%DOCSDIR%%/www/motion-picture.html
-%%PORTDOCS%%%%DOCSDIR%%/www/perl.html
-%%PORTDOCS%%%%DOCSDIR%%/www/programming.html
-%%PORTDOCS%%%%DOCSDIR%%/www/quantize.html
-%%PORTDOCS%%%%DOCSDIR%%/www/smile.c
-%%PORTDOCS%%%%DOCSDIR%%/www/tools.html
-%%PORTDOCS%%%%DOCSDIR%%/www/utilities.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/www/api
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/www/Magick++
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/www
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/config
-@dirrm %%DATADIR%%
-@dirrm lib/GraphicsMagick/modules-Q%%Q%%/filters
-@dirrm lib/GraphicsMagick/modules-Q%%Q%%/coders
-@dirrm lib/GraphicsMagick/modules-Q%%Q%%
-@dirrm lib/GraphicsMagick/config
-@dirrm lib/GraphicsMagick
-@dirrm include/GraphicsMagick/wand
-@dirrm include/GraphicsMagick/magick
-@dirrm include/GraphicsMagick/Magick++
-@dirrm include/GraphicsMagick
-@exec mkdir -p %D/lib/GraphicsMagick/modules-Q%%Q%%/filters
-@exec mkdir -p %D/lib/GraphicsMagick/modules-Q%%Q%%/coders