aboutsummaryrefslogtreecommitdiff
path: root/graphics/GraphicsMagick13
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-21 10:34:00 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-21 10:34:00 +0000
commit9da829959cfcfbc4aaf3ef06c77600ad591f3e19 (patch)
tree2e0d0937751028bb0025bc76340d7a0d5b30e4a6 /graphics/GraphicsMagick13
parentfd1ffdc93084ef4f21cc4a76271c6a5d86a8554d (diff)
downloadports-9da829959cfcfbc4aaf3ef06c77600ad591f3e19.tar.gz
ports-9da829959cfcfbc4aaf3ef06c77600ad591f3e19.zip
Notes
Diffstat (limited to 'graphics/GraphicsMagick13')
-rw-r--r--graphics/GraphicsMagick13/Makefile2
-rw-r--r--graphics/GraphicsMagick13/files/patch-coders-png.c39
2 files changed, 40 insertions, 1 deletions
diff --git a/graphics/GraphicsMagick13/Makefile b/graphics/GraphicsMagick13/Makefile
index efa4d2373ad7..9de49a7b6454 100644
--- a/graphics/GraphicsMagick13/Makefile
+++ b/graphics/GraphicsMagick13/Makefile
@@ -7,7 +7,7 @@
PORTNAME= GraphicsMagick
PORTVERSION= 1.1.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/
diff --git a/graphics/GraphicsMagick13/files/patch-coders-png.c b/graphics/GraphicsMagick13/files/patch-coders-png.c
new file mode 100644
index 000000000000..f1a5ed6f8d36
--- /dev/null
+++ b/graphics/GraphicsMagick13/files/patch-coders-png.c
@@ -0,0 +1,39 @@
+--- coders/png.c.orig Thu Nov 11 07:14:54 2004
++++ coders/png.c Sun Aug 20 15:21:14 2006
+@@ -71,7 +71,7 @@
+ #include "magick/transform.h"
+ #include "magick/utility.h"
+ #if defined(HasPNG)
+-#include "png.h"
++#include "libpng/png.h"
+ #include "zlib.h"
+
+ #if PNG_LIBPNG_VER > 95
+@@ -1567,6 +1567,8 @@
+ num_passes,
+ pass;
+
++ png_structp png_ptr;
++
+ PixelPacket
+ transparent_color;
+
+@@ -1709,18 +1711,6 @@
+ #if defined(PNG_USE_PNGGCCRD) && defined(PNG_ASSEMBLER_CODE_SUPPORTED) \
+ && (PNG_LIBPNG_VER >= 10200)
+ /* Disable thread-unsafe features of pnggccrd */
+- if (png_access_version() >= 10200)
+- {
+- png_uint_32 mmx_disable_mask=0;
+- png_uint_32 asm_flags;
+-
+- mmx_disable_mask |= ( PNG_ASM_FLAG_MMX_READ_COMBINE_ROW \
+- | PNG_ASM_FLAG_MMX_READ_FILTER_SUB \
+- | PNG_ASM_FLAG_MMX_READ_FILTER_AVG \
+- | PNG_ASM_FLAG_MMX_READ_FILTER_PAETH );
+- asm_flags=png_get_asm_flags(png_ptr);
+- png_set_asm_flags(png_ptr, asm_flags & ~mmx_disable_mask);
+- }
+ #endif
+
+ png_read_info(ping,ping_info);