aboutsummaryrefslogtreecommitdiff
path: root/graphics/IPA
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-08-06 02:49:34 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-08-06 02:49:34 +0000
commita6342f310d6c454920a1d9160b1ed88181e3c0ec (patch)
tree8b069ef3388e24e8bd35e91263aa499574ef2050 /graphics/IPA
parent00e2c9ce587d309eaa11a782f1d67a32a52fe3d3 (diff)
downloadports-a6342f310d6c454920a1d9160b1ed88181e3c0ec.tar.gz
ports-a6342f310d6c454920a1d9160b1ed88181e3c0ec.zip
Notes
Diffstat (limited to 'graphics/IPA')
-rw-r--r--graphics/IPA/Makefile11
-rw-r--r--graphics/IPA/files/patch-Makefile.PL16
2 files changed, 20 insertions, 7 deletions
diff --git a/graphics/IPA/Makefile b/graphics/IPA/Makefile
index 080d86fbc7a7..a55e88010cd4 100644
--- a/graphics/IPA/Makefile
+++ b/graphics/IPA/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= http://www.prima.eu.org/IPA/ CPAN/Prima/KARASIK
MAINTAINER= ports@FreeBSD.org
COMMENT= Image Processing Algorithms
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Prima>1.24:x11-toolkits/p5-Prima
@@ -21,10 +24,4 @@ MAKE_JOBS_UNSAFE= yes
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/IPA/IPA.so
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 502600
-BROKEN= Does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/IPA/files/patch-Makefile.PL b/graphics/IPA/files/patch-Makefile.PL
new file mode 100644
index 000000000000..47cdce9ce2fc
--- /dev/null
+++ b/graphics/IPA/files/patch-Makefile.PL
@@ -0,0 +1,16 @@
+Fix regular expression match and build with MakeMaker >= 7.05_05 which adds a
+space between the target name and the operator.
+
+--- Makefile.PL.orig 2011-05-14 06:27:26 UTC
++++ Makefile.PL
+@@ -79,8 +79,8 @@ H
+ sub c_o
+ {
+ my $t = shift-> SUPER::c_o(@_);
+- unless ( $t =~ /.c\$\(OBJ_EXT\):\n\t.*\$\*\$\(OBJ_EXT\)/ ) {
+- $t =~ s/(\.c\$\(OBJ_EXT\):\n\t.*)/$1 $co\$*\$(OBJ_EXT)/;
++ unless ( $t =~ /\.c\$\(OBJ_EXT\)\s*:\n\t.*\Q\$\*\$\(OBJ_EXT\)\E/ ) {
++ $t =~ s/(\.c\$\(OBJ_EXT\)\s*:\n\t.*)/$1 $co\$*\$(OBJ_EXT)/;
+ }
+ return $t;
+ }