aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-07-19 13:08:38 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-07-19 13:08:38 +0000
commit25375e24c545b1d930b3839761e15ba50a38f5b2 (patch)
tree96ffad8ba400065c674e389353b03c538949af34 /graphics/ImageMagick/Makefile
parent145b1dce51a37041f8d697636ed40152d5201374 (diff)
Notes
Diffstat (limited to 'graphics/ImageMagick/Makefile')
-rw-r--r--graphics/ImageMagick/Makefile49
1 files changed, 23 insertions, 26 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 57694a455b40..3481831e9680 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ImageMagick
-PORTVERSION= 5.1.1
+PORTVERSION= 5.2.1
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_LOCAL} \
ftp://ftp.wizards.dupont.com/pub/ImageMagick/ \
@@ -19,42 +19,39 @@ MASTER_SITE_SUBDIR= jseger
MAINTAINER= jseger@FreeBSD.org
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= bz2.1:${PORTSDIR}/archivers/bzip2 \
df.1:${PORTSDIR}/graphics/hdf \
- tiff.4:${PORTSDIR}/graphics/tiff \
- png.4:${PORTSDIR}/graphics/png \
jbig.1:${PORTSDIR}/graphics/jbigkit \
- ttf.4:${PORTSDIR}/print/freetype
-
-# bzip2 for bzlib
-BUILD_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2 \
- fig2dev:${PORTSDIR}/print/transfig \
- picttoppm:${PORTSDIR}/graphics/netpbm \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.3:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ ttf.4:${PORTSDIR}/print/freetype \
+ xml.5:${PORTSDIR}/textproc/libxml2
+BUILD_DEPENDS= gs:${PORTSDIR}/print/ghostscript55 \
mpeg2decode:${PORTSDIR}/graphics/mpeg2codec \
- gs:${PORTSDIR}/print/ghostscript55
-
-MAN1= ImageMagick.1 animate.1 combine.1 convert.1 display.1 \
- identify.1 import.1 mogrify.1 montage.1
-MAN3= Image::Magick.3
-MAN4= miff.4
-MAN5= quantize.5
+ picttoppm:${PORTSDIR}/graphics/netpbm \
+ fig2dev:${PORTSDIR}/print/transfig
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+USE_PERL5= yes
+USE_XLIB= yes
+USE_LIBTOOL= yes
USE_AUTOCONF= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-shared --enable-16bit-pixel --without-modules \
+ --with-perl=${PERL5}
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} --enable-shared --with-perl=${PERL5} \
- --enable-16bit-pixel
-
.if defined(HAVE_UNISYS_LICENSE)
CONFIGURE_ARGS+= --enable-lzw
.endif
-USE_PERL5= YES
-USE_XLIB= YES
-CONFIGURE_ENV= LDFLAGS="$(LDFLAGS) -L${WRKSRC}/magick/.libs"
+MAN1= ImageMagick.1 animate.1 combine.1 convert.1 display.1 \
+ identify.1 import.1 mogrify.1 montage.1
+MAN3= Image::Magick.3
+MAN4= miff.4
+MAN5= quantize.5
-pre-configure:
- ${RM} -f ${WRKSRC}/config.cache
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.mk>