aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick6
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-11-20 16:56:57 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-11-20 16:56:57 +0000
commitc76f570dba4285027939889e7aec9c7d88479d61 (patch)
tree1a3e66a226e83e6d5bf66afc01982de9333751f5 /graphics/ImageMagick6
parent6c68e91ddc99b45b1763d5ae9be10e31f72bc177 (diff)
downloadports-c76f570dba4285027939889e7aec9c7d88479d61.tar.gz
ports-c76f570dba4285027939889e7aec9c7d88479d61.zip
Notes
Diffstat (limited to 'graphics/ImageMagick6')
-rw-r--r--graphics/ImageMagick6/Makefile1
-rw-r--r--graphics/ImageMagick6/files/patch-coders_icon.c24
-rw-r--r--graphics/ImageMagick6/files/patch-configure11
3 files changed, 36 insertions, 0 deletions
diff --git a/graphics/ImageMagick6/Makefile b/graphics/ImageMagick6/Makefile
index d5a2fcb56c73..323b71976eb9 100644
--- a/graphics/ImageMagick6/Makefile
+++ b/graphics/ImageMagick6/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ImageMagick
DISTVERSION= 6.9.10-14
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics perl5
MASTER_SITES= http://www.imagemagick.org/download/ \
diff --git a/graphics/ImageMagick6/files/patch-coders_icon.c b/graphics/ImageMagick6/files/patch-coders_icon.c
new file mode 100644
index 000000000000..3b5c1f5dec4a
--- /dev/null
+++ b/graphics/ImageMagick6/files/patch-coders_icon.c
@@ -0,0 +1,24 @@
+From e08e321e2a763325329e5c4748ef374ec9e3b76a Mon Sep 17 00:00:00 2001
+From: Cristy <urban-warrior@imagemagick.org>
+Date: Sun, 18 Nov 2018 17:40:50 -0500
+Subject: [PATCH] https://github.com/ImageMagick/ImageMagick/issues/1386
+
+---
+ coders/icon.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/coders/icon.c b/coders/icon.c
+index 5f4657f6f..c9b748d77 100644
+--- coders/icon.c
++++ coders/icon.c
+@@ -372,8 +372,8 @@ static Image *ReadICONImage(const ImageInfo *image_info,
+ png[13]=(unsigned char) (icon_info.planes >> 8);
+ png[14]=(unsigned char) icon_info.bits_per_pixel;
+ png[15]=(unsigned char) (icon_info.bits_per_pixel >> 8);
+- count=ReadBlob(image,length,png+16);
+- if (count != (ssize_t) length)
++ count=ReadBlob(image,length-16,png+16);
++ if (count != (ssize_t) (length-16))
+ {
+ png=(unsigned char *) RelinquishMagickMemory(png);
+ ThrowReaderException(CorruptImageError,
diff --git a/graphics/ImageMagick6/files/patch-configure b/graphics/ImageMagick6/files/patch-configure
new file mode 100644
index 000000000000..8487ba21adc6
--- /dev/null
+++ b/graphics/ImageMagick6/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2018-11-20 17:30:00.562966000 +0100
++++ configure 2018-11-20 17:30:07.703770000 +0100
+@@ -36930,7 +36930,7 @@
+ MAGICK_CPPFLAGS=`echo $MAGICK_CPPFLAGS | sed -e 's/ */ /g'`
+ MAGICK_PCFLAGS=`echo $MAGICK_PCFLAGS | sed -e 's/ */ /g'`
+ MAGICK_LDFLAGS="-L$LIB_DIR $LDFLAGS"
+-MAGICK_LIBS="$MAGICK_DEP_LIBS MAGICK_EXTRA_DEP_LIBS"
++MAGICK_LIBS="$MAGICK_DEP_LIBS $MAGICK_EXTRA_DEP_LIBS"
+
+
+