aboutsummaryrefslogtreecommitdiff
path: root/graphics/OpenEXR
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-08-15 20:37:31 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-08-15 20:37:31 +0000
commit515db2ed104a7de4ffb582600576cfa5136637cc (patch)
tree3c1641f7451c72c9a9f849082551388e5ddbe65a /graphics/OpenEXR
parente55c717cb08120ba9ecda980d27c3ddc87d94f95 (diff)
downloadports-515db2ed104a7de4ffb582600576cfa5136637cc.tar.gz
ports-515db2ed104a7de4ffb582600576cfa5136637cc.zip
Upgrade OpenEXR and ilmbase to 2.2.0.
GCC 4.2 in FreeBSD 8.X/9.X base is now too old to compile OpenEXR, so GCC-based systems will upgrade to the default ports compiler (GCC 4.7 currently.) Add two patches to OpenEXR to permit building it in a live system with the older OpenEXR version installed. Bug report filed to upstream Github at https://github.com/openexr/openexr/issues/130 Couple OpenEXR more tightly to ilmbase and require its exact .so version. Add UPDATING note, and bump PORTREVISION of all dependent ports. Proto-STAGE hugin-devel, and mark it IGNORE because hugin is newer. Approved by: portmgr (implicit for bumping PORTREVISION on unstaged ports)
Notes
Notes: svn path=/head/; revision=365038
Diffstat (limited to 'graphics/OpenEXR')
-rw-r--r--graphics/OpenEXR/Makefile27
-rw-r--r--graphics/OpenEXR/distinfo4
-rw-r--r--graphics/OpenEXR/files/patch-IlmImfUtil__Makefile.in16
-rw-r--r--graphics/OpenEXR/files/patch-IlmImf__Makefile.in15
-rw-r--r--graphics/OpenEXR/pkg-plist10
5 files changed, 58 insertions, 14 deletions
diff --git a/graphics/OpenEXR/Makefile b/graphics/OpenEXR/Makefile
index adcb84291c86..d03e16cb799c 100644
--- a/graphics/OpenEXR/Makefile
+++ b/graphics/OpenEXR/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= OpenEXR
-PORTVERSION= 2.1.0
-PORTREVISION= 3
+PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= SAVANNAH/openexr/
DISTNAME= openexr-${DISTVERSION}
@@ -13,7 +13,8 @@ COMMENT= High dynamic-range (HDR) image file format
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libImath.so:${PORTSDIR}/graphics/ilmbase
+# exact version required to avoid hard-to-debug issues
+LIB_DEPENDS= libImath-2_2.so.12:${PORTSDIR}/graphics/ilmbase
WRKSRC= ${WRKDIR}/${DISTNAME}
@@ -21,6 +22,7 @@ USES= compiler:features gmake libtool:keepla pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-ilmbasetest --enable-imfexamples
USE_LDCONFIG= yes
+CPPFLAGS+= -I. -I../IlmImf
# must be linked with -l{thr|pthread} explicitly
LDFLAGS+= ${PTHREAD_LIBS}
@@ -42,10 +44,17 @@ OPTIONS_SUB= yes
LARGE_STACK_CONFIGURE_ENABLE= large-stack
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-MAJORVER= 2_1
-VER= 21
+# If default compiler is GCC, upgrade it because
+# g++ 4.2 is too old to auto-upgrade 0xffffffffffffffffl to
+# a long long integer constant - and has likely more issues.
+.if ${COMPILER_TYPE} == gcc
+USE_GCC= yes
+.endif
+
+MAJORVER= 2_2
+VER= 22
PLIST_SUB= MAJORVER=${MAJORVER}
PLIST_SUB+= VER=${VER}
@@ -59,7 +68,7 @@ post-patch:
-e 's|$$(EXTRA_DIST)||' \
${WRKSRC}/doc/Makefile.am ${WRKSRC}/doc/Makefile.in
-# too many reports about compileration failures, so sanity check C++
+# too many reports about compilation failures, so sanity check C++
# library
_ilm_libcxx=${COMPILER_FEATURES:Mlib*c++}
pre-configure:
@@ -79,11 +88,11 @@ regression-test regression test check: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libIlmImf-Imf_${MAJORVER}.so.${VER}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libIlmImf-${MAJORVER}.so.${VER}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR2}
${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/OpenEXR/distinfo b/graphics/OpenEXR/distinfo
index 6f5394f5cb53..e7081c4279cd 100644
--- a/graphics/OpenEXR/distinfo
+++ b/graphics/OpenEXR/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openexr-2.1.0.tar.gz) = 54486b454073c1dcb5ae9892cf0f730ffefe62f38176325281505093fd218a14
-SIZE (openexr-2.1.0.tar.gz) = 13680816
+SHA256 (openexr-2.2.0.tar.gz) = 36a012f6c43213f840ce29a8b182700f6cf6b214bea0d5735594136b44914231
+SIZE (openexr-2.2.0.tar.gz) = 14489661
diff --git a/graphics/OpenEXR/files/patch-IlmImfUtil__Makefile.in b/graphics/OpenEXR/files/patch-IlmImfUtil__Makefile.in
new file mode 100644
index 000000000000..f874a4f6603e
--- /dev/null
+++ b/graphics/OpenEXR/files/patch-IlmImfUtil__Makefile.in
@@ -0,0 +1,16 @@
+--- ./IlmImfUtil/Makefile.in.orig 2014-08-15 19:35:57.000000000 +0200
++++ ./IlmImfUtil/Makefile.in 2014-08-15 19:45:15.000000000 +0200
+@@ -265,10 +265,11 @@
+ libIlmImfUtil_la_LIBADD = -L$(top_builddir)/IlmImf @ILMBASE_LIBS@ -lIlmImf
+ libIlmImfUtilincludedir = $(includedir)/OpenEXR
+ EXTRA_DIST = CMakeLists.txt
+-INCLUDES = @ILMBASE_CXXFLAGS@ \
++INCLUDES = \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/IlmImf \
+- -I$(top_srcdir)/config
++ -I$(top_srcdir)/config \
++ @ILMBASE_CXXFLAGS@
+
+ all: all-am
+
diff --git a/graphics/OpenEXR/files/patch-IlmImf__Makefile.in b/graphics/OpenEXR/files/patch-IlmImf__Makefile.in
new file mode 100644
index 000000000000..2a259498124b
--- /dev/null
+++ b/graphics/OpenEXR/files/patch-IlmImf__Makefile.in
@@ -0,0 +1,15 @@
+--- ./IlmImf/Makefile.in.orig 2014-08-15 19:35:57.000000000 +0200
++++ ./IlmImf/Makefile.in 2014-08-15 19:45:43.000000000 +0200
+@@ -458,9 +458,10 @@
+ ImfOptimizedPixelReading.h
+
+ EXTRA_DIST = $(noinst_HEADERS) b44ExpLogTable.cpp b44ExpLogTable.h dwaLookups.cpp dwaLookups.h CMakeLists.txt
+-INCLUDES = @ILMBASE_CXXFLAGS@ \
++INCLUDES = \
+ -I$(top_builddir) \
+- -I$(top_srcdir)/config
++ -I$(top_srcdir)/config \
++ @ILMBASE_CXXFLAGS@
+
+ CLEANFILES = b44ExpLogTable b44ExpLogTable.h dwaLookups dwaLookups.h
+ b44ExpLogTable_SOURCES = b44ExpLogTable.cpp
diff --git a/graphics/OpenEXR/pkg-plist b/graphics/OpenEXR/pkg-plist
index cc540bf2b53a..e1804528b905 100644
--- a/graphics/OpenEXR/pkg-plist
+++ b/graphics/OpenEXR/pkg-plist
@@ -92,11 +92,15 @@ include/OpenEXR/ImfVersion.h
include/OpenEXR/ImfWav.h
include/OpenEXR/ImfXdr.h
include/OpenEXR/OpenEXRConfig.h
-lib/libIlmImf-Imf_%%MAJORVER%%.so.%%VER%%
-lib/libIlmImf-Imf_%%MAJORVER%%.so.%%VER%%.0.0
+lib/libIlmImf-%%MAJORVER%%.so.%%VER%%
+lib/libIlmImf-%%MAJORVER%%.so.%%VER%%.0.0
lib/libIlmImf.a
lib/libIlmImf.la
lib/libIlmImf.so
+lib/libIlmImfUtil-%%MAJORVER%%.so.22
+lib/libIlmImfUtil-%%MAJORVER%%.so.22.0.0
+lib/libIlmImfUtil.a
+lib/libIlmImfUtil.la
+lib/libIlmImfUtil.so
libdata/pkgconfig/OpenEXR.pc
share/aclocal/openexr.m4
-@dirrmtry include/OpenEXR