aboutsummaryrefslogtreecommitdiff
path: root/graphics/OpenEXR
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-10 23:03:35 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-10 23:03:35 +0000
commite1652f1472958fefa0b27019729387731ffc0e49 (patch)
treefd1b2ac2aee6ef5e2e8494754171d3c8f19ebe92 /graphics/OpenEXR
parent67d519d830e0e1fb471e2f5f0919d263d8e1e311 (diff)
downloadports-e1652f1472958fefa0b27019729387731ffc0e49.tar.gz
ports-e1652f1472958fefa0b27019729387731ffc0e49.zip
- Fix build with GCC 45
- Bump PORTREVISION PR: ports/148990 Submitted by: Anonymous <swell.k@gmail.com> Approved by: maintainer timeout (nork ; 136 days)
Notes
Notes: svn path=/head/; revision=266014
Diffstat (limited to 'graphics/OpenEXR')
-rw-r--r--graphics/OpenEXR/Makefile2
-rw-r--r--graphics/OpenEXR/files/patch-exrenvmap-main.cpp10
-rw-r--r--graphics/OpenEXR/files/patch-exrmaketiled-main.cpp10
3 files changed, 21 insertions, 1 deletions
diff --git a/graphics/OpenEXR/Makefile b/graphics/OpenEXR/Makefile
index 65a055d8dddc..04a1135f9eac 100644
--- a/graphics/OpenEXR/Makefile
+++ b/graphics/OpenEXR/Makefile
@@ -7,7 +7,7 @@
PORTNAME= OpenEXR
PORTVERSION= 1.6.1
-PORTREVISION= 2
+PORTREVISION= 3
DISTNAME= ${PORTNAME:L}-${PORTVERSION}
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
diff --git a/graphics/OpenEXR/files/patch-exrenvmap-main.cpp b/graphics/OpenEXR/files/patch-exrenvmap-main.cpp
new file mode 100644
index 000000000000..cef2bf088a59
--- /dev/null
+++ b/graphics/OpenEXR/files/patch-exrenvmap-main.cpp
@@ -0,0 +1,10 @@
+--- exrenvmap/main.cpp~
++++ exrenvmap/main.cpp
+@@ -43,6 +43,7 @@
+ #include <makeLatLongMap.h>
+ #include <ImfEnvmap.h>
+ #include <iostream>
++#include <cstring>
+ #include <exception>
+ #include <stdlib.h>
+
diff --git a/graphics/OpenEXR/files/patch-exrmaketiled-main.cpp b/graphics/OpenEXR/files/patch-exrmaketiled-main.cpp
new file mode 100644
index 000000000000..d72c07e3aeee
--- /dev/null
+++ b/graphics/OpenEXR/files/patch-exrmaketiled-main.cpp
@@ -0,0 +1,10 @@
+--- exrmaketiled/main.cpp~
++++ exrmaketiled/main.cpp
+@@ -44,6 +44,7 @@
+
+ #include <iostream>
+ #include <exception>
++#include <cstring>
+ #include <string>
+ #include <stdlib.h>
+