aboutsummaryrefslogtreecommitdiff
path: root/graphics/R-cran-rgdal
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-02-11 01:45:46 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-02-11 01:45:46 +0000
commit8b5cfab87d148238e68415ffbd4f579447a9dae9 (patch)
tree4e0b47f6bd9811b0424d2e249475058dc3fe41c1 /graphics/R-cran-rgdal
parent86c1a8911c9fdb4639155116c592d9f5cbeaaedf (diff)
Notes
Diffstat (limited to 'graphics/R-cran-rgdal')
-rw-r--r--graphics/R-cran-rgdal/Makefile26
-rw-r--r--graphics/R-cran-rgdal/distinfo2
-rw-r--r--graphics/R-cran-rgdal/pkg-descr10
3 files changed, 38 insertions, 0 deletions
diff --git a/graphics/R-cran-rgdal/Makefile b/graphics/R-cran-rgdal/Makefile
new file mode 100644
index 000000000000..99a9e9ed9c13
--- /dev/null
+++ b/graphics/R-cran-rgdal/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: R-cran-rgdal
+# Date created: 2012-01-04
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rgdal
+DISTVERSION= 0.7-8
+CATEGORIES= graphics
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Bindings for the Geospatial Data Abstraction Library
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+LIB_DEPENDS= gdal.16:${PORTSDIR}/graphics/gdal \
+ proj.6:${PORTSDIR}/graphics/proj
+RUN_DEPENDS= R-cran-sp>=0.9.60:${PORTSDIR}/math/R-cran-sp
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/R-cran-rgdal/distinfo b/graphics/R-cran-rgdal/distinfo
new file mode 100644
index 000000000000..8d7fb86dde62
--- /dev/null
+++ b/graphics/R-cran-rgdal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rgdal_0.7-8.tar.gz) = 063cbb688970d840c8e9f5388e9516ca8c5620f649a261489c7faaffa2e614fe
+SIZE (rgdal_0.7-8.tar.gz) = 1427851
diff --git a/graphics/R-cran-rgdal/pkg-descr b/graphics/R-cran-rgdal/pkg-descr
new file mode 100644
index 000000000000..5bb8bb498b2f
--- /dev/null
+++ b/graphics/R-cran-rgdal/pkg-descr
@@ -0,0 +1,10 @@
+Provides bindings to Frank Warmerdam's Geospatial Data Abstraction
+Library (GDAL) (>= 1.3.1) and access to projection/transformation
+operations from the PROJ.4 library. The GDAL and PROJ.4 libraries
+are external to the package, and, when installing the package from
+source, must be correctly installed first. Both GDAL raster and OGR
+vector map data can be imported into R, and GDAL raster data and
+OGR vector data exported. Use is made of classes defined in the sp
+package.
+
+WWW: http://cran.r-project.org/web/packages/rgdal/