aboutsummaryrefslogtreecommitdiff
path: root/graphics/aaphoto
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/aaphoto
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
Notes
Diffstat (limited to 'graphics/aaphoto')
-rw-r--r--graphics/aaphoto/Makefile3
-rw-r--r--graphics/aaphoto/files/patch-aaphoto.c10
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/aaphoto/Makefile b/graphics/aaphoto/Makefile
index cde5ed737a0b..fef5fcac9f8e 100644
--- a/graphics/aaphoto/Makefile
+++ b/graphics/aaphoto/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aaphoto
PORTVERSION= 0.41
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://log69.com/downloads/
DISTNAME= ${PORTNAME}_sources_v${PORTVERSION}
@@ -16,7 +17,7 @@ COMMENT= Auto Adjust Photo, automatic color correction of photos
LIB_DEPENDS= jasper:${PORTSDIR}/graphics/jasper \
jpeg:${PORTSDIR}/graphics/jpeg \
- png:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
LICENSE= GPLv3
diff --git a/graphics/aaphoto/files/patch-aaphoto.c b/graphics/aaphoto/files/patch-aaphoto.c
new file mode 100644
index 000000000000..adb518502a76
--- /dev/null
+++ b/graphics/aaphoto/files/patch-aaphoto.c
@@ -0,0 +1,10 @@
+--- aaphoto.c.orig 2011-01-26 16:39:58.000000000 +0100
++++ aaphoto.c 2012-04-23 19:07:00.000000000 +0200
+@@ -243,6 +243,7 @@
+ #ifndef __BMP_ONLY__
+ #include <jasper/jasper.h>
+ #include <png.h>
++#include <zlib.h>
+ #include <jpeglib.h>
+ #endif
+