aboutsummaryrefslogtreecommitdiff
path: root/graphics/aaphoto
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2010-07-20 14:35:18 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2010-07-20 14:35:18 +0000
commiteaa89f59ac83f83a0f0fdc002a9131551a3721f2 (patch)
treecc00b7aae0d4d56954417bfac2dd399e4232c670 /graphics/aaphoto
parenteab148937915b352d491a9420edf0f5928a59022 (diff)
downloadports-eaa89f59ac83f83a0f0fdc002a9131551a3721f2.tar.gz
ports-eaa89f59ac83f83a0f0fdc002a9131551a3721f2.zip
Notes
Diffstat (limited to 'graphics/aaphoto')
-rw-r--r--graphics/aaphoto/Makefile12
-rw-r--r--graphics/aaphoto/distinfo6
-rw-r--r--graphics/aaphoto/files/patch-Makefile.in2
3 files changed, 9 insertions, 11 deletions
diff --git a/graphics/aaphoto/Makefile b/graphics/aaphoto/Makefile
index 277dbd739876..353eca4dbd7b 100644
--- a/graphics/aaphoto/Makefile
+++ b/graphics/aaphoto/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= aaphoto
-PORTVERSION= 0.37
-PORTREVISION= 1
+PORTVERSION= 0.38
CATEGORIES= graphics
MASTER_SITES= http://log69.com/downloads/
DISTNAME= ${PORTNAME}_sources_v${PORTVERSION}
@@ -19,6 +18,9 @@ LIB_DEPENDS= jasper:${PORTSDIR}/graphics/jasper \
jpeg:${PORTSDIR}/graphics/jpeg \
png:${PORTSDIR}/graphics/png
+LICENSE= GPLv3
+
+USE_AUTOTOOLS= autoheader:262
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -31,11 +33,7 @@ PORTDOCS= AUTHORS ChangeLog COPYING COPYRIGHT INSTALL LICENSE \
.include <bsd.port.pre.mk>
-.if ${ARCH} != "amd64" && ${ARCH} != "i386"
-BROKEN= Does not compile on !amd64 and !i386
-.endif
-
-.if ${OSVERSION} >= 700000
+.if ${ARCH} == "amd64" || ${ARCH} == "i386" && ${OSVERSION} >= 700000
CFLAGS+= -fopenmp -D__OPENMP__
.endif
diff --git a/graphics/aaphoto/distinfo b/graphics/aaphoto/distinfo
index e598875edcd3..be1a696b17ba 100644
--- a/graphics/aaphoto/distinfo
+++ b/graphics/aaphoto/distinfo
@@ -1,3 +1,3 @@
-MD5 (aaphoto_sources_v0.37.tar.gz) = f9cfaf7112713cb937f7b3ac1236d077
-SHA256 (aaphoto_sources_v0.37.tar.gz) = 2efe35c406ea5bd0b8a05a6eab02437c6b3eefbff38d4d74c0f200023c4f7ae4
-SIZE (aaphoto_sources_v0.37.tar.gz) = 134442
+MD5 (aaphoto_sources_v0.38.tar.gz) = 99c07a650eda444e753cb611dd0c9d36
+SHA256 (aaphoto_sources_v0.38.tar.gz) = e2a4de457d957bb80925beb18c79b4128982941dec24f506dfa2d495830ce63e
+SIZE (aaphoto_sources_v0.38.tar.gz) = 134661
diff --git a/graphics/aaphoto/files/patch-Makefile.in b/graphics/aaphoto/files/patch-Makefile.in
index eefb2448c794..da8f0fa6204f 100644
--- a/graphics/aaphoto/files/patch-Makefile.in
+++ b/graphics/aaphoto/files/patch-Makefile.in
@@ -5,7 +5,7 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-AM_CFLAGS = -Wall -O2 -D__OPENMP__ -fopenmp
-+AM_CFLAGS = -Wall -O2 -Wno-unknown-pragmas
++AM_CFLAGS = -Wall -O2
AM_LDFLAGS = -ljasper -ljpeg -lpng -lm
aaphoto_SOURCES = aaphoto.c
INCLUDES =