aboutsummaryrefslogtreecommitdiff
path: root/graphics/ale/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-17 04:15:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-12-17 04:15:52 +0000
commit62bfc3bd0579501e4c7b04be1ae551abb08e0f39 (patch)
tree3d42b98f0c2fc515c47d3f3263c4409755cd2f99 /graphics/ale/Makefile
parent042d621d2e24fb50b4d3f0b66bb4a4f04bd2e47f (diff)
Notes
Diffstat (limited to 'graphics/ale/Makefile')
-rw-r--r--graphics/ale/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/ale/Makefile b/graphics/ale/Makefile
new file mode 100644
index 000000000000..1f7b826abd7f
--- /dev/null
+++ b/graphics/ale/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection Makefile for: ale
+# Date created: Dec 17, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ale
+PORTVERSION= 0.5.1
+CATEGORIES= graphics
+MASTER_SITES= http://auricle.dyndns.org/ALE/download/
+PATCH_SITES= http://auricle.dyndns.org/ALE/bugs/
+PATCHFILES= 0.5.1.patch1 0.5.1.patch2
+PATCH_DIST_ARGS= -p1 -d ${PATCH_WRKSRC}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Anti-Lamenessing Engine
+
+USE_GCC= 3.1
+USE_GMAKE= yes
+
+.if !defined(WITHOUT_IMAGEMAGICK)
+LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick
+MAKE_ARGS= IMAGEMAGICK=1
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ale ${PREFIX}/bin
+
+.include <bsd.port.mk>