aboutsummaryrefslogtreecommitdiff
path: root/graphics/allegrogl/files
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-09-09 16:27:45 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-09-09 16:27:45 +0000
commit0b6c2e4bbe42b6ae3f186943dd9bfc524c89c99b (patch)
tree5589ac90f1b17bfddba85559ad7ead6a04b23e35 /graphics/allegrogl/files
parent4d40bb0bce2472d4b63f03336fbc8619436621c9 (diff)
Notes
Diffstat (limited to 'graphics/allegrogl/files')
-rw-r--r--graphics/allegrogl/files/makefile.ex9
-rw-r--r--graphics/allegrogl/files/patch-configure.in35
-rw-r--r--graphics/allegrogl/files/patch-make-makefile.unx39
3 files changed, 6 insertions, 77 deletions
diff --git a/graphics/allegrogl/files/makefile.ex b/graphics/allegrogl/files/makefile.ex
index d57b505d15ad..0c32c4be6287 100644
--- a/graphics/allegrogl/files/makefile.ex
+++ b/graphics/allegrogl/files/makefile.ex
@@ -1,10 +1,10 @@
CC= %%CC%%
RM= %%RM%%
-CFLAGS= %%CFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include/
+CFLAGS= %%CFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include
LDFLAGS= -L%%X11BASE%%/lib -L%%PREFIX%%/lib -lagl -lGL -lGLU
-ALLEGRO_CFLAGS!=%%ALLEGRO_CONFIG%% --cflags
-ALLEGRO_LFLAGS!=%%ALLEGRO_CONFIG%% --libs
+ALLEGRO_CFLAGS!=allegro-config --cflags
+ALLEGRO_LFLAGS!=allegro-config --libs
CFLAGS+= ${ALLEGRO_CFLAGS}
LDFLAGS+= ${ALLEGRO_LFLAGS}
@@ -37,6 +37,9 @@ exgui: exgui.o
exmasked: exmasked.o
${CC} $> -o $@ ${LDFLAGS}
+exmipmaps: exmipmaps.o
+ ${CC} $> -o $@ ${LDFLAGS}
+
extext: extext.o
${CC} $> -o $@ ${LDFLAGS}
diff --git a/graphics/allegrogl/files/patch-configure.in b/graphics/allegrogl/files/patch-configure.in
deleted file mode 100644
index 7b6358d76661..000000000000
--- a/graphics/allegrogl/files/patch-configure.in
+++ /dev/null
@@ -1,35 +0,0 @@
---- configure.in.orig Sat Feb 21 19:38:28 2004
-+++ configure.in Sat Mar 20 07:14:42 2004
-@@ -52,7 +52,7 @@
-
- dnl Check for pthread support, which GL libs may require (e.g. FreeBSD)
- AC_CHECK_HEADER(pthread.h, , dontcare=y)
--AC_CHECK_LIB(pthread, pthread_create, LIBS="-lpthread $LIBS")
-+AC_CHECK_LIB(pthread, pthread_create, LIBS="%%PTHREAD_LIBS%% $LIBS")
-
-
- dnl Build Mesa generic driver
-@@ -171,14 +171,14 @@
- dnl the Mesa generic driver and the (hopefully) accelerated one
- if test -f makefile; then
- echo '# Remove older build'
-- make veryclean
-+ %%GMAKE%% veryclean
- agl_make_depend="yes";
- fi
-
-
- dnl If dependencies are not built yet then do it !
- if (test ! -f make/makefile.dep); then
-- echo '# Execute "make depend".' > make/makefile.dep
-+ echo '# Execute "%%GMAKE%% depend".' > make/makefile.dep
- agl_make_depend="yes";
- fi
-
-@@ -189,5 +189,5 @@
-
- dnl Run "make depend" if necessary
- if test -n "$agl_make_depend"; then
-- make depend
-+ %%GMAKE%% depend
- fi
diff --git a/graphics/allegrogl/files/patch-make-makefile.unx b/graphics/allegrogl/files/patch-make-makefile.unx
deleted file mode 100644
index f1117dbfaffb..000000000000
--- a/graphics/allegrogl/files/patch-make-makefile.unx
+++ /dev/null
@@ -1,39 +0,0 @@
---- make/makefile.unx.orig Sat Feb 21 18:25:06 2004
-+++ make/makefile.unx Fri Mar 26 20:55:17 2004
-@@ -18,7 +18,7 @@
- # Programs
- CC = @CC@
- CXX = @CXX@
--INSTALLER = @INSTALL@ -D -m 644
-+INSTALLER = @INSTALL@ -m 644
-
-
- # Where to install the library and header file
-@@ -49,13 +49,13 @@
- # --- Compiler optimizations ---#
-
- ifdef DEBUGMODE
-- CFLAGS = -g -W -Wall -Wno-unused
-+ CFLAGS += -g -W -Wall -Wno-unused
- CFLAGS += -DDEBUGMODE=$(DEBUGMODE)
- ifdef LOGLEVEL
- CFLAGS += -DLOGLEVEL=$(LOGLEVEL)
- endif
- else
-- CFLAGS = -O2 -Wall -ffast-math -fomit-frame-pointer
-+ CFLAGS += -O2 -Wall -ffast-math -fomit-frame-pointer
- endif
-
- ifdef SHARED
-@@ -65,9 +65,9 @@
- endif
-
- ifdef DEBUGALLEG
-- LDLIBS += `allegro-config --libs debug` $(LIBS)
-+ LDLIBS += `%%ALLEGRO_CONFIG%% --libs debug` $(LIBS)
- else
-- LDLIBS += `allegro-config --libs` $(LIBS)
-+ LDLIBS += `%%ALLEGRO_CONFIG%% --libs` $(LIBS)
- endif
-
- ifdef MESABUILD