aboutsummaryrefslogtreecommitdiff
path: root/graphics/alpng/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-08-01 21:38:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-08-01 21:38:39 +0000
commitd370d5d7d4947d74cd9ea9454e4268ca151e448b (patch)
tree1c12ab3f11d62cf457636543510bc04cc2855fc8 /graphics/alpng/Makefile
parentdcc596b5a67688cc7056fbfa1f0994e32c515951 (diff)
downloadports-d370d5d7d4947d74cd9ea9454e4268ca151e448b.tar.gz
ports-d370d5d7d4947d74cd9ea9454e4268ca151e448b.zip
Notes
Diffstat (limited to 'graphics/alpng/Makefile')
-rw-r--r--graphics/alpng/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/graphics/alpng/Makefile b/graphics/alpng/Makefile
index be40b14ce293..e29e3b3459bb 100644
--- a/graphics/alpng/Makefile
+++ b/graphics/alpng/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: graphics/alpng
-# Date created: 27 Aug 2009
-# Whom: Stas Timokhin <stast@bsdportal.ru>
-#
+# Created by: Stas Timokhin <stast@bsdportal.ru>
# $FreeBSD$
-#
PORTNAME= alpng
PORTVERSION= 1.3
@@ -20,12 +16,16 @@ LIB_DEPENDS+= alleg:${PORTSDIR}/devel/allegro
HAS_CONFIGURE= yes
WRKSRC= ${WRKDIR}
MAKEFILE= makefile
-USE_GMAKE= yes
+USES= gmake
+MAKE_ARGS= CC=${CC}
CFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= include/alpng.h \
lib/libalpng.a
+do-configure:
+ @${REINPLACE_CMD} -e "s/gcc/${CC}/g" ${WRKSRC}/makefile
+
do-install:
${INSTALL_DATA} ${WRKSRC}/libalpng.a ${PREFIX}/lib/libalpng.a
${INSTALL_DATA} ${WRKSRC}/src/alpng.h ${PREFIX}/include/alpng.h