aboutsummaryrefslogtreecommitdiff
path: root/graphics/amanith
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-03 14:32:53 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-03 14:32:53 +0000
commit501ee1a225ebd482617c1b9eb8129c97450ffbce (patch)
treee9c8ddbc1fd5bcba81518e503dcabda9057455b8 /graphics/amanith
parent4c0231cdfed617cef5aae795a8c812613c236c52 (diff)
Notes
Diffstat (limited to 'graphics/amanith')
-rw-r--r--graphics/amanith/Makefile73
-rw-r--r--graphics/amanith/distinfo3
-rw-r--r--graphics/amanith/files/patch-plugins-fonts_build.conf11
-rw-r--r--graphics/amanith/files/patch-plugins-jpeg_build.conf11
-rw-r--r--graphics/amanith/files/patch-plugins-png_build.conf11
-rw-r--r--graphics/amanith/pkg-descr17
-rw-r--r--graphics/amanith/pkg-plist80
7 files changed, 206 insertions, 0 deletions
diff --git a/graphics/amanith/Makefile b/graphics/amanith/Makefile
new file mode 100644
index 000000000000..ac166b381ca8
--- /dev/null
+++ b/graphics/amanith/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: amanith
+# Date created: 2006-09-01
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amanith
+PORTVERSION= 0.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.amanith.org/download/files/ \
+ http://louhi.kempele.fi/~skyostil/projects/pyamanith/dist/
+DISTNAME= ${PORTNAME:S/$/_/}${PORTVERSION:S/.//}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= C++ CrossPlatform framework designed for 2d & 3d vector graphics
+
+BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ freetype.9:${PORTSDIR}/print/freetype2
+
+USE_GCC= 3.4+
+USE_QT_VER= 3
+USE_XLIB= yes
+USE_GL= yes
+USE_GMAKE= yes
+USE_DOS2UNIX= yes
+USE_LDCONFIG= yes
+
+MAKE_ENV= QTDIR="${LOCALBASE}" \
+ QMAKESPEC="${QMAKESPEC}" \
+ AMANITHDIR="${AMANITHDIR}"
+
+QMAKESPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+QMAKECMD= qmake
+AMANITHDIR= ${WRKSRC}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not build on FreeBSD 4.x
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -i "" -e 's|3rdpart||' ${WRKSRC}/amanith.pro
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKECMD} ${WRKSRC}/amanith.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/libamanith.so.1.0.0 ${PREFIX}/lib/libamanith.so.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/plugins/libfontimpexp.so.1.0.0 ${PREFIX}/lib/libfontimpexp.so.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/plugins/libjpegimpexp.so.1.0.0 ${PREFIX}/lib/libjpegimpexp.so.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/plugins/libpngimpexp.so.1.0.0 ${PREFIX}/lib/libpngimpexp.so.1
+
+. for FILE in libamanith libfontimpexp libjpegimpexp libpngimpexp
+ cd ${PREFIX}/lib && \
+ ${LN} -s ${FILE}.so.1 ${FILE}.so
+. endfor
+
+ ${MKDIR} ${PREFIX}/include/${PORTNAME}
+ cd ${WRKSRC}/include/${PORTNAME} && \
+ ${FIND} * -type d -exec ${MKDIR} "${PREFIX}/include/${PORTNAME}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${PREFIX}/include/${PORTNAME}/{}" \;
+
+. for DIRE in fonts jpeg png
+ cd ${WRKSRC}/plugins/${DIRE} && \
+ ${INSTALL_DATA} *.h ${PREFIX}/include/${PORTNAME}
+. endfor
+
+.include <bsd.port.post.mk>
diff --git a/graphics/amanith/distinfo b/graphics/amanith/distinfo
new file mode 100644
index 000000000000..3dd6019a2e81
--- /dev/null
+++ b/graphics/amanith/distinfo
@@ -0,0 +1,3 @@
+MD5 (amanith_03.tar.gz) = 392e79d36cc2d57921c7fefacbc4d4a3
+SHA256 (amanith_03.tar.gz) = 2e92dde6e56abef0f5146fd61ad0310e176d25578673353afe4def99c6bdaa1a
+SIZE (amanith_03.tar.gz) = 7688202
diff --git a/graphics/amanith/files/patch-plugins-fonts_build.conf b/graphics/amanith/files/patch-plugins-fonts_build.conf
new file mode 100644
index 000000000000..d41e547e433e
--- /dev/null
+++ b/graphics/amanith/files/patch-plugins-fonts_build.conf
@@ -0,0 +1,11 @@
+--- plugins/fonts/build.conf Fri Sep 1 21:11:18 2006
++++ plugins/fonts/build.conf Fri Sep 1 21:14:46 2006
+@@ -40,7 +40,7 @@
+
+ INCLUDEPATH += $$(AMANITHDIR)/3rdpart/freetype2/include
+
+-unix: LIBS += $$(AMANITHDIR)/lib/libfreetype2.a $$(AMANITHDIR)/lib/libzlib.a
++unix: LIBS += $(LOCALBASE)/lib/libfreetype.so /usr/lib/libz.so
+ win32: {
+
+ !contains(DEFINES, WIN32_MINGW) {
diff --git a/graphics/amanith/files/patch-plugins-jpeg_build.conf b/graphics/amanith/files/patch-plugins-jpeg_build.conf
new file mode 100644
index 000000000000..28f35851c0f2
--- /dev/null
+++ b/graphics/amanith/files/patch-plugins-jpeg_build.conf
@@ -0,0 +1,11 @@
+--- plugins/jpeg/build.conf Fri Sep 1 21:12:42 2006
++++ plugins/jpeg/build.conf Fri Sep 1 21:13:02 2006
+@@ -25,7 +25,7 @@
+ }
+ }
+
+-unix: LIBS += $$(AMANITHDIR)/lib/libjpeg.a
++unix: LIBS += $(LOCALBASE)/lib/libjpeg.so
+ win32: {
+
+ !contains(DEFINES, WIN32_MINGW) {
diff --git a/graphics/amanith/files/patch-plugins-png_build.conf b/graphics/amanith/files/patch-plugins-png_build.conf
new file mode 100644
index 000000000000..6ba31d09df9f
--- /dev/null
+++ b/graphics/amanith/files/patch-plugins-png_build.conf
@@ -0,0 +1,11 @@
+--- plugins/png/build.conf Fri Sep 1 21:13:28 2006
++++ plugins/png/build.conf Fri Sep 1 21:14:18 2006
+@@ -27,7 +27,7 @@
+
+ INCLUDEPATH += $$(AMANITHDIR)/3rdpart/zlib
+
+-unix: LIBS += $$(AMANITHDIR)/lib/libpng.a $$(AMANITHDIR)/lib/libzlib.a
++unix: LIBS += $(LOCALBASE)/lib/libpng.so /usr/lib/libz.so
+ win32: {
+
+ !contains(DEFINES, WIN32_MINGW) {
diff --git a/graphics/amanith/pkg-descr b/graphics/amanith/pkg-descr
new file mode 100644
index 000000000000..166d2362afd1
--- /dev/null
+++ b/graphics/amanith/pkg-descr
@@ -0,0 +1,17 @@
+Amanith is an OpenSource C++ CrossPlatform framework designed for 2d & 3d
+vector graphics.
+
+Open source has made Amanith possible, so we wanna Amanith to be open source
+too. This mean that Amanith source code is fully available for everyone.
+
+Same source tree can be compiled without modifications under multiple targets.
+Linux, Win32, Mac, FreeBSD, NetBSD, OpenBSD, Solaris, IRIX, AIX are only few
+of them.
+
+All the framework is heavily based on a light plug-in system.
+This make fast and easy to include or esclude everything you want.
+
+The Amanith philosophy is to support many open standards as possible.
+Png, Jpeg, Svg, Xml, OpenGl, Ansi c++, and many others.
+
+WWW: http://www.amanith.org/
diff --git a/graphics/amanith/pkg-plist b/graphics/amanith/pkg-plist
new file mode 100644
index 000000000000..f6d180a53a33
--- /dev/null
+++ b/graphics/amanith/pkg-plist
@@ -0,0 +1,80 @@
+include/amanith/1d/gbeziercurve1d.h
+include/amanith/1d/gbsplinecurve1d.h
+include/amanith/1d/gcurve1d.h
+include/amanith/1d/ghermitecurve1d.h
+include/amanith/1d/gmulticurve1d.h
+include/amanith/1d/gpolylinecurve1d.h
+include/amanith/2d/ganimtrsnode2d.h
+include/amanith/2d/gbeziercurve2d.h
+include/amanith/2d/gbsplinecurve2d.h
+include/amanith/2d/gcurve2d.h
+include/amanith/2d/gellipsecurve2d.h
+include/amanith/2d/gfont2d.h
+include/amanith/2d/ghermitecurve2d.h
+include/amanith/2d/gmesh2d.h
+include/amanith/2d/gmulticurve2d.h
+include/amanith/2d/gpath2d.h
+include/amanith/2d/gpixelmap.h
+include/amanith/2d/gpolylinecurve2d.h
+include/amanith/2d/gtesselator2d.h
+include/amanith/2d/gtracer2d.h
+include/amanith/geometry/gaabox.h
+include/amanith/geometry/gaffineparts.h
+include/amanith/geometry/garea.h
+include/amanith/geometry/gaxisangle.h
+include/amanith/geometry/gdistance.h
+include/amanith/geometry/gintersect.h
+include/amanith/geometry/ginterval.h
+include/amanith/geometry/glineseg.h
+include/amanith/geometry/gmatrix.h
+include/amanith/geometry/goobox.h
+include/amanith/geometry/gplane.h
+include/amanith/geometry/gquat.h
+include/amanith/geometry/gray.h
+include/amanith/geometry/gsphere.h
+include/amanith/geometry/gvect.h
+include/amanith/geometry/gxform.h
+include/amanith/geometry/gxformconv.h
+include/amanith/lang/gerror_en.h
+include/amanith/lang/gerror_it.h
+include/amanith/numerics/geigen.h
+include/amanith/numerics/gfilter.h
+include/amanith/numerics/gintegration.h
+include/amanith/rendering/gdrawboard.h
+include/amanith/rendering/gdrawstyle.h
+include/amanith/rendering/gopenglboard.h
+include/amanith/support/gavltree.h
+include/amanith/support/gmetaprogramming.h
+include/amanith/support/gsvgpathtokenizer.h
+include/amanith/support/gutilities.h
+include/amanith/gclassid.h
+include/amanith/gelement.h
+include/amanith/gerror.h
+include/amanith/gglobal.h
+include/amanith/gimpexp.h
+include/amanith/gkernel.h
+include/amanith/gmath.h
+include/amanith/gmultiproperty.h
+include/amanith/gopenglext.h
+include/amanith/gpluglib.h
+include/amanith/gproperty.h
+include/amanith/gfontsimpexp.h
+include/amanith/gjpegimpexp.h
+include/amanith/gpngimpexp.h
+lib/libamanith.so.1
+lib/libfontimpexp.so.1
+lib/libjpegimpexp.so.1
+lib/libpngimpexp.so.1
+lib/libamanith.so
+lib/libfontimpexp.so
+lib/libjpegimpexp.so
+lib/libpngimpexp.so
+@dirrm include/amanith/support
+@dirrm include/amanith/rendering
+@dirrm include/amanith/numerics
+@dirrm include/amanith/lang
+@dirrm include/amanith/geometry
+@dirrm include/amanith/3d
+@dirrm include/amanith/2d
+@dirrm include/amanith/1d
+@dirrm include/amanith