aboutsummaryrefslogtreecommitdiff
path: root/graphics/amide
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-05-29 21:37:49 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-05-29 21:37:49 +0000
commit96ca81d959e16f35d08620092f5e81f651c9bd5f (patch)
tree0b86403572207594fc60f0247f4b0336e88cbc86 /graphics/amide
parent69c779778164bc8506d6e72af770ec03d072f969 (diff)
downloadports-96ca81d959e16f35d08620092f5e81f651c9bd5f.tar.gz
ports-96ca81d959e16f35d08620092f5e81f651c9bd5f.zip
Notes
Diffstat (limited to 'graphics/amide')
-rw-r--r--graphics/amide/Makefile83
-rw-r--r--graphics/amide/distinfo4
-rw-r--r--graphics/amide/files/patch-configure60
-rw-r--r--graphics/amide/pkg-plist41
4 files changed, 115 insertions, 73 deletions
diff --git a/graphics/amide/Makefile b/graphics/amide/Makefile
index 4e7d69bab712..85f16abfdd53 100644
--- a/graphics/amide/Makefile
+++ b/graphics/amide/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amide
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= graphics
MASTER_SITES= SF
EXTRACT_SUFX= .tgz
@@ -27,46 +27,77 @@ INSTALLS_OMF= yes
MAN1= amide.1
-OPTIONS= XMEDCON "Use xmedcon" on \
- DCMTK "Use dcmtk" on \
- FFMPEG "Use ffmpeg" on \
- GSL "Use gsl" on
+OPTIONS_DEFINE= DCMTK FAME FFMPEG GSL VOLPACK XMEDCON
+OPTIONS_DEFAULT= DCMTK FFMPEG GSL VOLPACK XMEDCON
-.include <bsd.port.pre.mk>
+DCMTK_DESC= "Use dcmtk"
+FAME_DESC= "Use libfame (mutually exclusive with ffmpeg)"
+FFMPEG_DESC= "Use ffmpeg (mutually exclusive with libfame)"
+GSL_DESC= "Use gsl"
+VOLPACK_DESC= "Use volpack"
+XMEDCON_DESC= "Use xmedcon"
-.if !defined(WITHOUT_XMEDCON)
-LIB_DEPENDS+= mdc.2:${PORTSDIR}/graphics/xmedcon
-CONFIGUE_ARGS+= --enable-libmdc
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDCMTK}
+LIB_DEPENDS+= dcmdata:${PORTSDIR}/devel/dcmtk
+CONFIGURE_ARGS+= --enable-libdcmdata
.else
-CONFIGUE_ARGS+= --disable-libmdc
+CONFIGURE_ARGS+= --disable-libdcmdata
.endif
-.if !defined(WITHOUT_DCMTK)
-LIB_DEPENDS+= dcmdata.3:${PORTSDIR}/devel/dcmtk
-CONFIGUE_ARGS+= --enable-libdcmdata
+.if ${PORT_OPTIONS:MFAME}
+. if${PORT_OPTIONS:MFFMPEG}
+IGNORE= libfame and ffmpeg support are mutually exclusive, please check options.
+. endif
+LIB_DEPENDS+= fame:${PORTSDIR}/multimedia/libfame
+CONFIGURE_ARGS+= --enable-libfame
.else
-CONFIGUE_ARGS+= --disable-libdcmdata
+CONFIGURE_ARGS+= --disable-libfame
.endif
-.if !defined(WITHOUT_FFMPEG)
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
-CONFIGUE_ARGS+= --enable-ffmpeg
+.if ${PORT_OPTIONS:MFFMPEG}
+. if${PORT_OPTIONS:MFAME}
+IGNORE= libfame and ffmpeg support are mutually exclusive, please check options.
+. endif
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+= --enable-ffmpeg
.else
-CONFIGUE_ARGS+= --disable-ffmpeg
+CONFIGURE_ARGS+= --disable-ffmpeg
.endif
-.if !defined(WITHOUT_GSL)
-LIB_DEPENDS+= gsl.16:${PORTSDIR}/math/gsl
-CONFIGUE_ARGS+= --enable-libgsl
+.if ${PORT_OPTIONS:MGSL}
+LIB_DEPENDS+= gsl:${PORTSDIR}/math/gsl
+CONFIGURE_ARGS+= --enable-libgsl
.else
-CONFIGUE_ARGS+= --disable-libgsl
+CONFIGURE_ARGS+= --disable-libgsl
.endif
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS='@comment '
+.if ${PORT_OPTIONS:MVOLPACK}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libvolpack.a:${PORTSDIR}/graphics/volpack
+CONFIGURE_ARGS+= --enable-libvolpack
+.else
+CONFIGURE_ARGS+= --disable-libvolpack
+.endif
+
+.if ${PORT_OPTIONS:MXMEDCON}
+LIB_DEPENDS+= mdc:${PORTSDIR}/graphics/xmedcon
+CONFIGURE_ARGS+= --enable-libmdc
.else
+CONFIGURE_ARGS+= --disable-libmdc
+.endif
+
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=''
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS='@comment '
.endif
-.include <bsd.port.post.mk>
+post-patch:
+ @${TOUCH} ${WRKSRC}/aclocal.m4 ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/amide_config.h.in
+ @${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/graphics/amide/distinfo b/graphics/amide/distinfo
index d0b0d54e523b..ffce2dece753 100644
--- a/graphics/amide/distinfo
+++ b/graphics/amide/distinfo
@@ -1,2 +1,2 @@
-SHA256 (amide-1.0.1.tgz) = 029392ebf88c58e8ce724583f86d2a63f5730cce47c32163d908998a7a850a2d
-SIZE (amide-1.0.1.tgz) = 1543896
+SHA256 (amide-1.0.2.tgz) = 8fe9618efd9e397ab5742d7f3508425005d022bf2dddb7d84ce4961efb413dc7
+SIZE (amide-1.0.2.tgz) = 1380625
diff --git a/graphics/amide/files/patch-configure b/graphics/amide/files/patch-configure
index 617f8283e9a2..3a38229840c1 100644
--- a/graphics/amide/files/patch-configure
+++ b/graphics/amide/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2011-01-20 03:24:42.000000000 +0100
-+++ configure 2011-05-10 15:10:45.000000000 +0200
-@@ -15399,13 +15399,13 @@
+--- configure.orig 2012-04-14 20:02:59.000000000 +0200
++++ configure 2012-05-29 22:31:25.785277676 +0200
+@@ -16046,7 +16046,7 @@
DATADIRNAME=share
else
CATOBJEXT=.mo
@@ -9,6 +9,8 @@
fi
;;
+@@ -16056,7 +16056,7 @@
+ ;;
*)
CATOBJEXT=.mo
- DATADIRNAME=lib
@@ -16,8 +18,8 @@
;;
esac
fi
-@@ -16063,12 +16063,12 @@
- if test "x$ac_cv_func_bind_textdomain_codeset" = x""yes; then :
+@@ -16723,12 +16723,12 @@
+ if test "x$ac_cv_func_bind_textdomain_codeset" = xyes; then :
DATADIRNAME=share
else
- DATADIRNAME=lib
@@ -31,3 +33,51 @@
;;
esac
fi
+@@ -16793,9 +16793,9 @@
+ fi
+
+
+-OPTIMIZATION_LEVEL="-O3"
+-echo "setting optimization level to $OPTIMIZATION_LEVEL"
+-CFLAGS="$CFLAGS $OPTIMIZATION_LEVEL"
++#OPTIMIZATION_LEVEL="-O3"
++#echo "setting optimization level to $OPTIMIZATION_LEVEL"
++#CFLAGS="$CFLAGS $OPTIMIZATION_LEVEL"
+
+ if test $CC = "gcc"; then
+ echo -n "checking version of gcc... "
+@@ -17443,8 +17443,8 @@
+ THREAD_LIBS=""
+ fi
+
+-AMIDE_LIBDCMDATA_LIBS="-L/usr/local/dicom/lib -L/usr/lib64/dcmtk -L/usr/lib/dcmtk -ldcmdata -loflog -lofstd -lz $THREAD_LIBS"
+-AMIDE_LIBDCMDATA_CFLAGS="-I/usr/local/dicom/include"
++AMIDE_LIBDCMDATA_LIBS="-L%%LOCALBASE%%/lib -L/usr/local/dicom/lib -L/usr/lib64/dcmtk -L/usr/lib/dcmtk -ldcmdata -loflog -lofstd -lz $THREAD_LIBS"
++AMIDE_LIBDCMDATA_CFLAGS="-I%%LOCALBASE%%/include -I/usr/local/dicom/include"
+ saved_libs="${LIBS}"
+ LIBS="${LIBS} ${AMIDE_LIBDCMDATA_LIBS}"
+ saved_cxxflags="${CXXFLAGS}"
+@@ -17982,6 +17982,7 @@
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $LIBFAME_CFLAGS"
++ CXXFLAGS="$CFLAGS $LIBFAME_CFLAGS"
+ LIBS="$LIBFAME_LIBS $LIBS"
+ rm -f conf.libfametest
+ if test "$cross_compiling" = yes; then :
+@@ -17993,6 +17994,7 @@
+ #include <fame.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+
+ int
+ main ()
+@@ -21896,7 +21898,3 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: unrecognized options: $ac_unrecognized_opts" >&5
+ $as_echo "$as_me: WARNING: unrecognized options: $ac_unrecognized_opts" >&2;}
+ fi
+-
+-
+-echo "Moving SPEC file to base directory"
+-mv etc/amide.spec ./
diff --git a/graphics/amide/pkg-plist b/graphics/amide/pkg-plist
index e967f4b89096..821daa0ad24e 100644
--- a/graphics/amide/pkg-plist
+++ b/graphics/amide/pkg-plist
@@ -7,51 +7,12 @@ share/gnome/help/amide/C/legal.xml
share/gnome/help/amide/es/amide.xml
share/gnome/help/amide/es/figures/amide_main_window.png
share/gnome/help/amide/es/figures/study_tree.png
-share/gnome/help/amide/es/legal.xml
-share/gtk-doc/html/amitk/AmitkWidgets.html
-share/gtk-doc/html/amitk/SpaceObjects.html
-share/gtk-doc/html/amitk/amitk-AmitkCanvas.html
-share/gtk-doc/html/amitk/amitk-AmitkColorTableMenu.html
-share/gtk-doc/html/amitk/amitk-AmitkDataSet.html
-share/gtk-doc/html/amitk/amitk-AmitkFiducialMark.html
-share/gtk-doc/html/amitk/amitk-AmitkLineProfile.html
-share/gtk-doc/html/amitk/amitk-AmitkObject.html
-share/gtk-doc/html/amitk/amitk-AmitkObjectDialog.html
-share/gtk-doc/html/amitk/amitk-AmitkProgressDialog.html
-share/gtk-doc/html/amitk/amitk-AmitkRawData.html
-share/gtk-doc/html/amitk/amitk-AmitkRoi.html
-share/gtk-doc/html/amitk/amitk-AmitkSpace.html
-share/gtk-doc/html/amitk/amitk-AmitkSpaceEdit.html
-share/gtk-doc/html/amitk/amitk-AmitkStudy.html
-share/gtk-doc/html/amitk/amitk-AmitkThresholdsDialog.html
-share/gtk-doc/html/amitk/amitk-AmitkTreeView.html
-share/gtk-doc/html/amitk/amitk-AmitkVolume.html
-share/gtk-doc/html/amitk/amitk-amitk-canvas-object.html
-share/gtk-doc/html/amitk/amitk-amitk-color-table.html
-share/gtk-doc/html/amitk/amitk-amitk-common.html
-share/gtk-doc/html/amitk/amitk-amitk-filter.html
-share/gtk-doc/html/amitk/amitk-amitk-point.html
-share/gtk-doc/html/amitk/amitk-amitk-type.html
-share/gtk-doc/html/amitk/amitk-theory.html
-share/gtk-doc/html/amitk/amitk.devhelp
-share/gtk-doc/html/amitk/amitk.devhelp2
-share/gtk-doc/html/amitk/amitk_base.html
-share/gtk-doc/html/amitk/amitk_intro.html
-share/gtk-doc/html/amitk/amitk_objects.html
-share/gtk-doc/html/amitk/ch01.html
-share/gtk-doc/html/amitk/home.png
-share/gtk-doc/html/amitk/index.html
-share/gtk-doc/html/amitk/index.sgml
-share/gtk-doc/html/amitk/left.png
-share/gtk-doc/html/amitk/right.png
-share/gtk-doc/html/amitk/style.css
-share/gtk-doc/html/amitk/up.png
%%NLS%%share/locale/zh_CN/LC_MESSAGES/amide.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/amide.mo
share/omf/amide/amide-C.omf
share/omf/amide/amide-es.omf
share/pixmaps/amide_logo.png
share/pixmaps/amide_file_logo.png
-@dirrm share/gtk-doc/html/amitk
@dirrm share/gnome/help/amide/es/figures
@dirrm share/gnome/help/amide/es
@dirrm share/gnome/help/amide/C/figures