aboutsummaryrefslogtreecommitdiff
path: root/graphics/ampasCTL/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-01-17 03:26:03 +0000
committerSteve Wills <swills@FreeBSD.org>2013-01-17 03:26:03 +0000
commit9c4499335a926635b98ddda90e6b83c90acde13b (patch)
tree2f79752ba0ade3a9a71f70ee80ff7a1da7f674fa /graphics/ampasCTL/Makefile
parente9591ed4640bf2cb93eb00d67b40f5505c09b97a (diff)
downloadports-9c4499335a926635b98ddda90e6b83c90acde13b.tar.gz
ports-9c4499335a926635b98ddda90e6b83c90acde13b.zip
Notes
Diffstat (limited to 'graphics/ampasCTL/Makefile')
-rw-r--r--graphics/ampasCTL/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/graphics/ampasCTL/Makefile b/graphics/ampasCTL/Makefile
index 47d6c87edb6c..5edc9c711ef3 100644
--- a/graphics/ampasCTL/Makefile
+++ b/graphics/ampasCTL/Makefile
@@ -6,21 +6,27 @@
#
PORTNAME= ampasCTL
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.1
CATEGORIES= graphics devel
-MASTER_SITES= SF/${PORTNAME:L}/ctl/${PORTVERSION}
-DISTNAME= ctl-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME:L}/ctl/ctl-${PORTVERSION}/
+DISTNAME= ctl-${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Color Transformation Language interpreter
-LIB_DEPENDS= Half.6:${PORTSDIR}/graphics/ilmbase
+LICENSE= BSD
-USE_GNOME= pkgconfig
+LIB_DEPENDS= Imath:${PORTSDIR}/graphics/ilmbase
+
+USE_PKGCONFIG= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+.include <bsd.port.options.mk>
+
test check: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
@@ -28,4 +34,10 @@ test check: build
pre-install: test
.endif
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>