aboutsummaryrefslogtreecommitdiff
path: root/graphics/ampasCTL
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2007-10-07 22:46:38 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2007-10-07 22:46:38 +0000
commit29b41023b614e37c18a3d72718ec5760bb9ad7ee (patch)
tree6550e75d28c998f47102da5c519ab77385e2ca49 /graphics/ampasCTL
parent98e59b9530970d5d7824ee92afd7d6f6b35c922d (diff)
downloadports-29b41023b614e37c18a3d72718ec5760bb9ad7ee.tar.gz
ports-29b41023b614e37c18a3d72718ec5760bb9ad7ee.zip
Add ampasCTL 1.4.0, is Color Transformation Language interpreter
by Academy of Motion Picture Arts and Sciences.
Notes
Notes: svn path=/head/; revision=201061
Diffstat (limited to 'graphics/ampasCTL')
-rw-r--r--graphics/ampasCTL/Makefile32
-rw-r--r--graphics/ampasCTL/distinfo3
-rw-r--r--graphics/ampasCTL/files/patch-Makefile.in11
-rw-r--r--graphics/ampasCTL/files/patch-doc-Makefile.in11
-rw-r--r--graphics/ampasCTL/pkg-descr13
-rw-r--r--graphics/ampasCTL/pkg-plist38
6 files changed, 108 insertions, 0 deletions
diff --git a/graphics/ampasCTL/Makefile b/graphics/ampasCTL/Makefile
new file mode 100644
index 000000000000..61e1aed72143
--- /dev/null
+++ b/graphics/ampasCTL/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ampasCTL
+# Date created: 2007-10-08
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ampasCTL
+PORTVERSION= 1.4.0
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ampasctl
+DISTNAME= ctl-${PORTVERSION}
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= Color Transformation Language interpreter
+
+LIB_DEPENDS= Half.6:${PORTSDIR}/graphics/ilmbase
+
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+
+test check: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
+.if defined(PACKAGE_BUILDING)
+pre-install: test
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/ampasCTL/distinfo b/graphics/ampasCTL/distinfo
new file mode 100644
index 000000000000..255061ad0ac1
--- /dev/null
+++ b/graphics/ampasCTL/distinfo
@@ -0,0 +1,3 @@
+MD5 (ctl-1.4.0.tar.gz) = 04717d3923bcbfbc045bc25c888d22cc
+SHA256 (ctl-1.4.0.tar.gz) = 85cc710d18f1ac16e77640e165ba083c6e27766cbe6b0cfdb80eac3daef58aa6
+SIZE (ctl-1.4.0.tar.gz) = 1004039
diff --git a/graphics/ampasCTL/files/patch-Makefile.in b/graphics/ampasCTL/files/patch-Makefile.in
new file mode 100644
index 000000000000..0f987f6b2404
--- /dev/null
+++ b/graphics/ampasCTL/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2007-08-04 09:11:41.000000000 +0900
++++ Makefile.in 2007-10-08 06:50:25.000000000 +0900
+@@ -203,7 +203,7 @@
+ AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS \
+ README README.CVS README.OSX README.win32 bootstrap
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = CTL.pc
+ all: all-recursive
+
diff --git a/graphics/ampasCTL/files/patch-doc-Makefile.in b/graphics/ampasCTL/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..e13a9c10940a
--- /dev/null
+++ b/graphics/ampasCTL/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig 2007-08-04 09:11:41.000000000 +0900
++++ doc/Makefile.in 2007-10-08 06:51:25.000000000 +0900
+@@ -171,7 +171,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ EXTRA_DIST = CtlManual.pdf CtlManual.doc
+-docdir = $(datadir)/doc/CTL-@CTL_VERSION@
++docdir = $(datadir)/doc/ampasCTL
+ doc_DATA = $(EXTRA_DIST)
+ all: all-am
+
diff --git a/graphics/ampasCTL/pkg-descr b/graphics/ampasCTL/pkg-descr
new file mode 100644
index 000000000000..e779f37c693d
--- /dev/null
+++ b/graphics/ampasCTL/pkg-descr
@@ -0,0 +1,13 @@
+The CTL(Color Transformation Language) interpreter contains
+the following C++ libraries:
+
+IlmCtl The CTL interpreter front end and the interpreter's
+ public programming interface.
+
+IlmCtlSimd The interpreter's SIMD back end.
+
+IlmCtlMath Math routines that are used by IlmCtlSimd: conversions
+ between standard color spaces, 1D and 3D lookup tables,
+ 3D scattered data interpolation.
+
+WWW: http://www.oscars.org/council/ctl.html
diff --git a/graphics/ampasCTL/pkg-plist b/graphics/ampasCTL/pkg-plist
new file mode 100644
index 000000000000..87c5a5da4bca
--- /dev/null
+++ b/graphics/ampasCTL/pkg-plist
@@ -0,0 +1,38 @@
+lib/libIlmCtl.a
+lib/libIlmCtl.la
+lib/libIlmCtl.so
+lib/libIlmCtl.so.2
+lib/libIlmCtlMath.a
+lib/libIlmCtlMath.la
+lib/libIlmCtlMath.so
+lib/libIlmCtlMath.so.2
+lib/libIlmCtlSimd.a
+lib/libIlmCtlSimd.la
+lib/libIlmCtlSimd.so
+lib/libIlmCtlSimd.so.2
+include/CTL/CtlAddr.h
+include/CTL/CtlAlign.h
+include/CTL/CtlColorSpace.h
+include/CTL/CtlErrors.h
+include/CTL/CtlExc.h
+include/CTL/CtlFunctionCall.h
+include/CTL/CtlInterpreter.h
+include/CTL/CtlLContext.h
+include/CTL/CtlLookupTable.h
+include/CTL/CtlMessage.h
+include/CTL/CtlModule.h
+include/CTL/CtlRbfInterpolator.h
+include/CTL/CtlRcPtr.h
+include/CTL/CtlReadWriteAccess.h
+include/CTL/CtlSimdInterpreter.h
+include/CTL/CtlSparseMatrix.h
+include/CTL/CtlSymbolTable.h
+include/CTL/CtlSyntaxTree.h
+include/CTL/CtlTokens.h
+include/CTL/CtlType.h
+include/CTL/CtlVersion.h
+libdata/pkgconfig/CTL.pc
+%%DOCSDIR%%/CtlManual.pdf
+%%DOCSDIR%%/CtlManual.doc
+@dirrm %%DOCSDIR%%
+@dirrm include/CTL