aboutsummaryrefslogtreecommitdiff
path: root/graphics/ampasCTL
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-01-17 03:26:03 +0000
committerSteve Wills <swills@FreeBSD.org>2013-01-17 03:26:03 +0000
commit9c4499335a926635b98ddda90e6b83c90acde13b (patch)
tree2f79752ba0ade3a9a71f70ee80ff7a1da7f674fa /graphics/ampasCTL
parente9591ed4640bf2cb93eb00d67b40f5505c09b97a (diff)
downloadports-9c4499335a926635b98ddda90e6b83c90acde13b.tar.gz
ports-9c4499335a926635b98ddda90e6b83c90acde13b.zip
Notes
Diffstat (limited to 'graphics/ampasCTL')
-rw-r--r--graphics/ampasCTL/Makefile24
-rw-r--r--graphics/ampasCTL/distinfo4
-rw-r--r--graphics/ampasCTL/pkg-descr29
-rw-r--r--graphics/ampasCTL/pkg-plist33
4 files changed, 57 insertions, 33 deletions
diff --git a/graphics/ampasCTL/Makefile b/graphics/ampasCTL/Makefile
index 47d6c87edb6c..5edc9c711ef3 100644
--- a/graphics/ampasCTL/Makefile
+++ b/graphics/ampasCTL/Makefile
@@ -6,21 +6,27 @@
#
PORTNAME= ampasCTL
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.1
CATEGORIES= graphics devel
-MASTER_SITES= SF/${PORTNAME:L}/ctl/${PORTVERSION}
-DISTNAME= ctl-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME:L}/ctl/ctl-${PORTVERSION}/
+DISTNAME= ctl-${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= nemysis@gmx.ch
COMMENT= Color Transformation Language interpreter
-LIB_DEPENDS= Half.6:${PORTSDIR}/graphics/ilmbase
+LICENSE= BSD
-USE_GNOME= pkgconfig
+LIB_DEPENDS= Imath:${PORTSDIR}/graphics/ilmbase
+
+USE_PKGCONFIG= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+.include <bsd.port.options.mk>
+
test check: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
@@ -28,4 +34,10 @@ test check: build
pre-install: test
.endif
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/ampasCTL/distinfo b/graphics/ampasCTL/distinfo
index 499257e0d920..fcab7094c1cc 100644
--- a/graphics/ampasCTL/distinfo
+++ b/graphics/ampasCTL/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ctl-1.4.0.tar.gz) = 85cc710d18f1ac16e77640e165ba083c6e27766cbe6b0cfdb80eac3daef58aa6
-SIZE (ctl-1.4.0.tar.gz) = 1004039
+SHA256 (ctl-1.4.1.tar.gz) = b202d9552eeb81f3ded66a6786719f6e1138fa4e31c866799b1efad6ef7a9f9a
+SIZE (ctl-1.4.1.tar.gz) = 996923
diff --git a/graphics/ampasCTL/pkg-descr b/graphics/ampasCTL/pkg-descr
index e779f37c693d..287655b6e1e5 100644
--- a/graphics/ampasCTL/pkg-descr
+++ b/graphics/ampasCTL/pkg-descr
@@ -1,13 +1,24 @@
-The CTL(Color Transformation Language) interpreter contains
-the following C++ libraries:
+ABOUT THE CTL LIBRARIES
+-----------------------
-IlmCtl The CTL interpreter front end and the interpreter's
- public programming interface.
+The CTL interpreter source code release contains the following
+C++ libraries:
-IlmCtlSimd The interpreter's SIMD back end.
+IlmCtl The CTL interpreter front end and the interpreter's
+ public programming interface.
-IlmCtlMath Math routines that are used by IlmCtlSimd: conversions
- between standard color spaces, 1D and 3D lookup tables,
- 3D scattered data interpolation.
+IlmCtlSimd The interpreter's SIMD back end.
-WWW: http://www.oscars.org/council/ctl.html
+IlmCtlMath Math routines that are used by IlmCtlSimd: conversions
+ between standard color spaces, 1D and 3D lookup tables,
+ 3D scattered data interpolation.
+
+IlmCtlTest Confidence tests for IlmCtl, IlmCtlSimd
+
+IlmCtlMathTest Confidence tests for IlmCtlMath
+
+IlmCtlTest Confidence tests for IlmImfCtl
+
+WWW: http://www.openexr.com/
+WWW: http://www.oscars.org/science-technology/council/projects/ctl.html
+WWW: http://ampasctl.sourceforge.net/
diff --git a/graphics/ampasCTL/pkg-plist b/graphics/ampasCTL/pkg-plist
index 87c5a5da4bca..7a5392143c3d 100644
--- a/graphics/ampasCTL/pkg-plist
+++ b/graphics/ampasCTL/pkg-plist
@@ -1,15 +1,3 @@
-lib/libIlmCtl.a
-lib/libIlmCtl.la
-lib/libIlmCtl.so
-lib/libIlmCtl.so.2
-lib/libIlmCtlMath.a
-lib/libIlmCtlMath.la
-lib/libIlmCtlMath.so
-lib/libIlmCtlMath.so.2
-lib/libIlmCtlSimd.a
-lib/libIlmCtlSimd.la
-lib/libIlmCtlSimd.so
-lib/libIlmCtlSimd.so.2
include/CTL/CtlAddr.h
include/CTL/CtlAlign.h
include/CTL/CtlColorSpace.h
@@ -31,8 +19,21 @@ include/CTL/CtlSyntaxTree.h
include/CTL/CtlTokens.h
include/CTL/CtlType.h
include/CTL/CtlVersion.h
+lib/libIlmCtl.a
+lib/libIlmCtl.la
+lib/libIlmCtl.so
+lib/libIlmCtl.so.2
+lib/libIlmCtlMath.a
+lib/libIlmCtlMath.la
+lib/libIlmCtlMath.so
+lib/libIlmCtlMath.so.2
+lib/libIlmCtlSimd.a
+lib/libIlmCtlSimd.la
+lib/libIlmCtlSimd.so
+lib/libIlmCtlSimd.so.2
libdata/pkgconfig/CTL.pc
-%%DOCSDIR%%/CtlManual.pdf
-%%DOCSDIR%%/CtlManual.doc
-@dirrm %%DOCSDIR%%
-@dirrm include/CTL
+%%PORTDOCS%%%%DOCSDIR%%/CtlManual.doc
+%%PORTDOCS%%%%DOCSDIR%%/CtlManual.pdf
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry share/applications
+@dirrmtry include/CTL