aboutsummaryrefslogtreecommitdiff
path: root/graphics/animorph/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-10 18:54:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-10 18:54:22 +0000
commit1b3031c7fa40b754e4f85f184e535cf7c8e4c5eb (patch)
tree73cf331a38b082ac83a3ba038dc56a7be6929f5d /graphics/animorph/Makefile
parentff72e14cb777e07deaee591e665219b3b965aa2a (diff)
Animorph is a morphing engine responsible for calculating and then
executing all the real time changes to the MakeHuman basemesh, as required by the user's morph target selections and those target's value settings. Naturally, it also loads and saves character body setting (.bs) files. WWW: http://www.dedalo-3d.com/index.php PR: ports/111075 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Notes
Notes: svn path=/head/; revision=189704
Diffstat (limited to 'graphics/animorph/Makefile')
-rw-r--r--graphics/animorph/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/animorph/Makefile b/graphics/animorph/Makefile
new file mode 100644
index 000000000000..bfc32241a9a0
--- /dev/null
+++ b/graphics/animorph/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: animorph
+# Date created: 31 Mar 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= animorph
+PORTVERSION= 0.2
+CATEGORIES= graphics
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= makehuman
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Morphing engine for MakeHuman
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^libanimorphdocdir =/ s|doc/|share/doc/|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^pkgconfigdir =/ s|\$$(libdir)|\$$(exec_prefix)/libdata|' ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-libanimorphdocDATA||' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>