aboutsummaryrefslogtreecommitdiff
path: root/graphics/animorph
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-10 18:54:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-10 18:54:22 +0000
commit1b3031c7fa40b754e4f85f184e535cf7c8e4c5eb (patch)
tree73cf331a38b082ac83a3ba038dc56a7be6929f5d /graphics/animorph
parentff72e14cb777e07deaee591e665219b3b965aa2a (diff)
downloadports-1b3031c7fa40b754e4f85f184e535cf7c8e4c5eb.tar.gz
ports-1b3031c7fa40b754e4f85f184e535cf7c8e4c5eb.zip
Notes
Diffstat (limited to 'graphics/animorph')
-rw-r--r--graphics/animorph/Makefile32
-rw-r--r--graphics/animorph/distinfo3
-rw-r--r--graphics/animorph/pkg-descr7
-rw-r--r--graphics/animorph/pkg-plist40
4 files changed, 82 insertions, 0 deletions
diff --git a/graphics/animorph/Makefile b/graphics/animorph/Makefile
new file mode 100644
index 000000000000..bfc32241a9a0
--- /dev/null
+++ b/graphics/animorph/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: animorph
+# Date created: 31 Mar 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= animorph
+PORTVERSION= 0.2
+CATEGORIES= graphics
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= makehuman
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Morphing engine for MakeHuman
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^libanimorphdocdir =/ s|doc/|share/doc/|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^pkgconfigdir =/ s|\$$(libdir)|\$$(exec_prefix)/libdata|' ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-libanimorphdocDATA||' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/animorph/distinfo b/graphics/animorph/distinfo
new file mode 100644
index 000000000000..f42a52949b13
--- /dev/null
+++ b/graphics/animorph/distinfo
@@ -0,0 +1,3 @@
+MD5 (animorph-0.2.tar.gz) = 90cfb95f5eb0b49df0ab5c717e26b2e0
+SHA256 (animorph-0.2.tar.gz) = acb37c9b1b0331613f7bd379e7a201aade14eb1bab40201977771057f378abd4
+SIZE (animorph-0.2.tar.gz) = 313115
diff --git a/graphics/animorph/pkg-descr b/graphics/animorph/pkg-descr
new file mode 100644
index 000000000000..ca59064b524d
--- /dev/null
+++ b/graphics/animorph/pkg-descr
@@ -0,0 +1,7 @@
+Animorph is a morphing engine responsible for calculating and then
+executing all the real time changes to the MakeHuman basemesh, as
+required by the user's morph target selections and those target's value
+settings. Naturally, it also loads and saves character body setting
+(.bs) files.
+
+WWW: http://www.dedalo-3d.com/index.php
diff --git a/graphics/animorph/pkg-plist b/graphics/animorph/pkg-plist
new file mode 100644
index 000000000000..e5322bdffcde
--- /dev/null
+++ b/graphics/animorph/pkg-plist
@@ -0,0 +1,40 @@
+include/animorph/BodySettings.h
+include/animorph/Color.h
+include/animorph/DirectoryList.h
+include/animorph/Euler.h
+include/animorph/Face.h
+include/animorph/FaceVector.h
+include/animorph/FileReader.h
+include/animorph/FileWriter.h
+include/animorph/Hotspot.h
+include/animorph/Material.h
+include/animorph/MathUtil.h
+include/animorph/Matrix.h
+include/animorph/Mesh.h
+include/animorph/ObjExporter.h
+include/animorph/PoseSemiTarget.h
+include/animorph/PoseTarget.h
+include/animorph/Quaternion.h
+include/animorph/RIBExporter.h
+include/animorph/Target.h
+include/animorph/TextureVector.h
+include/animorph/Vector2.h
+include/animorph/Vector3.h
+include/animorph/Vertex.h
+include/animorph/VertexGroup.h
+include/animorph/VertexVector.h
+include/animorph/util.h
+lib/libanimorph.a
+lib/libanimorph.la
+lib/libanimorph.so
+lib/libanimorph.so.0
+libdata/pkgconfig/animorph.pc
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/animorph