aboutsummaryrefslogtreecommitdiff
path: root/graphics/apngasm/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-13 14:47:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-13 14:47:58 +0000
commita62adac27820d2baf130774f154bcb45015fb3e6 (patch)
treea57bfdd07341c4ec4990672ee443a844c1ba9c0d /graphics/apngasm/Makefile
parent0e050d80bd605c6c5507b01cc7dd36dd0a6c8064 (diff)
Notes
Diffstat (limited to 'graphics/apngasm/Makefile')
-rw-r--r--graphics/apngasm/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/apngasm/Makefile b/graphics/apngasm/Makefile
new file mode 100644
index 000000000000..6c663523395a
--- /dev/null
+++ b/graphics/apngasm/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: apngasm
+# Date created: 02 May 2010
+# Whom: Anonymous <swell.k@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apngasm
+PORTVERSION= 2.0
+DISTVERSIONSUFFIX=-src
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= swell.k@gmail.com
+COMMENT= Create Animated PNG from a sequence of files
+
+LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+
+USE_ZIP= yes
+USE_DOS2UNIX= yes
+NO_WRKSUBDIR= yes
+
+ALL_TARGET= ${PORTNAME}
+MAKEFILE= /dev/null
+CFLAGS+= -I${LOCALBASE}/include -lpng -lz -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>