aboutsummaryrefslogtreecommitdiff
path: root/graphics/apngasm
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-18 17:51:04 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-18 17:51:04 +0000
commit9175c2f2222953ae0ed5b7533b35eebf043a4757 (patch)
tree7ffbb31dde487efe6f1cbaedbcdf8033178d8f09 /graphics/apngasm
parentf0d679be01317933f2fe976a5d470cdd3128a121 (diff)
downloadports-9175c2f2222953ae0ed5b7533b35eebf043a4757.tar.gz
ports-9175c2f2222953ae0ed5b7533b35eebf043a4757.zip
- Update from 2.7 to 2.8
- Improve COMMENT - Add stage support - Convert LIB_DEPENDS to new syntax - Use CC and CXX properly PR: ports/184864 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=336852
Diffstat (limited to 'graphics/apngasm')
-rw-r--r--graphics/apngasm/Makefile40
-rw-r--r--graphics/apngasm/distinfo4
-rw-r--r--graphics/apngasm/files/patch-Makefile49
3 files changed, 66 insertions, 27 deletions
diff --git a/graphics/apngasm/Makefile b/graphics/apngasm/Makefile
index 6aa6bcabd63f..43d22ae5d475 100644
--- a/graphics/apngasm/Makefile
+++ b/graphics/apngasm/Makefile
@@ -2,50 +2,40 @@
# $FreeBSD$
PORTNAME= apngasm
-PORTVERSION= 2.7
+PORTVERSION= 2.8
DISTVERSIONSUFFIX=-src
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Creates an APNG animation from a PNG/TGA image sequence
+COMMENT= Create Animated PNG from a sequence of files
LICENSE= ZLIB
+OPTIONS_DEFINE= DOCS STATIC
+
NO_WRKSUBDIR= yes
-USE_DOS2UNIX= yes
USE_ZIP= yes
-
-CPPFLAGS+= `libpng-config --I_opts`
-LDFLAGS+= `libpng-config --ldflags` -lm -lz
-
-PLIST_FILES= bin/${PORTNAME}
+USES= dos2unix gmake
PORTDOCS= readme.txt
+PLIST_FILES= bin/${PORTNAME}
-OPTIONS_DEFINE= DOCS STATIC
+STATIC_BUILD_DEPENDS= ${LOCALBASE}/lib/libpng.a:${PORTSDIR}/graphics/png
+STATIC_MAKE_ENV= STATIC=1
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSTATIC}
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libpng.a:${PORTSDIR}/graphics/png
-LDFLAGS+= -static
-.else
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+.if ! ${PORT_OPTIONS:MSTATIC}
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
.endif
-do-build:
- cd ${WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} ${PORTNAME}.c \
- -o ${PORTNAME} ${LDFLAGS}
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} \
+ ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/graphics/apngasm/distinfo b/graphics/apngasm/distinfo
index 62754de920fa..dbef43950b9c 100644
--- a/graphics/apngasm/distinfo
+++ b/graphics/apngasm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (apngasm-2.7-src.zip) = af42569666cab268a20a0754191396c9d48f4e01d6e8f93c3ae1164c3c821cc3
-SIZE (apngasm-2.7-src.zip) = 11448
+SHA256 (apngasm-2.8-src.zip) = 47bee31bc149efc5932a87819cc0daea668cf7322eeaed9378c43edbdc9803bc
+SIZE (apngasm-2.8-src.zip) = 568753
diff --git a/graphics/apngasm/files/patch-Makefile b/graphics/apngasm/files/patch-Makefile
new file mode 100644
index 000000000000..ef82e7f03b42
--- /dev/null
+++ b/graphics/apngasm/files/patch-Makefile
@@ -0,0 +1,49 @@
+--- ./Makefile.orig 2013-12-18 15:23:41.000000000 -0200
++++ ./Makefile 2013-12-18 15:23:54.000000000 -0200
+@@ -1,10 +1,17 @@
+ PACKAGE = apngasm
+-CC = gcc
++CC ?= cc
++CXX ?= c++
+ SRC_DIRS = . 7z zopfli
+-CFLAGS = -Wall -pedantic
+-CFLAGS_OPT = -O2
+-CFLAGS_7Z = -Wno-sign-compare -Wno-reorder -Wno-maybe-uninitialized -Wno-parentheses
+-LIBS = -lstdc++ -lm -lpng -lz
++CFLAGS += -Wall -pedantic
++CXXFLAGS += -Wall -pedantic
++CPPFLAGS += $(shell libpng-config --cflags)
++CFLAGS_7Z = -Wno-sign-compare -Wno-reorder -Wno-parentheses
++ifeq ($(strip $(STATIC)),)
++LIBS = $(shell libpng-config --ldflags)
++else
++LIBS = $(shell libpng-config --static --ldflags)
++LDFLAGS += -static
++endif
+
+ INCUDE_DIRS := $(addprefix -I./, $(SRC_DIRS))
+ OBJ_DIRS := $(addprefix obj/, $(SRC_DIRS))
+@@ -16,19 +23,19 @@
+ all : $(PACKAGE)
+
+ $(PACKAGE) : objdirs $(OBJECTS)
+- $(CC) -o $@ $(OBJECTS) -s $(LIBS)
++ $(CXX) -o $@ $(OBJECTS) $(LIBS) $(LDFLAGS)
+
+ objdirs :
+ mkdir -p $(OBJ_DIRS)
+
+ obj/%.o : %.cpp
+- $(CC) -o $@ -c $< $(INCUDE_DIRS) $(CFLAGS) $(CFLAGS_OPT)
++ $(CXX) -o $@ -c $< $(INCUDE_DIRS) $(CXXFLAGS) $(CPPFLAGS)
+
+ obj/%.o : %.c
+- $(CC) -o $@ -c $< $(INCUDE_DIRS) $(CFLAGS) $(CFLAGS_OPT)
++ $(CC) -o $@ -c $< $(INCUDE_DIRS) $(CFLAGS) $(CPPFLAGS)
+
+ obj/%.o : %.cc
+- $(CC) -o $@ -c $< $(INCUDE_DIRS) $(CFLAGS) $(CFLAGS_OPT) $(CFLAGS_7Z)
++ $(CXX) -o $@ -c $< $(INCUDE_DIRS) $(CXXFLAGS) $(CPPFLAGS) $(CFLAGS_7Z)
+
+ .PHONY : clean
+