aboutsummaryrefslogtreecommitdiff
path: root/graphics/apvlv
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:36:20 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:36:20 +0000
commit284cf7e6238e1818f820249028610aa60b2d146b (patch)
tree2d5a24d57a83c8612c5741488988d6819f23f4c9 /graphics/apvlv
parent8baa0305dbf37f362652e57504f2bb313edc2514 (diff)
downloadports-284cf7e6238e1818f820249028610aa60b2d146b.tar.gz
ports-284cf7e6238e1818f820249028610aa60b2d146b.zip
Notes
Diffstat (limited to 'graphics/apvlv')
-rw-r--r--graphics/apvlv/Makefile4
-rw-r--r--graphics/apvlv/files/patch-src_ApvlvFile.cpp14
2 files changed, 16 insertions, 2 deletions
diff --git a/graphics/apvlv/Makefile b/graphics/apvlv/Makefile
index 618fa8080db2..7e9ec919e018 100644
--- a/graphics/apvlv/Makefile
+++ b/graphics/apvlv/Makefile
@@ -7,14 +7,14 @@
PORTNAME= apvlv
PORTVERSION= 0.0.9.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
MAINTAINER= jupengfei@gmail.com
COMMENT= Apvlv is a PDF Viewer Under Linux and its behaviour like Vim
-LIB_DEPENDS= poppler-glib.5:${PORTSDIR}/graphics/poppler-gtk
+LIB_DEPENDS= poppler-glib.6:${PORTSDIR}/graphics/poppler-gtk
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/graphics/apvlv/files/patch-src_ApvlvFile.cpp b/graphics/apvlv/files/patch-src_ApvlvFile.cpp
new file mode 100644
index 000000000000..ab16c19eac78
--- /dev/null
+++ b/graphics/apvlv/files/patch-src_ApvlvFile.cpp
@@ -0,0 +1,14 @@
+--- src/ApvlvFile.cpp.orig 2011-08-12 10:22:23.000000000 +0200
++++ src/ApvlvFile.cpp 2011-08-12 10:24:26.000000000 +0200
+@@ -273,9 +273,9 @@ ApvlvPDF::ApvlvPDF (const char *filename
+
+ bool ApvlvPDF::pagetext (int pn, int x1, int y1, int x2, int y2, char **out)
+ {
+- PopplerRectangle rect = { x1, y1, x2, y2 };
+ PopplerPage *page = poppler_document_get_page (mDoc, pn);
+- *out = poppler_page_get_text (page, POPPLER_SELECTION_WORD, &rect);
++ PopplerRectangle rect = { x1, y2, x2, y1 };
++ *out = poppler_page_get_selected_text (page, POPPLER_SELECTION_WORD, &rect);
+ if (*out != NULL)
+ {
+ return true;