aboutsummaryrefslogtreecommitdiff
path: root/graphics/aqsis/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-10-31 00:32:31 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-10-31 00:32:31 +0000
commit1752bb5a6e253b2040e8fc493b85d7980962c42c (patch)
tree7b8bf4527ee8a7f7c5d3f4e85a1707da0b869062 /graphics/aqsis/Makefile
parent0157fa0fe8d64d0d31225fb8f57ae6ecb2d1d4b2 (diff)
downloadports-1752bb5a6e253b2040e8fc493b85d7980962c42c.tar.gz
ports-1752bb5a6e253b2040e8fc493b85d7980962c42c.zip
Notes
Diffstat (limited to 'graphics/aqsis/Makefile')
-rw-r--r--graphics/aqsis/Makefile29
1 files changed, 21 insertions, 8 deletions
diff --git a/graphics/aqsis/Makefile b/graphics/aqsis/Makefile
index 91257afb1bfe..e1a1873dbead 100644
--- a/graphics/aqsis/Makefile
+++ b/graphics/aqsis/Makefile
@@ -3,31 +3,44 @@
PORTNAME= aqsis
PORTVERSION= 1.8.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
-COMMENT= A photorealistic rendering system
+COMMENT= Photorealistic rendering system
LICENSE= BSD GPLv2
LICENSE_COMB= multi
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
xsltproc:${PORTSDIR}/textproc/libxslt
-LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
- boost_filesystem:${PORTSDIR}/devel/boost-libs \
- tiff.4:${PORTSDIR}/graphics/tiff \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libtiff.so:${PORTSDIR}/graphics/tiff
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-USES= cmake:outsource
+USES= cmake:outsource desktop-file-utils shared-mime-info
USE_QT4= opengl qmake_build moc_build rcc_build uic_build
PLIST_SUB+= LIBVERS=${PORTVERSION:R}
INSTALLS_ICONS= yes
-NO_STAGE= yes
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|examples_install_dir $${EXAMPLESDIR}|examples_install_dir ${PREFIX}/share/examples/${PORTNAME}|' \
+ ${WRKSRC}/examples/CMakeLists.txt
+
+.if !${PORT_OPTIONS:MEXAMPLES}
+ @${REINPLACE_CMD} -i '' -e '/add_subdirectory(examples)/d' \
+ ${WRKSRC}/CMakeLists.txt
+.endif
+
.include <bsd.port.mk>