aboutsummaryrefslogtreecommitdiff
path: root/graphics/aqsis/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-09 16:37:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-09 16:37:37 +0000
commit49ef7daedc0c4b4214e9df6087dd79fc3799421f (patch)
treeb912d82ca3c8ab3d97c3aaf7d49405ac6cf695af /graphics/aqsis/Makefile
parent3631d411454e9523994d1c27af6794254276b3a3 (diff)
downloadports-49ef7daedc0c4b4214e9df6087dd79fc3799421f.tar.gz
ports-49ef7daedc0c4b4214e9df6087dd79fc3799421f.zip
Notes
Diffstat (limited to 'graphics/aqsis/Makefile')
-rw-r--r--graphics/aqsis/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/aqsis/Makefile b/graphics/aqsis/Makefile
index 6dfbbc4a10c2..b751c3620fca 100644
--- a/graphics/aqsis/Makefile
+++ b/graphics/aqsis/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aqsis
PORTVERSION= 1.8.2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-source/${PORTVERSION}
@@ -18,11 +18,15 @@ BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
libtiff.so:${PORTSDIR}/graphics/tiff
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-USES= cmake:outsource desktop-file-utils shared-mime-info
+USES= cmake:outsource desktop-file-utils shared-mime-info shebangfix
+SHEBANG_FILES= examples/*/*/*.sh \
+ tools/neqsus/houdini/post.sh \
+ distribution/linux/*.sh
USE_QT4= opengl qmake_build moc_build rcc_build uic_build
PLIST_SUB+= LIBVERS=${PORTVERSION:R}