aboutsummaryrefslogtreecommitdiff
path: root/graphics/art
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-11-22 07:39:26 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-11-22 07:39:26 +0000
commitb992d0fa58090195b5cfebe5823d7e80873451f8 (patch)
treef89b82e5046ddf0be2c5c2932b15d27b12ead3d6 /graphics/art
parent40add23a093bc06db3a2627906b5fec88a235d1b (diff)
downloadports-b992d0fa58090195b5cfebe5823d7e80873451f8.tar.gz
ports-b992d0fa58090195b5cfebe5823d7e80873451f8.zip
Notes
Diffstat (limited to 'graphics/art')
-rw-r--r--graphics/art/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/graphics/art/Makefile b/graphics/art/Makefile
index 8511aa1fd34c..16daccea850b 100644
--- a/graphics/art/Makefile
+++ b/graphics/art/Makefile
@@ -27,15 +27,26 @@ USES= cmake compiler:c++11-lang desktop-file-utils gnome jpeg pkgconfig xorg
USE_GNOME= atk atkmm cairo cairomm glibmm gtkmm30 librsvg2
USE_XORG= x11
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+
INSTALLS_ICONS= yes
BB_ACCOUNT= agriggio
BB_PROJECT= art
BB_COMMIT= b2d77c8f0080
-WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+.include <bsd.port.pre.mk>
+
+# breaks with llvm-8
+.if ${CHOSEN_COMPILER_TYPE} == clang
+LLVM_VERSION= 10
+BUILD_DEPENDS+= clang${LLVM_VERSION}:devel/llvm${LLVM_VERSION}
+CC= clang${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+CPP= clang-cpp${LLVM_VERSION}
+.endif
post-install:
${RM} -r ${STAGEDIR}${PREFIX}/share/doc/ART
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>