aboutsummaryrefslogtreecommitdiff
path: root/graphics/autoq3d/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-10 16:24:36 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-10 16:24:36 +0000
commitc4d94d5101e7af31e13cfdbcae93131b51f238cd (patch)
tree63a715d6768c5e5dfb3271588a90facc67fb4b6b /graphics/autoq3d/Makefile
parent9e88578bd12cecf4b30e223185a12bcb6217034f (diff)
downloadports-c4d94d5101e7af31e13cfdbcae93131b51f238cd.tar.gz
ports-c4d94d5101e7af31e13cfdbcae93131b51f238cd.zip
Notes
Diffstat (limited to 'graphics/autoq3d/Makefile')
-rw-r--r--graphics/autoq3d/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/autoq3d/Makefile b/graphics/autoq3d/Makefile
index b32617f1a71f..b23271e3b3a2 100644
--- a/graphics/autoq3d/Makefile
+++ b/graphics/autoq3d/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= autoq3d
-DISTVERSION= 1.39
-PORTREVISION= 1
+DISTVERSION= 1.40
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/AutoQ3D%20${PORTVERSION}
DISTNAME= AutoQ3DCommunity${PORTVERSION:C/\./-/}qt4source
@@ -15,10 +14,14 @@ DISTNAME= AutoQ3DCommunity${PORTVERSION:C/\./-/}qt4source
MAINTAINER= ports@FreeBSD.org
COMMENT= A complete QT quick 3d model editor program
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
USE_ZIP= yes
USE_QT_VER= 4
QT_COMPONENTS= corelib gui opengl \
moc_build qmake_build
+MAKE_JOBS_SAFE= yes
DESKTOP_ENTRIES= "AutoQ3D" \
"A complete QT quick 3d model editor program" \
@@ -34,7 +37,7 @@ post-patch:
.endfor
do-configure:
- @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${QMAKESPEC}
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/AutoQ3D ${PREFIX}/bin