aboutsummaryrefslogtreecommitdiff
path: root/graphics/autoq3d
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-05-20 02:10:15 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-05-20 02:10:15 +0000
commitcb15105d415737e8522c9be05310b72da3c83c3a (patch)
treed8c4912e136bc6512c410b006265bf1fb13cff4f /graphics/autoq3d
parentc7bd24eb19d0b8c04adedf8f90c8ed9e51552b5f (diff)
downloadports-cb15105d415737e8522c9be05310b72da3c83c3a.tar.gz
ports-cb15105d415737e8522c9be05310b72da3c83c3a.zip
Notes
Diffstat (limited to 'graphics/autoq3d')
-rw-r--r--graphics/autoq3d/Makefile2
-rw-r--r--graphics/autoq3d/files/patch-AutoQ3D.pro10
-rw-r--r--graphics/autoq3d/files/patch-src__fgui__glapparea.cpp11
3 files changed, 23 insertions, 0 deletions
diff --git a/graphics/autoq3d/Makefile b/graphics/autoq3d/Makefile
index b23271e3b3a2..6d6a255d3e85 100644
--- a/graphics/autoq3d/Makefile
+++ b/graphics/autoq3d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= autoq3d
DISTVERSION= 1.40
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/AutoQ3D%20${PORTVERSION}
DISTNAME= AutoQ3DCommunity${PORTVERSION:C/\./-/}qt4source
@@ -17,6 +18,7 @@ COMMENT= A complete QT quick 3d model editor program
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+USE_GL= glu
USE_ZIP= yes
USE_QT_VER= 4
QT_COMPONENTS= corelib gui opengl \
diff --git a/graphics/autoq3d/files/patch-AutoQ3D.pro b/graphics/autoq3d/files/patch-AutoQ3D.pro
new file mode 100644
index 000000000000..d2e6e510229d
--- /dev/null
+++ b/graphics/autoq3d/files/patch-AutoQ3D.pro
@@ -0,0 +1,10 @@
+--- AutoQ3D.pro~ 2012-05-19 22:52:00.000000000 -0300
++++ AutoQ3D.pro 2012-05-19 22:56:52.000000000 -0300
+@@ -8,6 +8,7 @@
+ win32:LIBS+= -L$(QTDIR)/plugins/imageformats -lqjpeg4
+
+ QT += opengl
++LIBS += -lGLU
+ DEPENDPATH += . \
+ src \
+ src/cmds \
diff --git a/graphics/autoq3d/files/patch-src__fgui__glapparea.cpp b/graphics/autoq3d/files/patch-src__fgui__glapparea.cpp
new file mode 100644
index 000000000000..50ca56b1787e
--- /dev/null
+++ b/graphics/autoq3d/files/patch-src__fgui__glapparea.cpp
@@ -0,0 +1,11 @@
+--- src/fgui/glapparea.cpp~ 2012-05-19 22:54:35.000000000 -0300
++++ src/fgui/glapparea.cpp 2012-05-19 22:54:50.000000000 -0300
+@@ -24,6 +24,8 @@
+ #include <qtimer.h>
+ #include <math.h>
+
++#include <GL/glu.h>
++
+
+ GLAppArea::GLAppArea( QWidget* parent,QStringList* strlista)
+ : QGLWidget( parent)