aboutsummaryrefslogtreecommitdiff
path: root/graphics/autotrace/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-28 21:54:33 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-28 21:54:33 +0000
commit60b37dbedcfe6e22fe9a61ee8432ae7bd2780483 (patch)
tree42c5d548da07f10a85c92da3191700e6f34e6829 /graphics/autotrace/Makefile
parent83fd533649cd182142029432aebb1c591fd3f524 (diff)
downloadports-60b37dbedcfe6e22fe9a61ee8432ae7bd2780483.tar.gz
ports-60b37dbedcfe6e22fe9a61ee8432ae7bd2780483.zip
Notes
Diffstat (limited to 'graphics/autotrace/Makefile')
-rw-r--r--graphics/autotrace/Makefile31
1 files changed, 10 insertions, 21 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index c7402ef92329..fb6de2c80fc5 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -23,30 +23,19 @@ LDFLAGS+= $$(libpng-config --L_opts) ${PTHREAD_LIBS}
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= IMAGEMAGICK MING PSTOEDIT
-OPTIONS_DEFAULT= IMAGEMAGICK PSTOEDIT
+OPTIONS_DEFAULT=IMAGEMAGICK PSTOEDIT
MING_DESC= Enable swf interface
PSTOEDIT_DESC= Convert postscript to other formats
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MIMAGEMAGICK}
-LIB_DEPENDS+= libMagickWand-6.Q*.so:${PORTSDIR}/graphics/ImageMagick
-.else
-CONFIGURE_ARGS+= --without-magick
-.endif
-
-.if ${PORT_OPTIONS:MMING}
-LIB_DEPENDS+= libming.so:${PORTSDIR}/graphics/ming
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ming
-.else
-CONFIGURE_ENV+= ac_cv_header_ming_h=no
-.endif
-
-.if ${PORT_OPTIONS:MPSTOEDIT}
-LIB_DEPENDS+= libpstoedit.so:${PORTSDIR}/graphics/pstoedit
-.else
-CONFIGURE_ARGS+= --without-pstoedit
-.endif
+IMAGEMAGICK_LIB_DEPENDS= libMagickWand-6.Q*.so:${PORTSDIR}/graphics/ImageMagick
+IMAGEMAGICK_CONFIGURE_OFF= --without-magick
+
+MING_LIB_DEPENDS= libming.so:${PORTSDIR}/graphics/ming
+MING_CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/ming
+MING_CONFIGURE_OFF= ac_cv_header_ming_h=no
+
+PSTOEDIT_LIB_DEPENDS= libpstoedit.so:${PORTSDIR}/graphics/pstoedit
+PSTOEDIT_CONFIGURE_OFF= --without-pstoedit
post-patch:
@${REINPLACE_CMD} -e \