aboutsummaryrefslogtreecommitdiff
path: root/graphics/autotrace/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-06-15 13:10:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-06-15 13:10:58 +0000
commitbda5588150672990c41ff4ffe35d32b33c21b35a (patch)
tree15fd0274ba3ae4edf19d32aaf5c5e782c26de50b /graphics/autotrace/Makefile
parentf9205d3f3e685db4c400757713edce62229a8fc3 (diff)
downloadports-bda5588150672990c41ff4ffe35d32b33c21b35a.tar.gz
ports-bda5588150672990c41ff4ffe35d32b33c21b35a.zip
Notes
Diffstat (limited to 'graphics/autotrace/Makefile')
-rw-r--r--graphics/autotrace/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index 9b4a7cf4f203..5323cbddf6e8 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -7,7 +7,7 @@
PORTNAME= autotrace
PORTVERSION= 0.31.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,7 +21,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
pstoedit.0:${PORTSDIR}/graphics/pstoedit
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming"
@@ -29,9 +29,12 @@ USE_XLIB= yes
MAN1= autotrace.1
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e \
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/$$PSTOEDIT_CONFIG/ s|--version|--modversion| ; \
+ s|$$PSTOEDIT_CONFIG $$pstoedit_args|pkg-config pstoedit| ; \
+ /^PSTOEDIT_CONFIG=/ s|=.*$$|=pkg-config| ' ${WRKSRC}/configure
.include <bsd.port.mk>