aboutsummaryrefslogtreecommitdiff
path: root/graphics/autotrace
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-12-02 22:02:40 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-12-02 22:02:40 +0000
commit97f234dc38de7c39b61ee116e39312fec8f484dd (patch)
tree64ac37ef9777ec32339594b83da3526eb5809c15 /graphics/autotrace
parentf6e39a8319b5d106fc95511bdf834b97f6cddc1f (diff)
downloadports-97f234dc38de7c39b61ee116e39312fec8f484dd.tar.gz
ports-97f234dc38de7c39b61ee116e39312fec8f484dd.zip
Notes
Diffstat (limited to 'graphics/autotrace')
-rw-r--r--graphics/autotrace/Makefile6
-rw-r--r--graphics/autotrace/files/patch-input-magick.c11
2 files changed, 14 insertions, 3 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index bba55a5bf008..a239f474c9f2 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -7,21 +7,21 @@
PORTNAME= autotrace
PORTVERSION= 0.31.1
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert bitmap to vector graphics
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ MagickWand.1:${PORTSDIR}/graphics/ImageMagick
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming"
-CONFIGURE_ARGS= --without-magick
MAN1= autotrace.1
diff --git a/graphics/autotrace/files/patch-input-magick.c b/graphics/autotrace/files/patch-input-magick.c
new file mode 100644
index 000000000000..a20852dca7ce
--- /dev/null
+++ b/graphics/autotrace/files/patch-input-magick.c
@@ -0,0 +1,11 @@
+--- input-magick.c.orig 2008-12-02 22:58:14.000000000 +0100
++++ input-magick.c 2008-12-02 22:58:31.000000000 +0100
+@@ -83,7 +83,7 @@
+
+ for(j=0,runcount=0,point=0;j<image->rows;j++)
+ for(i=0;i<image->columns;i++) {
+- p=GetOnePixel(image,i,j);
++ GetOnePixel(image,i,j, pixel);
+ AT_BITMAP_BITS(bitmap)[point++]=pixel->red; /* if gray: red=green=blue */
+ if(np==3) {
+ AT_BITMAP_BITS(bitmap)[point++]=pixel->green;