aboutsummaryrefslogtreecommitdiff
path: root/graphics/autotrace
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-29 11:05:21 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-29 11:05:21 +0000
commitbd160ee26bf84a4b37a44f1948a9575ad4838864 (patch)
treee6b2984c5a9804f8dc54c6fac2e3cae1635d9774 /graphics/autotrace
parent8acecd427232897e4c551ef41156f7652edbca97 (diff)
downloadports-bd160ee26bf84a4b37a44f1948a9575ad4838864.tar.gz
ports-bd160ee26bf84a4b37a44f1948a9575ad4838864.zip
Notes
Diffstat (limited to 'graphics/autotrace')
-rw-r--r--graphics/autotrace/Makefile50
-rw-r--r--graphics/autotrace/files/patch-configure11
2 files changed, 26 insertions, 35 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index 2cf10079b150..fc60e43015ac 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: autotrace
-# Date created: 12 April 2001
-# Whom: KANOU Hiroki <kanou@mil.allnet.ne.jp>
-#
+# Created by: KANOU Hiroki <kanou@mil.allnet.ne.jp>
# $FreeBSD$
-#
PORTNAME= autotrace
PORTVERSION= 0.31.1
@@ -14,42 +10,48 @@ MASTER_SITES= SF/${PORTNAME}/AutoTrace/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert bitmap to vector graphics
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- MagickWand.5:${PORTSDIR}/graphics/ImageMagick
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= multi
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+
+OPTIONS_DEFINE= IMAGEMAGICK MING PSTOEDIT
+OPTIONS_DEFAULT= IMAGEMAGICK PSTOEDIT
+MING_DESC= Enable swf interface
+PSTOEDIT_DESC= Convert postscript to other formats
+
+USE_GNOME= gnomehack
+USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CPPFLAGS+= -I${LOCALBASE}/include/libpng15
+MAKE_JOBS_SAFE= yes
+CPPFLAGS+= $$(libpng-config --I_opts) ${PTHREAD_CFLAGS}
+LDFLAGS+= $$(libpng-config --L_opts) ${PTHREAD_LIBS}
MAN1= autotrace.1
-OPTIONS_DEFINE= MING PSTOEDIT
-OPTIONS_DEFAULT= PSTOEDIT
-MING_DESC= Enable swf interface
-PSTOEDIT_DESC= Convert postscript to other formats
-
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MIMAGEMAGICK}
+LIB_DEPENDS+= MagickWand:${PORTSDIR}/graphics/ImageMagick
+.else
+CONFIGURE_ARGS+= --without-magick
+.endif
+
.if ${PORT_OPTIONS:MMING}
-LIB_DEPENDS+= ming.5:${PORTSDIR}/graphics/ming
+LIB_DEPENDS+= ming:${PORTSDIR}/graphics/ming
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ming
.endif
.if ${PORT_OPTIONS:MPSTOEDIT}
-LIB_DEPENDS+= pstoedit.0:${PORTSDIR}/graphics/pstoedit
+LIB_DEPENDS+= pstoedit:${PORTSDIR}/graphics/pstoedit
.endif
post-patch:
@${REINPLACE_CMD} -e \
- 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in
-
-.if ${PORT_OPTIONS:MPSTOEDIT}
- @${REINPLACE_CMD} -e '/$$PSTOEDIT_CONFIG/ s|--version|--modversion| ; \
+ 's|Magick-config|MagickWand-config|g ; \
+ /$$PSTOEDIT_CONFIG/s|--version|--modversion| ; \
s|$$PSTOEDIT_CONFIG $$pstoedit_args|pkg-config pstoedit| ; \
- /^PSTOEDIT_CONFIG=/ s|=.*$$|=pkg-config| ' ${WRKSRC}/configure
-.endif
+ /^PSTOEDIT_CONFIG=/s|=.*$$|=pkg-config|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/autotrace/files/patch-configure b/graphics/autotrace/files/patch-configure
deleted file mode 100644
index 0b2ac58b06b3..000000000000
--- a/graphics/autotrace/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2008-09-26 15:52:26.000000000 +0200
-+++ configure 2008-09-26 15:52:09.000000000 +0200
-@@ -7973,7 +7973,7 @@
- MAGICK_CFLAGS=${CPPFLAGS}
- CPPFLAGS=${CPPFLAGS_BACKUP}
- if test "x${magick_header_found}" = xyes ; then
-- MAGICK_LDFLAGS="`Magick-config --ldflags` `Magick-config --libs`"
-+ MAGICK_LDFLAGS="`Magick-config --ldflags` `Magick-config --libs` `MagickWand-config --ldflags` `MagickWand-config --libs`"
- echo "$as_me:$LINENO: checking ImageMagick - version >= 5.2.1" >&5
- echo $ECHO_N "checking ImageMagick - version >= 5.2.1... $ECHO_C" >&6
- MAGICK_VERSION=`Magick-config --version`