aboutsummaryrefslogtreecommitdiff
path: root/graphics/autotrace
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2008-01-26 14:10:19 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2008-01-26 14:10:19 +0000
commitceb80dfeff81c2ba97c5138f6f585559fe08c643 (patch)
tree74e14b1d3a9a2c689ed72faa9688e2065148f994 /graphics/autotrace
parent3707b22cf989d75d715072d74c587a0d8fb6326b (diff)
downloadports-ceb80dfeff81c2ba97c5138f6f585559fe08c643.tar.gz
ports-ceb80dfeff81c2ba97c5138f6f585559fe08c643.zip
Notes
Diffstat (limited to 'graphics/autotrace')
-rw-r--r--graphics/autotrace/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index 5323cbddf6e8..17da74a38722 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -9,16 +9,12 @@ PORTNAME= autotrace
PORTVERSION= 0.31.1
PORTREVISION= 9
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert bitmap to vector graphics
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- ming.4:${PORTSDIR}/graphics/ming \
- Magick.10:${PORTSDIR}/graphics/ImageMagick \
- pstoedit.0:${PORTSDIR}/graphics/pstoedit
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
@@ -29,12 +25,27 @@ USE_XLIB= yes
MAN1= autotrace.1
+OPTIONS= MING "Enable swf interface" on \
+ PSTOEDIT "Convert postscript to other formats" on
+
+.if !defined (WITHOUT_MING)
+LIB_DEPENDS+= ming.4:${PORTSDIR}/graphics/ming
+CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming"
+.endif
+
+.if !defined (WITHOUT_PSTOEDIT)
+LIB_DEPENDS+= pstoedit.0:${PORTSDIR}/graphics/pstoedit
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
+
+.if defined (WITH_PSTOEDIT)
@${REINPLACE_CMD} -e '/$$PSTOEDIT_CONFIG/ s|--version|--modversion| ; \
s|$$PSTOEDIT_CONFIG $$pstoedit_args|pkg-config pstoedit| ; \
/^PSTOEDIT_CONFIG=/ s|=.*$$|=pkg-config| ' ${WRKSRC}/configure
+.endif
.include <bsd.port.mk>