aboutsummaryrefslogtreecommitdiff
path: root/graphics/blender
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-04-13 15:34:19 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-04-13 15:34:19 +0000
commit26a6160fe059fc74ad1d5730a112e45d4b14d5ae (patch)
treee44d93bc9223bc30da123cce55a41994bb9c75d9 /graphics/blender
parentab887551f5ed1bb4e2c98f06ef92a1f005506a4b (diff)
downloadports-26a6160fe059fc74ad1d5730a112e45d4b14d5ae.tar.gz
ports-26a6160fe059fc74ad1d5730a112e45d4b14d5ae.zip
Notes
Diffstat (limited to 'graphics/blender')
-rw-r--r--graphics/blender/Makefile8
-rw-r--r--graphics/blender/distinfo4
-rw-r--r--graphics/blender/files/patch-CMakeLists.txt10
-rw-r--r--graphics/blender/files/patch-extern_carve_include_mesh_ops.hpp14
-rw-r--r--graphics/blender/files/patch-source_blender_editors_sculpt_paint_paint_cursor.c34
5 files changed, 52 insertions, 18 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 35b2c989a94b..d5694cc0ff19 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= blender
-PORTVERSION= 2.70
+PORTVERSION= 2.70a
CATEGORIES= graphics games
MASTER_SITES= http://download.blender.org/source/ \
http://mirror.cs.umn.edu/blender.org/source/ \
@@ -32,6 +32,7 @@ SHEBANG_FILES= release/bin/blender-thumbnailer.py \
SUB_FILES= blender blenderplayer
+WRKSRC= ${WRKDIR}/${PORTNAME}-v${PORTVERSION}
OUTDIR= ${INSTALL_WRKSRC}/bin/2.70
.include "${.CURDIR}/Makefile.options"
@@ -91,7 +92,10 @@ LIBMV_CMAKE_OFF= -DWITH_LIBMV:BOOL=OFF
MENU_USES= desktop-file-utils
NLS_CMAKE_ON= -DWITH_INTERNATIONAL:BOOL=ON
NLS_CMAKE_OFF= -DWITH_INTERNATIONAL:BOOL=OFF
-NLS_USES= gettext iconv
+# Use iconv:wchar_t to force the usage of iconv from ports.
+# libboost_locale.so uses libiconv_open, while we only provide
+# iconv_open in 10.x+
+NLS_USES= gettext iconv:lib,wchar_t
OPENCOLORIO_CMAKE_ON= -DWITH_OPENCOLORIO:BOOL=ON
OPENCOLORIO_CMAKE_OFF= -DWITH_OPENCOLORIO:BOOL=OFF
OPENCOLORIO_LIB_DEPENDS= libOpenColorIO.so:${PORTSDIR}/graphics/opencolorio
diff --git a/graphics/blender/distinfo b/graphics/blender/distinfo
index b770b7f4478c..ea13844bcdef 100644
--- a/graphics/blender/distinfo
+++ b/graphics/blender/distinfo
@@ -1,2 +1,2 @@
-SHA256 (blender-2.70.tar.gz) = 2695c3cab21721d1108c90e6e9cb4b279817f551904d5276793fb3adaef3e348
-SIZE (blender-2.70.tar.gz) = 55298021
+SHA256 (blender-2.70a.tar.gz) = eb2d82e4bace4028e05eef2ac9799104231eafd91f1500b91c32471bac8cf3e5
+SIZE (blender-2.70a.tar.gz) = 55875629
diff --git a/graphics/blender/files/patch-CMakeLists.txt b/graphics/blender/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..b93b88311399
--- /dev/null
+++ b/graphics/blender/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- CMakeLists.txt.orig 2014-04-13 12:03:21.000000000 +0200
++++ CMakeLists.txt 2014-04-13 12:13:07.000000000 +0200
+@@ -740,6 +740,7 @@
+ set(__boost_packages filesystem regex system thread date_time)
+ if(WITH_INTERNATIONAL)
+ list(APPEND __boost_packages locale)
++ set(PLATFORM_LINKFLAGS "${PLATFORM_LINKFLAGS} -liconv") # boost_locale needs it !
+ endif()
+ if(WITH_CYCLES_NETWORK)
+ list(APPEND __boost_packages serialization)
diff --git a/graphics/blender/files/patch-extern_carve_include_mesh_ops.hpp b/graphics/blender/files/patch-extern_carve_include_mesh_ops.hpp
deleted file mode 100644
index 691b502c3612..000000000000
--- a/graphics/blender/files/patch-extern_carve_include_mesh_ops.hpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- extern/carve/include/carve/mesh_ops.hpp.orig 2014-03-22 13:19:46.000000000 +0100
-+++ extern/carve/include/carve/mesh_ops.hpp 2014-03-22 13:20:36.000000000 +0100
-@@ -580,8 +580,10 @@
- std::vector<VertexInfo *> queue;
-
- void checkheap() {
--#ifdef __GNUC__
-+#if defined(__GNUC__) && !defined(__clang__)
- CARVE_ASSERT(std::__is_heap(queue.begin(), queue.end(), order_by_score()));
-+#elif defined(__clang__) && defined(_LIBCPP_VERSION)
-+ CARVE_ASSERT(std::is_heap(queue.begin(), queue.end(), order_by_score()));
- #endif
- }
-
diff --git a/graphics/blender/files/patch-source_blender_editors_sculpt_paint_paint_cursor.c b/graphics/blender/files/patch-source_blender_editors_sculpt_paint_paint_cursor.c
new file mode 100644
index 000000000000..e987765ee38e
--- /dev/null
+++ b/graphics/blender/files/patch-source_blender_editors_sculpt_paint_paint_cursor.c
@@ -0,0 +1,34 @@
+--- source/blender/editors/sculpt_paint/paint_cursor.c.orig 2014-04-12 23:54:53.000000000 +0200
++++ source/blender/editors/sculpt_paint/paint_cursor.c 2014-04-12 23:58:59.000000000 +0200
+@@ -210,6 +210,13 @@
+ int i;
+ float y;
+ float len;
++ int thread_num;
++
++#ifdef _OPENMP
++ thread_num = omp_get_thread_num();
++#else
++ thread_num = 0;
++#endif
+
+ for (i = 0; i < size; i++) {
+
+@@ -249,7 +256,7 @@
+ if (col) {
+ float rgba[4];
+
+- paint_get_tex_pixel_col(mtex, x, y, rgba, pool, omp_get_thread_num());
++ paint_get_tex_pixel_col(mtex, x, y, rgba, pool, thread_num);
+
+ buffer[index * 4] = rgba[0] * 255;
+ buffer[index * 4 + 1] = rgba[1] * 255;
+@@ -257,7 +264,7 @@
+ buffer[index * 4 + 3] = rgba[3] * 255;
+ }
+ else {
+- float avg = paint_get_tex_pixel(mtex, x, y, pool, omp_get_thread_num());
++ float avg = paint_get_tex_pixel(mtex, x, y, pool, thread_num);
+
+ avg += br->texture_sample_bias;
+