aboutsummaryrefslogtreecommitdiff
path: root/graphics/blender
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-03-13 19:21:34 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-03-13 19:21:34 +0000
commit7a67beae576430d075cc2be1dd580d869deefa60 (patch)
tree06e44f611b6075b5953d8146fed1164e4a7589eb /graphics/blender
parent957a11558e3b173bb5b28c5d88442e08407bd71c (diff)
downloadports-7a67beae576430d075cc2be1dd580d869deefa60.tar.gz
ports-7a67beae576430d075cc2be1dd580d869deefa60.zip
Notes
Diffstat (limited to 'graphics/blender')
-rw-r--r--graphics/blender/Makefile33
-rw-r--r--graphics/blender/distinfo4
-rw-r--r--graphics/blender/files/blender.in8
-rw-r--r--graphics/blender/files/blenderplayer.in8
-rw-r--r--graphics/blender/files/patch-intern_cycles_render_osl.cpp11
-rw-r--r--graphics/blender/files/patch-intern_ffmpeg_compat.h44
6 files changed, 60 insertions, 48 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 48dd02e0df4a..750d9a0f4281 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= blender
-PORTVERSION= 2.65a
-PORTREVISION= 4
+PORTVERSION= 2.66a
CATEGORIES= graphics games
MASTER_SITES= http://download.blender.org/source/ \
http://mirror.cs.umn.edu/blender.org/source/ \
@@ -31,16 +30,13 @@ CMAKE_ARGS+= -DWITH_PYTHON_INSTALL:BOOL=OFF \
SUB_FILES= blender blenderplayer
MAN1= blender.1
-OUTDIR= ${INSTALL_WRKSRC}/bin/2.65
+OUTDIR= ${INSTALL_WRKSRC}/bin/2.66
-LANG= ar cs de eo es es_ES fa fr he hr hu id it ja ky nl pt pt_BR ru \
- sr sr@latin sv tr uk zh_CN zh_TW
-
-OPTIONS_DEFINE= BOOLEAN BULLET CINEON CAMERATRACK CYCLES CYCLESOSL DDS FFMPEG \
- FFTW3 GAMEENGINE HDR HEADLESS JACK NLS MENU OCEANSIM OPENAL \
+OPTIONS_DEFINE= BOOLEAN BULLET CINEON CAMERATRACK COMPOSITOR CYCLES CYCLESOSL \
+ DDS FFMPEG FFTW3 GAMEENGINE HDR HEADLESS JACK NLS MENU OCEANSIM OPENAL \
OPENCOLORIO OPENEXR OPENJPEG OPENMP PLAYER RAYOPTIMIZATION \
REDCODE SAMPLERATE SDL SNDFILE TIFF XINPUT XF86VMODE
-OPTIONS_DEFAULT= BOOLEAN BULLET CINEON CYCLES CYCLESOSL DDS GAMEENGINE \
+OPTIONS_DEFAULT= BOOLEAN BULLET CINEON COMPOSITOR CYCLES CYCLESOSL DDS GAMEENGINE \
HDR JACK OPENAL OPENCOLORIO OPENEXR OPENJPEG OPENMP \
PLAYER SAMPLERATE SDL TIFF XINPUT XF86VMODE
@@ -48,6 +44,7 @@ BOOLEAN_DESC= Boolean library support
BULLET_DESC= Bullet physics engine
CINEON_DESC= CINEON and DPX graphics format support
CAMERATRACK_DESC= Camera tracking support
+COMPOSITOR_DESC= Use the tile-based nodal compositor
CYCLES_DESC= Cycles render engine support
CYCLESOSL_DESC= Shading support for the cycles render engine
DDS_DESC= DDS graphics format support
@@ -65,10 +62,6 @@ SDL_DESC= Audio and Joystick support using SDL
XINPUT_DESC= X11 Xinput (tablet) support
XF86VMODE_DESC= X11 video mode switching support
-# TODO: provide switches for the following options
-#
-# WITH_IMAGE_FRAMESERVER WITH_LZO WITH_LZMA WITH_LIBMV WITH_INPUT_NDOF
-
.include <bsd.port.options.mk>
. if ${PORT_OPTIONS:MBOOLEAN}
@@ -97,6 +90,12 @@ LIB_DEPENDS+= unwind:${PORTSDIR}/devel/libunwind
CMAKE_ARGS+= -DWITH_LIBMV:BOOL=OFF
.endif
+.if ${PORT_OPTIONS:MCOMPOSITOR}
+CMAKE_ARGS+= -DWITH_COMPOSITOR:BOOL=ON
+.else
+CMAKE_ARGS+= -DWITH_COMPOSITOR:BOOL=OFF
+.endif
+
# openimageio to enable cycles requires 8.0 or higher
.if ${PORT_OPTIONS:MCYCLES}
.if ${OSVERSION} < 800000
@@ -336,12 +335,8 @@ post-install:
.endif
.if ${PORT_OPTIONS:MNLS}
-.for ii in ${LANG}
- @${MKDIR} ${DATADIR}/datafiles/locale/${ii}/LC_MESSAGES
- @${INSTALL_DATA} \
- ${OUTDIR}/datafiles/locale/${ii}/LC_MESSAGES/${PORTNAME}.mo \
- ${DATADIR}/datafiles/locale/${ii}/LC_MESSAGES/${PORTNAME}.mo
-.endfor
+ @cd ${OUTDIR} && ${COPYTREE_SHARE} datafiles/locale ${DATADIR}
+ @(cd ${OUTDIR}; ${FIND} datafiles/locale -type f -name languages) | ${SORT} | ${SED} "s|^|${DATADIR_REL}/|" >> ${TMPPLIST}
@(cd ${OUTDIR}; ${FIND} datafiles/locale -type f -name ${PORTNAME}.mo) | ${SORT} | ${SED} "s|^|${DATADIR_REL}/|" >> ${TMPPLIST}
@(cd ${OUTDIR}; ${FIND} datafiles/locale -type d) | ${SORT} -r | ${SED} "s|^|@dirrm ${DATADIR_REL}/|" >> ${TMPPLIST}
diff --git a/graphics/blender/distinfo b/graphics/blender/distinfo
index 337da7075f54..0f653f0c358e 100644
--- a/graphics/blender/distinfo
+++ b/graphics/blender/distinfo
@@ -1,2 +1,2 @@
-SHA256 (blender-2.65a.tar.gz) = f8cab44715096c6220a485877db340f28982cf56780199a5d188588dd7d7f6dc
-SIZE (blender-2.65a.tar.gz) = 31841541
+SHA256 (blender-2.66a.tar.gz) = 8b6136755c024ca75a9c04f9db6e63fd101968fdfcd43c98d43bc7327bea4872
+SIZE (blender-2.66a.tar.gz) = 36911037
diff --git a/graphics/blender/files/blender.in b/graphics/blender/files/blender.in
index a1ca63d18179..46eeed9ea09d 100644
--- a/graphics/blender/files/blender.in
+++ b/graphics/blender/files/blender.in
@@ -2,12 +2,4 @@
export BLENDER_SYSTEM_SCRIPTS=%%DATADIR%%/scripts
export BLENDER_SYSTEM_DATAFILES=%%DATADIR%%/datafiles
-
-if [ -L ${HOME}/.blender ]; then
- echo "A symbolic link for ~/.blender was detected."
- echo "Due to security restrictions, blender can not be"
- echo "started until you have removed the link."
- exit 1
-fi
-
exec %%PREFIX%%/bin/blender-bin "$@"
diff --git a/graphics/blender/files/blenderplayer.in b/graphics/blender/files/blenderplayer.in
index ead8a5cc1733..ecd17e320e7b 100644
--- a/graphics/blender/files/blenderplayer.in
+++ b/graphics/blender/files/blenderplayer.in
@@ -2,12 +2,4 @@
export BLENDER_SYSTEM_SCRIPTS=%%DATADIR%%/scripts
export BLENDER_SYSTEM_DATAFILES=%%DATADIR%%/datafiles
-
-if [ -L ${HOME}/.blender ]; then
- echo "A symbolic link for ~/.blender was detected."
- echo "Due to security restrictions, blenderplayer can not be"
- echo "started until you have removed the link."
- exit 1
-fi
-
exec %%PREFIX%%/bin/blenderplayer-bin "$@"
diff --git a/graphics/blender/files/patch-intern_cycles_render_osl.cpp b/graphics/blender/files/patch-intern_cycles_render_osl.cpp
deleted file mode 100644
index 673affc4c92f..000000000000
--- a/graphics/blender/files/patch-intern_cycles_render_osl.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- intern/cycles/render/osl.cpp.orig 2013-02-02 23:31:36.000000000 +0100
-+++ intern/cycles/render/osl.cpp 2013-02-02 23:31:56.000000000 +0100
-@@ -277,7 +277,7 @@
-
- const char *OSLShaderManager::shader_load_bytecode(const string& hash, const string& bytecode)
- {
-- ss->LoadMemoryShader(hash.c_str(), bytecode.c_str());
-+ ss->LoadMemoryCompiledShader(hash.c_str(), bytecode.c_str());
-
- /* this is a bit weak, but works */
- OSLShaderInfo info;
diff --git a/graphics/blender/files/patch-intern_ffmpeg_compat.h b/graphics/blender/files/patch-intern_ffmpeg_compat.h
new file mode 100644
index 000000000000..59b8a07ad16e
--- /dev/null
+++ b/graphics/blender/files/patch-intern_ffmpeg_compat.h
@@ -0,0 +1,44 @@
+--- intern/ffmpeg/ffmpeg_compat.h.orig 2013-03-06 17:47:13.000000000 +0100
++++ intern/ffmpeg/ffmpeg_compat.h 2013-03-06 17:49:33.000000000 +0100
+@@ -113,14 +113,14 @@
+ #define avformat_close_input(x) av_close_input_file(*(x))
+ #endif
+
+-#if ((LIBAVCODEC_VERSION_MAJOR < 53) || (LIBAVCODEC_VERSION_MAJOR == 53 && LIBAVCODEC_VERSION_MINOR < 35))
+-static inline
+-int avcodec_open2(AVCodecContext *avctx, AVCodec *codec, AVDictionary **options)
+-{
+- /* TODO: no options are taking into account */
+- return avcodec_open(avctx, codec);
+-}
+-#endif
++// #if ((LIBAVCODEC_VERSION_MAJOR < 53) || (LIBAVCODEC_VERSION_MAJOR == 53 && LIBAVCODEC_VERSION_MINOR < 35))
++// static inline
++// int avcodec_open2(AVCodecContext *avctx, AVCodec *codec, AVDictionary **options)
++// {
++// /* TODO: no options are taking into account */
++// return avcodec_open(avctx, codec);
++// }
++// #endif
+
+ #if ((LIBAVFORMAT_VERSION_MAJOR < 53) || (LIBAVFORMAT_VERSION_MAJOR == 53 && LIBAVFORMAT_VERSION_MINOR < 21))
+ static inline
+@@ -130,12 +130,12 @@
+ return av_new_stream(s, 0);
+ }
+
+-static inline
+-int avformat_find_stream_info(AVFormatContext *ic, AVDictionary **options)
+-{
+- /* TODO: no options are taking into account */
+- return av_find_stream_info(ic);
+-}
++// static inline
++// int avformat_find_stream_info(AVFormatContext *ic, AVDictionary **options)
++// {
++// /* TODO: no options are taking into account */
++// return av_find_stream_info(ic);
++// }
+ #endif
+
+ #if ((LIBAVFORMAT_VERSION_MAJOR > 53) || ((LIBAVFORMAT_VERSION_MAJOR == 53) && (LIBAVFORMAT_VERSION_MINOR > 32)) || ((LIBAVFORMAT_VERSION_MAJOR == 53) && (LIBAVFORMAT_VERSION_MINOR == 24) && (LIBAVFORMAT_VERSION_MICRO >= 100)))