aboutsummaryrefslogtreecommitdiff
path: root/graphics/blender
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-05-19 12:36:00 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-05-19 12:36:00 +0000
commitefd0bfb812d452179703d83b41607b263bcb90a7 (patch)
tree43fdb71253bff560fb13652267ac39f2d85ba1c1 /graphics/blender
parentd97d6aaa95bdd6b51ba24af4af5451b3887bb082 (diff)
downloadports-efd0bfb812d452179703d83b41607b263bcb90a7.tar.gz
ports-efd0bfb812d452179703d83b41607b263bcb90a7.zip
Notes
Diffstat (limited to 'graphics/blender')
-rw-r--r--graphics/blender/Makefile113
-rw-r--r--graphics/blender/Makefile.options107
-rw-r--r--graphics/blender/distinfo4
-rw-r--r--graphics/blender/files/patch-intern_ffmpeg_compat.h42
4 files changed, 199 insertions, 67 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 2e72b459a6eb..def58200ef7d 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= blender
-PORTVERSION= 2.66a
+PORTVERSION= 2.67
CATEGORIES= graphics games
MASTER_SITES= http://download.blender.org/source/ \
http://mirror.cs.umn.edu/blender.org/source/ \
@@ -19,7 +19,6 @@ USE_XORG= x11 xext xmu
USE_GL= glew
USES= cmake:outsource
USE_PYTHON= 3.3
-WANT_GNOME= yes
MAKE_JOBS_SAFE= yes
@@ -29,47 +28,47 @@ CMAKE_ARGS+= -DWITH_PYTHON_INSTALL:BOOL=OFF \
SUB_FILES= blender blenderplayer
MAN1= blender.1
-OUTDIR= ${INSTALL_WRKSRC}/bin/2.66
-
-OPTIONS_DEFINE= BOOLEAN BULLET CINEON CAMERATRACK COMPOSITOR CYCLES CYCLESOSL \
- DDS FFMPEG FFTW3 GAMEENGINE HDR HEADLESS JACK NLS MENU OCEANSIM OPENAL \
- OPENCOLORIO OPENEXR OPENJPEG OPENMP PLAYER RAYOPTIMIZATION \
- REDCODE SAMPLERATE SDL SNDFILE TIFF XINPUT XF86VMODE
-OPTIONS_DEFAULT= BOOLEAN BULLET CINEON COMPOSITOR CYCLES CYCLESOSL DDS GAMEENGINE \
- HDR JACK OPENAL OPENCOLORIO OPENEXR OPENJPEG OPENMP \
- PLAYER SAMPLERATE SDL TIFF XINPUT XF86VMODE
-
-BOOLEAN_DESC= Boolean library support
-BULLET_DESC= Bullet physics engine
-CINEON_DESC= CINEON and DPX graphics format support
-CAMERATRACK_DESC= Camera tracking support
-COMPOSITOR_DESC= Use the tile-based nodal compositor
-CYCLES_DESC= Cycles render engine support
-CYCLESOSL_DESC= Shading support for the cycles render engine
-DDS_DESC= DDS graphics format support
-FFTW3_DESC= Use fftw for smoke and audio effects
-GAMEENGINE_DESC= Enable the game engine
-HDR_DESC= Generic high dynamic-range (HDR) support
-HEADLESS_DESC= Disable user interface (for render-farms)
-MENU_DESC= Install desktop menu
-OCEANSIM_DESC= Ocean simulation support
-OPENCOLORIO_DESC= OpenColorIO-based color management support
-PLAYER_DESC= Enable blender player
-RAYOPTIMIZATION_DESC= Enable SSE optimizatons for raytracing
-REDCODE_DESC= RedCode graphics format support
-SDL_DESC= Audio and Joystick support using SDL
-XINPUT_DESC= X11 Xinput (tablet) support
-XF86VMODE_DESC= X11 video mode switching support
+OUTDIR= ${INSTALL_WRKSRC}/bin/2.67
+
+.include "${.CURDIR}/Makefile.options"
.include <bsd.port.options.mk>
-. if ${PORT_OPTIONS:MBOOLEAN}
+. if ${PORT_OPTIONS:MMOD_BOOLEAN}
CMAKE_ARGS+= -DWITH_MOD_BOOLEAN:BOOL=ON
LIB_DEPENDS+= boost_thread:${PORTSDIR}/devel/boost-libs
.else
CMAKE_ARGS+= -DWITH_MOD_BOOLEAN:BOOL=OFF
.endif
+.if ${PORT_OPTIONS:MMOD_FLUID}
+CMAKE_ARGS+= -DWITH_MOD_FLUID:BOOL=ON
+.else
+CMAKE_ARGS+= -DWITH_MOD_FLUID:BOOL=OFF
+.endif
+
+.if ${PORT_OPTIONS:MMOD_REMESH}
+CMAKE_ARGS+= -DWITH_MOD_REMESH:BOOL=ON
+.else
+CMAKE_ARGS+= -DWITH_MOD_REMESH:BOOL=OFF
+.endif
+
+.if ${PORT_OPTIONS:MMOD_SMOKE}
+CMAKE_ARGS+= -DWITH_MOD_SMOKE:BOOL=ON
+.else
+CMAKE_ARGS+= -DWITH_MOD_SMOKE:BOOL=OFF
+.endif
+
+.if ${PORT_OPTIONS:MMOD_OCEANSIM}
+.if ${PORT_OPTIONS:MFFTW3}
+CMAKE_ARGS+= -DWITH_MOD_OCEANSIM:BOOL=ON
+.else
+BROKEN= MOD_OCEANSIM requires FFTW3
+.endif
+.else
+CMAKE_ARGS+= -DWITH_MOD_OCEANSIM:BOOL=OFF
+.endif
+
.if ${PORT_OPTIONS:MBULLET}
CMAKE_ARGS+= -DWITH_BULLET:BOOL=ON
.else
@@ -101,6 +100,9 @@ CMAKE_ARGS+= -DWITH_COMPOSITOR:BOOL=OFF
IGNORE= cycles render engine only works in FreeBSD 8 or later
.endif
CMAKE_ARGS+= -DWITH_CYCLES:BOOL=ON
+.if !${PORT_OPTIONS:MOPENEXR} || !${PORT_OPTIONS:MTIFF}
+BROKEN= CYCLES requires OPENEXR and TIFF
+.endif
LIB_DEPENDS+= OpenImageIO:${PORTSDIR}/graphics/openimageio
.else
CMAKE_ARGS+= -DWITH_CYCLES:BOOL=OFF
@@ -136,6 +138,12 @@ CMAKE_ARGS+= -DWITH_FFTW3:BOOL=ON
CMAKE_ARGS+= -DWITH_FFTW3:BOOL=OFF
.endif
+.if ${PORT_OPTIONS:MFRAMESERVER}
+CMAKE_ARGS+= -DWITH_IMAGE_FRAMESERVER:BOOL=ON
+.else
+CMAKE_ARGS+= -DWITH_IMAGE_FRAMESERVER:BOOL=OFF
+.endif
+
.if ${PORT_OPTIONS:MGAMEENGINE}
CMAKE_ARGS+= -DWITH_GAMEENGINE:BOOL=ON
.else
@@ -149,11 +157,20 @@ CMAKE_ARGS+= -DWITH_IMAGE_HDR:BOOL=OFF
.endif
.if ${PORT_OPTIONS:MHEADLESS}
+.if ${PORT_OPTIONS:MXINPUT} || ${PORT_OPTIONS:MXF86VMODE}
+BROKEN= HEADLESS does not require any X11 dependency
+.endif
CMAKE_ARGS+= -DWITH_HEADLESS:BOOL=ON
.else
CMAKE_ARGS+= -DWITH_HEADLESS:BOOL=OFF
.endif
+.if ${PORT_OPTIONS:MINPUT_NDOF}
+CMAKE_ARGS+= -DWITH_INPUT_NDOF:BOOL=ON
+.else
+CMAKE_ARGS+= -DWITH_INPUT_NDOF:BOOL=OFF
+.endif
+
.if ${PORT_OPTIONS:MJACK}
LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
CMAKE_ARGS+= -DWITH_JACK:BOOL=ON
@@ -161,6 +178,24 @@ CMAKE_ARGS+= -DWITH_JACK:BOOL=ON
CMAKE_ARGS+= -DWITH_JACK:BOOL=OFF
.endif
+.if ${PORT_OPTIONS:MLZO}
+CMAKE_ARGS+= -DWITH_LZO:BOOL=ON
+.else
+CMAKE_ARGS+= -DWITH_LZO:BOOL=OFF
+.endif
+
+.if ${PORT_OPTIONS:MLZMA}
+CMAKE_ARGS+= -DWITH_LZMA:BOOL=ON
+.else
+CMAKE_ARGS+= -DWITH_LZMA:BOOL=OFF
+.endif
+
+.if ${PORT_OPTIONS:MLIBMV}
+CMAKE_ARGS+= -DWITH_LIBMV:BOOL=ON
+.else
+CMAKE_ARGS+= -DWITH_LIBMV:BOOL=OFF
+.endif
+
.if ${PORT_OPTIONS:MMENU}
USE_GNOME= desktopfileutils
.endif
@@ -172,16 +207,6 @@ CMAKE_ARGS+= -DWITH_INTERNATIONAL:BOOL=ON
CMAKE_ARGS+= -DWITH_INTERNATIONAL:BOOL=OFF
.endif
-.if ${PORT_OPTIONS:MOCEANSIM}
-.if ${PORT_OPTIONS:MFFTW3}
-CMAKE_ARGS+= -DWITH_MOD_OCEANSIM:BOOL=ON
-.else
-BROKEN= OCEANSIM requires FFTW3
-.endif
-.else
-CMAKE_ARGS+= -DWITH_MOD_OCEANSIM:BOOL=OFF
-.endif
-
.if ${PORT_OPTIONS:MOPENAL}
.if ${PORT_OPTIONS:MSAMPLERATE}
USE_OPENAL= al alut
diff --git a/graphics/blender/Makefile.options b/graphics/blender/Makefile.options
new file mode 100644
index 000000000000..b0c534b54418
--- /dev/null
+++ b/graphics/blender/Makefile.options
@@ -0,0 +1,107 @@
+# $FreeBSD$
+
+OPTIONS_DEFINE= \
+ BULLET \
+ CINEON \
+ CAMERATRACK \
+ COMPOSITOR \
+ CYCLES \
+ CYCLESOSL \
+ DDS \
+ FFMPEG \
+ FFTW3 \
+ FRAMESERVER \
+ FREESTYLE \
+ GAMEENGINE \
+ HDR \
+ HEADLESS \
+ INPUT_NDOF \
+ JACK \
+ LIBMV \
+ LZO \
+ LZMA \
+ MENU \
+ MOD_BOOLEAN \
+ MOD_FLUID \
+ MOD_OCEANSIM \
+ MOD_REMESH \
+ MOD_SMOKE \
+ NLS \
+ OPENAL \
+ OPENCOLORIO \
+ OPENEXR \
+ OPENJPEG \
+ OPENMP \
+ PLAYER \
+ RAYOPTIMIZATION \
+ REDCODE \
+ SAMPLERATE \
+ SDL \
+ SNDFILE \
+ TIFF \
+ XINPUT \
+ XF86VMODE
+
+OPTIONS_DEFAULT= \
+ BULLET \
+ CINEON \
+ COMPOSITOR \
+ CYCLES \
+ CYCLESOSL \
+ DDS \
+ FFTW3 \
+ FRAMESERVER \
+ FREESTYLE \
+ GAMEENGINE \
+ HDR \
+ INPUT_NDOF \
+ LIBMV \
+ LZO \
+ LZMA \
+ MOD_BOOLEAN \
+ MOD_FLUID \
+ MOD_REMESH \
+ MOD_SMOKE \
+ OPENAL \
+ OPENCOLORIO \
+ OPENEXR \
+ OPENJPEG \
+ OPENMP \
+ PLAYER \
+ SAMPLERATE \
+ SDL \
+ TIFF \
+ XINPUT \
+ XF86VMODE
+
+BULLET_DESC= Bullet physics engine
+CINEON_DESC= CINEON and DPX graphics format support
+CAMERATRACK_DESC= Camera tracking support
+COMPOSITOR_DESC= Use the tile-based nodal compositor
+CYCLES_DESC= Cycles render engine support
+CYCLESOSL_DESC= Shading support for the cycles render engine
+DDS_DESC= DDS graphics format support
+FFTW3_DESC= Use fftw for smoke and audio effects
+FRAMESERVER_DESC= Image FrameServer support for rendering
+FREESTYLE_DESC= Enable advanced edges rendering
+GAMEENGINE_DESC= Enable the game engine
+HDR_DESC= Generic high dynamic-range (HDR) support
+HEADLESS_DESC= Disable user interface (for render-farms)
+INPUT_NDOF_DESC= Enable NDOF input device support
+LIBMV_DESC= Enable motion tracking via libmv
+LZO_DESC= Fast compression support
+LZMA_DESC= Best compression support
+MENU_DESC= Install desktop menu
+MOD_BOOLEAN_DESC= Boolean modifier support
+MOD_FLUID_DESC= Fluid simulation support
+MOD_OCEANSIM_DESC= Ocean simulation support
+MOD_REMESH_DESC= Remesh modifier support
+MOD_SMOKE_DESC= Smoke simulation support
+OPENCOLORIO_DESC= OpenColorIO-based color management support
+PLAYER_DESC= Enable blender player
+RAYOPTIMIZATION_DESC= Enable SSE optimizatons for raytracing
+REDCODE_DESC= RedCode graphics format support
+SDL_DESC= Audio and Joystick support using SDL
+XINPUT_DESC= X11 Xinput (tablet) support
+XF86VMODE_DESC= X11 video mode switching support
+
diff --git a/graphics/blender/distinfo b/graphics/blender/distinfo
index 0f653f0c358e..411cda1373bb 100644
--- a/graphics/blender/distinfo
+++ b/graphics/blender/distinfo
@@ -1,2 +1,2 @@
-SHA256 (blender-2.66a.tar.gz) = 8b6136755c024ca75a9c04f9db6e63fd101968fdfcd43c98d43bc7327bea4872
-SIZE (blender-2.66a.tar.gz) = 36911037
+SHA256 (blender-2.67.tar.gz) = 14a9d4be5e4f4d6982202ba4039c7182b588a11cb9af83827ea590826ae6d418
+SIZE (blender-2.67.tar.gz) = 41381712
diff --git a/graphics/blender/files/patch-intern_ffmpeg_compat.h b/graphics/blender/files/patch-intern_ffmpeg_compat.h
index 59b8a07ad16e..67a169addf40 100644
--- a/graphics/blender/files/patch-intern_ffmpeg_compat.h
+++ b/graphics/blender/files/patch-intern_ffmpeg_compat.h
@@ -1,44 +1,44 @@
---- intern/ffmpeg/ffmpeg_compat.h.orig 2013-03-06 17:47:13.000000000 +0100
-+++ intern/ffmpeg/ffmpeg_compat.h 2013-03-06 17:49:33.000000000 +0100
-@@ -113,14 +113,14 @@
+--- intern/ffmpeg/ffmpeg_compat.h.orig 2013-05-09 10:51:58.000000000 +0200
++++ intern/ffmpeg/ffmpeg_compat.h 2013-05-09 10:53:27.000000000 +0200
+@@ -179,14 +179,14 @@
#define avformat_close_input(x) av_close_input_file(*(x))
#endif
-#if ((LIBAVCODEC_VERSION_MAJOR < 53) || (LIBAVCODEC_VERSION_MAJOR == 53 && LIBAVCODEC_VERSION_MINOR < 35))
--static inline
+-FFMPEG_INLINE
-int avcodec_open2(AVCodecContext *avctx, AVCodec *codec, AVDictionary **options)
-{
- /* TODO: no options are taking into account */
- return avcodec_open(avctx, codec);
-}
-#endif
-+// #if ((LIBAVCODEC_VERSION_MAJOR < 53) || (LIBAVCODEC_VERSION_MAJOR == 53 && LIBAVCODEC_VERSION_MINOR < 35))
-+// static inline
-+// int avcodec_open2(AVCodecContext *avctx, AVCodec *codec, AVDictionary **options)
-+// {
-+// /* TODO: no options are taking into account */
-+// return avcodec_open(avctx, codec);
-+// }
-+// #endif
++//#if ((LIBAVCODEC_VERSION_MAJOR < 53) || (LIBAVCODEC_VERSION_MAJOR == 53 && LIBAVCODEC_VERSION_MINOR < 35))
++//FFMPEG_INLINE
++//int avcodec_open2(AVCodecContext *avctx, AVCodec *codec, AVDictionary **options)
++//{
++// /* TODO: no options are taking into account */
++// return avcodec_open(avctx, codec);
++//}
++//#endif
#if ((LIBAVFORMAT_VERSION_MAJOR < 53) || (LIBAVFORMAT_VERSION_MAJOR == 53 && LIBAVFORMAT_VERSION_MINOR < 21))
- static inline
-@@ -130,12 +130,12 @@
+ FFMPEG_INLINE
+@@ -196,12 +196,12 @@
return av_new_stream(s, 0);
}
--static inline
+-FFMPEG_INLINE
-int avformat_find_stream_info(AVFormatContext *ic, AVDictionary **options)
-{
- /* TODO: no options are taking into account */
- return av_find_stream_info(ic);
-}
-+// static inline
-+// int avformat_find_stream_info(AVFormatContext *ic, AVDictionary **options)
-+// {
-+// /* TODO: no options are taking into account */
-+// return av_find_stream_info(ic);
-+// }
++//FFMPEG_INLINE
++//int avformat_find_stream_info(AVFormatContext *ic, AVDictionary **options)
++//{
++// /* TODO: no options are taking into account */
++// return av_find_stream_info(ic);
++//}
#endif
#if ((LIBAVFORMAT_VERSION_MAJOR > 53) || ((LIBAVFORMAT_VERSION_MAJOR == 53) && (LIBAVFORMAT_VERSION_MINOR > 32)) || ((LIBAVFORMAT_VERSION_MAJOR == 53) && (LIBAVFORMAT_VERSION_MINOR == 24) && (LIBAVFORMAT_VERSION_MICRO >= 100)))