aboutsummaryrefslogtreecommitdiff
path: root/graphics/blender
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2009-06-06 10:33:45 +0000
committerMarcus von Appen <mva@FreeBSD.org>2009-06-06 10:33:45 +0000
commit6790934512463205cf5d91944cfff8af1ec6d2fd (patch)
tree20af86ea7ffe645ba00eb8a545d1b57b670effe3 /graphics/blender
parent2b10b3191f13c0e1441381d74cc98ab65cb8fd6d (diff)
Notes
Diffstat (limited to 'graphics/blender')
-rw-r--r--graphics/blender/Makefile28
-rw-r--r--graphics/blender/distinfo6
-rw-r--r--graphics/blender/files/patch-extern_Makefile15
-rw-r--r--graphics/blender/files/patch-source_Makefile35
-rw-r--r--graphics/blender/files/patch-source_blender_blenkernel_intern_writeffmpeg.c11
-rw-r--r--graphics/blender/files/patch-user-def.mk18
-rw-r--r--graphics/blender/pkg-plist13
7 files changed, 90 insertions, 36 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index f46b4c83f21a..baf81b01521d 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= blender
-PORTVERSION= 2.48a
-PORTREVISION= 1
+PORTVERSION= 2.49
CATEGORIES= graphics games
MASTER_SITES= http://download.blender.org/source/ \
http://mirror.cs.umn.edu/blender.org/source/ \
@@ -49,15 +48,22 @@ OPTIONS= DDS "DDS file format support" on \
OCFLAGS "Optimized Cflags" off \
OPENAL "3D sound support using OpenAL" off \
OPENEXR "High dynamic-range (HDR) support using OpenEXR" on \
+ OPENJPEG "Enhanced JPEG graphics support using OpenJPEG" on \
OPENMP "Parallel processing support" off \
VERSE "Shared networking support using Verse" on
.include <bsd.port.pre.mk>
+BDSUFFIX= ${OSREL}-${ARCH}
+.if ${ARCH} == "amd64"
+BDSUFFIX= ${OSREL}-x86_64
+.endif
+
MAKE_ENV+= NAN_FMOD="${LOCALBASE}/"
MAKE_ENV+= NAN_PYTHON="${LOCALBASE}/"
MAKE_ENV+= NAN_PYTHON_VERSION=${PYTHON_VER}
MAKE_ENV+= NAN_JPEG="${LOCALBASE}/"
+MAKE_ENV+= NAN_OPENJPEG="${LOCALBASE}/"
MAKE_ENV+= NAN_PNG="${LOCALBASE}/"
MAKE_ENV+= NAN_ZLIB="${LOCALBASE}/"
MAKE_ENV+= NAN_ODE="${LOCALBASE}/"
@@ -158,6 +164,14 @@ LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
NANCPPFLAGS+= "-I${LOCALBASE}/include/OpenEXR"
.endif
+.if defined(WITHOUT_OPENJPEG)
+MAKE_ENV+= WITH_OPENJPEG="false"
+.else
+MAKE_ENV+= WITH_OPENJPEG="true"
+MAKE_ENV+= NAN_OPENJPEG="${LOCALBASE}/"
+LIB_DEPENDS+= openjpeg.2:${PORTSDIR}/graphics/openjpeg
+.endif
+
.if defined(WITH_OPENMP)
.if ${OSVERSION} < 700000
BROKEN= OpenMP support is not available for FreeBSD 6.x and below
@@ -192,8 +206,8 @@ pre-configure:
${WRKSRC}/user-def.mk
.else
@${REINPLACE_CMD} -e \
- 's|%%FFMPEGCFLAGS%%|$$\(shell pkg-config --cflags libavcodec libavformat\)|; \
- s|%%FFMPEGLIBS%%|$$\(shell pkg-config --libs libavcodec libavformat\)|;' \
+ 's|%%FFMPEGCFLAGS%%|$$\(shell pkg-config --cflags libavcodec libavformat libavdevice\)|; \
+ s|%%FFMPEGLIBS%%|$$\(shell pkg-config --libs libavcodec libavformat libavdevice\)|;' \
${WRKSRC}/user-def.mk
.endif
@@ -216,12 +230,12 @@ pre-configure:
do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/blender ${PREFIX}/bin/blender
- @${INSTALL_PROGRAM} ${WRKSRC}/obj/freebsd-${OSREL}-${ARCH}/bin/blender ${PREFIX}/bin/blender-bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/obj/freebsd-${BDSUFFIX}/bin/blender ${PREFIX}/bin/blender-bin
.if defined(WITH_KETSJI)
- @${INSTALL_PROGRAM} ${WRKSRC}/obj/freebsd-${OSREL}-${ARCH}/bin/blenderplayer ${PREFIX}/bin/blenderplayer
+ @${INSTALL_PROGRAM} ${WRKSRC}/obj/freebsd-${BDSUFFIX}/bin/blenderplayer ${PREFIX}/bin/blenderplayer
.endif
.if !defined(WITHOUT_VERSE)
- @${INSTALL_PROGRAM} ${WRKSRC}/obj/freebsd-${OSREL}-${ARCH}/bin/verse ${PREFIX}/bin/verse
+ @${INSTALL_PROGRAM} ${WRKSRC}/obj/freebsd-${BDSUFFIX}/bin/verse ${PREFIX}/bin/verse
.endif
@${MKDIR} ${DATADIR}
diff --git a/graphics/blender/distinfo b/graphics/blender/distinfo
index 036b51c050be..b458c7822c08 100644
--- a/graphics/blender/distinfo
+++ b/graphics/blender/distinfo
@@ -1,3 +1,3 @@
-MD5 (blender-2.48a.tar.gz) = 055d68d244458e9e429e4e492fc9b4ad
-SHA256 (blender-2.48a.tar.gz) = 781d4d9e2332f4f3887af1d66fb70c4c6dd0b89166391403ee4853108abf4e46
-SIZE (blender-2.48a.tar.gz) = 21502247
+MD5 (blender-2.49.tar.gz) = a0f58391ca2554df83375eeaaa8a3fb3
+SHA256 (blender-2.49.tar.gz) = 797a9c255b31e62ebc831952dba9149787f0b7c9ab8945948a619eae32d81a15
+SIZE (blender-2.49.tar.gz) = 23030434
diff --git a/graphics/blender/files/patch-extern_Makefile b/graphics/blender/files/patch-extern_Makefile
index cd0ac36e187b..7bba8f77db05 100644
--- a/graphics/blender/files/patch-extern_Makefile
+++ b/graphics/blender/files/patch-extern_Makefile
@@ -1,5 +1,5 @@
---- extern/Makefile.orig 2008-10-22 18:38:21.000000000 +0200
-+++ extern/Makefile 2009-03-20 23:17:59.000000000 +0100
+--- extern/Makefile.orig 2009-06-01 12:22:33.000000000 +0200
++++ extern/Makefile 2009-06-01 12:39:12.000000000 +0200
@@ -30,11 +30,7 @@
SOURCEDIR = extern
@@ -13,3 +13,14 @@
ifeq ($(WITH_FFMPEG), true)
ifeq ($(NAN_FFMPEG), $(LCGDIR)/ffmpeg)
+@@ -58,10 +54,6 @@
+ DIRS += binreloc
+ endif
+
+-ifeq ($(WITH_OPENJPEG), true)
+- DIRS += libopenjpeg
+-endif
+-
+ TARGET = solid
+
+ all::
diff --git a/graphics/blender/files/patch-source_Makefile b/graphics/blender/files/patch-source_Makefile
index 0cdd4b3ba6a0..67b8fc8dda29 100644
--- a/graphics/blender/files/patch-source_Makefile
+++ b/graphics/blender/files/patch-source_Makefile
@@ -1,6 +1,6 @@
---- source/Makefile.orig 2008-10-22 18:36:53.000000000 +0200
-+++ source/Makefile 2009-03-21 10:27:55.000000000 +0100
-@@ -106,7 +106,7 @@
+--- source/Makefile.orig 2009-06-01 12:22:26.000000000 +0200
++++ source/Makefile 2009-06-01 12:35:03.000000000 +0200
+@@ -105,7 +105,7 @@
COMLIB += $(OCGDIR)/blender/avi/$(DEBUG_DIR)libavi.a
COMLIB += $(NAN_JPEG)/lib/libjpeg.a
COMLIB += $(OCGDIR)/blender/gpu/$(DEBUG_DIR)libgpu.a
@@ -9,28 +9,45 @@
ifneq ($(NAN_NO_KETSJI),true)
COMLIB += $(OCGDIR)/gameengine/bloutines/$(DEBUG_DIR)libbloutines.a
-@@ -190,11 +190,11 @@
+@@ -160,7 +160,7 @@
+ COMLIB += $(NAN_GUARDEDALLOC)/lib/libguardedalloc.a
+ COMLIB += $(NAN_MEMUTIL)/lib/libmemutil.a
+ COMLIB += $(NAN_BMFONT)/lib/$(DEBUG_DIR)libbmfont.a
+-COMLIB += $(NAN_PNG)/lib/libpng.a
++COMLIB += $(NAN_PNG)/lib/libpng.so
+ COMLIB += $(OCGDIR)/blender/yafray/$(DEBUG_DIR)libyafrayexport.a
+ COMLIB += $(OCGDIR)/blender/blenlib/$(DEBUG_DIR)libblenlib.a
+
+@@ -173,7 +173,8 @@
+ endif
+
+ ifeq ($(WITH_OPENJPEG), true)
+- COMLIB += $(OCGDIR)/extern/openjpeg/$(DEBUG_DIR)libopenjpeg.a
++ #COMLIB += $(OCGDIR)/extern/openjpeg/$(DEBUG_DIR)libopenjpeg.a
++ COMLIB += $(NAN_OPENJPEG)/lib/libopenjpeg.so
+ endif
+
+ COMLIB += $(OCGDIR)/blender/imbuf/cineon/$(DEBUG_DIR)libcineon.a
+@@ -197,11 +198,11 @@
COMLIB += $(NAN_FREETYPE)/lib/freetype2ST.lib
endif
else
- COMLIB += $(NAN_FTGL)/lib/libftgl.a
+ COMLIB += $(NAN_FTGL)/lib/libftgl.so
ifeq ($(OS), irix)
- COMLIB += $(NAN_FREETYPE)/lib32/libfreetype.a
+ COMLIB += $(NAN_FREETYPE)/lib/libfreetype.a
else
- COMLIB += $(NAN_FREETYPE)/lib/libfreetype.a
+ COMLIB += $(NAN_FREETYPE)/lib/libfreetype.so
endif
endif
endif
-@@ -353,8 +353,8 @@
+@@ -362,7 +363,7 @@
NAN_SND_LIBS += $(DUMMYSOUND)
NAN_SND_LIBS += $(OPENALSOUND)
NAN_SND_LIBS += $(SDLSOUND)
- NAN_SND_LIBS += $(NAN_OPENAL)/lib/libopenal.a
-- ALUT = $(wildcard $(NAN_OPENAL)/lib/libalut.a)
+ NAN_SND_LIBS += $(NAN_OPENAL)/lib/libopenal.so
-+ ALUT = $(wildcard $(NAN_OPENAL)/lib/libalut.so)
- NAN_SND_LIBS += $(ALUT)
NAN_SND_LIBS += $(SOUNDSYSTEM)
else
+ ifeq ($(OS),windows)
diff --git a/graphics/blender/files/patch-source_blender_blenkernel_intern_writeffmpeg.c b/graphics/blender/files/patch-source_blender_blenkernel_intern_writeffmpeg.c
new file mode 100644
index 000000000000..4496858db061
--- /dev/null
+++ b/graphics/blender/files/patch-source_blender_blenkernel_intern_writeffmpeg.c
@@ -0,0 +1,11 @@
+--- source/blender/blenkernel/intern/writeffmpeg.c.orig 2009-06-01 17:26:43.000000000 +0200
++++ source/blender/blenkernel/intern/writeffmpeg.c 2009-06-01 17:27:38.000000000 +0200
+@@ -519,7 +519,7 @@
+
+ /* xasp & yasp got float lately... */
+
+- st->sample_aspect_ratio = c->sample_aspect_ratio = av_d2q(
++ st->codec->sample_aspect_ratio = c->sample_aspect_ratio = av_d2q(
+ ((double) G.scene->r.xasp / (double) G.scene->r.yasp), 255);
+
+ set_ffmpeg_properties(c, "video");
diff --git a/graphics/blender/files/patch-user-def.mk b/graphics/blender/files/patch-user-def.mk
index 4f79206faaef..1fe9d5d79585 100644
--- a/graphics/blender/files/patch-user-def.mk
+++ b/graphics/blender/files/patch-user-def.mk
@@ -1,6 +1,6 @@
---- user-def.mk.orig 2009-03-07 12:58:21.000000000 +0100
-+++ user-def.mk 2009-03-07 13:30:16.000000000 +0100
-@@ -0,0 +1,26 @@
+--- user-def.mk.orig 1970-01-01 01:00:00.000000000 +0100
++++ user-def.mk 2009-06-01 12:32:18.000000000 +0200
+@@ -0,0 +1,20 @@
+export NAN_DEBUG=
+
+export TYPE := $(shell echo `uname -s`)
@@ -8,22 +8,16 @@
+# Allow 64bit compiles.
+export NAN_YESIAMSTUPID=true
+
-+export NAN_PYTHON ?= /usr/local
-+export NAN_PYTHON_VERSION ?= 2.5
-+export NAN_OPENAL ?= /usr/local
+export NAN_FMOD ?= /usr/local
++export NAN_OPENJPEG ?= /usr/local
+export NAN_FTGL ?= /usr/local
-+export NAN_JPEG ?= /usr/local
-+export NAN_PNG ?= /usr/local
+export NAN_GLEW ?= /usr/local
+export NAN_OPENEXR ?= /usr/local
+export NAN_OPENEXR_LIBS ?= $(NAN_OPENEXR)/lib/libIlmImf.a \
-+ $(NAN_OPENEXR)/lib/libHalf.a \
-+ $(NAN_OPENEXR)/lib/libIex.a
++ $(NAN_OPENEXR)/lib/libHalf.a \
++ $(NAN_OPENEXR)/lib/libIex.a
+export NAN_ZLIB ?= /usr/local
+export NAN_ODE ?= /usr/local
-+export NAN_MESA = /export/scratch/crap/Mesa-6.2.1
-+export NAN_NSPR = /export/scratch/blender/src/nspr-4.2.2/mozilla/nsprpub/dist
+export NAN_FREETYPE ?= /usr/local
+export NAN_FFMPEGLIBS = %%FFMPEGLIBS%%
+export NAN_FFPMEGCFLAGS = %%FFMPEGCFLAGS%%
diff --git a/graphics/blender/pkg-plist b/graphics/blender/pkg-plist
index 7f65cf766535..144aadf720b8 100644
--- a/graphics/blender/pkg-plist
+++ b/graphics/blender/pkg-plist
@@ -46,7 +46,6 @@ bin/blender-bin
%%DATADIR%%/scripts/bpymodules/BPyImage.py
%%DATADIR%%/scripts/bpymodules/BPyMathutils.py
%%DATADIR%%/scripts/bpymodules/BPyMesh.py
-%%DATADIR%%/scripts/bpymodules/BPyMesh_octree.py
%%DATADIR%%/scripts/bpymodules/BPyMesh_redux.py
%%DATADIR%%/scripts/bpymodules/BPyMessages.py
%%DATADIR%%/scripts/bpymodules/BPyNMesh.py
@@ -78,6 +77,7 @@ bin/blender-bin
%%DATADIR%%/scripts/add_mesh_empty.py
%%DATADIR%%/scripts/add_mesh_torus.py
%%DATADIR%%/scripts/animation_bake_constraints.py
+%%DATADIR%%/scripts/animation_clean.py
%%DATADIR%%/scripts/animation_trajectory.py
%%DATADIR%%/scripts/armature_symmetry.py
%%DATADIR%%/scripts/bevel_center.py
@@ -122,6 +122,7 @@ bin/blender-bin
%%DATADIR%%/scripts/help_web_eshop.py
%%DATADIR%%/scripts/help_web_usercomm.py
%%DATADIR%%/scripts/hotkeys.py
+%%DATADIR%%/scripts/image_2d_cutout.py
%%DATADIR%%/scripts/image_auto_layout.py
%%DATADIR%%/scripts/image_billboard.py
%%DATADIR%%/scripts/image_edit.py
@@ -139,6 +140,7 @@ bin/blender-bin
%%DATADIR%%/scripts/mesh_edges2curves.py
%%DATADIR%%/scripts/mesh_mirror_tool.py
%%DATADIR%%/scripts/mesh_poly_reduce.py
+%%DATADIR%%/scripts/mesh_poly_reduce_grid.py
%%DATADIR%%/scripts/mesh_skin.py
%%DATADIR%%/scripts/mesh_solidify.py
%%DATADIR%%/scripts/mesh_unfolder.py
@@ -146,6 +148,7 @@ bin/blender-bin
%%DATADIR%%/scripts/ms3d_import.py
%%DATADIR%%/scripts/ms3d_import_ascii.py
%%DATADIR%%/scripts/obdatacopier.py
+%%DATADIR%%/scripts/object_active_to_other.py
%%DATADIR%%/scripts/object_apply_def.py
%%DATADIR%%/scripts/object_batch_name_edit.py
%%DATADIR%%/scripts/object_cookie_cutter.py
@@ -165,9 +168,11 @@ bin/blender-bin
%%DATADIR%%/scripts/render_save_layers.py
%%DATADIR%%/scripts/rvk1_torvk2.py
%%DATADIR%%/scripts/save_theme.py
-%%DATADIR%%/scripts/scripttemplate_camer_object.py
+%%DATADIR%%/scripts/scripttemplate_background_job.py
+%%DATADIR%%/scripts/scripttemplate_camera_object.py
%%DATADIR%%/scripts/scripttemplate_gamelogic.py
%%DATADIR%%/scripts/scripttemplate_gamelogic_basic.py
+%%DATADIR%%/scripts/scripttemplate_gamelogic_module.py
%%DATADIR%%/scripts/scripttemplate_ipo_gen.py
%%DATADIR%%/scripts/scripttemplate_mesh_edit.py
%%DATADIR%%/scripts/scripttemplate_metaball_create.py
@@ -176,6 +181,7 @@ bin/blender-bin
%%DATADIR%%/scripts/scripttemplate_text_plugin.py
%%DATADIR%%/scripts/slp_import.py
%%DATADIR%%/scripts/sysinfo.py
+%%DATADIR%%/scripts/textplugin_convert_ge.py
%%DATADIR%%/scripts/textplugin_functiondocs.py
%%DATADIR%%/scripts/textplugin_imports.py
%%DATADIR%%/scripts/textplugin_membersuggest.py
@@ -203,9 +209,10 @@ bin/blender-bin
%%DATADIR%%/scripts/weightpaint_invert.py
%%DATADIR%%/scripts/weightpaint_normalize.py
%%DATADIR%%/scripts/widgetwizard.py
+%%DATADIR%%/scripts/wizard_bolt_factory.py
%%DATADIR%%/scripts/wizard_curve2tree.py
+%%DATADIR%%/scripts/wizard_landscape_ant.py
%%DATADIR%%/scripts/x3d_export.py
-%%DATADIR%%/scripts/xfig_export.py
%%DATADIR%%/scripts/xsi_export.py
@dirrm %%DATADIR%%/scripts/bpymodules/colladaImEx
@dirrm %%DATADIR%%/scripts/bpymodules