aboutsummaryrefslogtreecommitdiff
path: root/graphics/bugle
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-06-05 00:16:04 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-06-05 00:16:04 +0000
commitccaeb9f055183fba18ff48ef7ceb70e856ec8ac0 (patch)
treeedb1fcf555575980c471c0ae6859ca9739af5a84 /graphics/bugle
parent572cad725f474c79634e20ffe5bf5468138b8385 (diff)
downloadports-ccaeb9f055183fba18ff48ef7ceb70e856ec8ac0.tar.gz
ports-ccaeb9f055183fba18ff48ef7ceb70e856ec8ac0.zip
Notes
Diffstat (limited to 'graphics/bugle')
-rw-r--r--graphics/bugle/Makefile36
-rw-r--r--graphics/bugle/distinfo6
2 files changed, 34 insertions, 8 deletions
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
index 1ffc56066976..dd46603985ca 100644
--- a/graphics/bugle/Makefile
+++ b/graphics/bugle/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bugle
-PORTVERSION= 0.0.20060429
+PORTVERSION= 0.0.20060528
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,7 +14,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= erik@smluc.org
COMMENT= A debugging library for OpenGL
-LIB_DEPENDS= gtkglext-x11-1.0.2:${PORTSDIR}/x11-toolkits/gtkglext
+OPTIONS= AVCODEC "With avcodec support (ffmpeg)" off
+OPTIONS+= GUI "With GTK support (GtkGlExt)" off
+OPTIONS+= THREADS "With threading support" off
GNU_CONFIGURE= yes
USE_GCC= 3.4
@@ -24,12 +26,16 @@ USE_AUTOTOOLS= libltdl:15
INSTALLS_SHLIB= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --enable-ltdl-install=no
+CONFIGURE_ARGS=--enable-ltdl-install=no
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
-MAN1= gldb.1
-MAN3= bugle.3
+MAN1= gldb.1
+MAN3= bugle.3
+MAN7= bugle-camera.7 bugle-checks.7 bugle-eps.7 bugle-error.7 \
+ bugle-frontbuffer.7 bugle-log.7 bugle-screenshot.7 \
+ bugle-showerror.7 bugle-showextensions.7 bugle-showstats.7 \
+ bugle-stats.7 bugle-trace.7 bugle-unwindstack.7 bugle-wireframe.7
.include <bsd.port.pre.mk>
@@ -37,4 +43,24 @@ MAN3= bugle.3
IGNORE= requires perl 5.6.x or later to build. Install lang/perl5.8 then try again
.endif
+.if defined(WITH_AVCODEC)
+CONFIGURE_ARGS+=--with-lavc
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+.else
+CONFIGURE_ARGS+=--without-lavc
+.endif
+
+.if defined(WITH_GUI)
+LIB_DEPENDS+= gtkglext-x11-1.0.2:${PORTSDIR}/x11-toolkits/gtkglext
+CONFIGURE_ARGS+=--with-gtk --with-gtkglext
+.else
+CONFIGURE_ARGS+=--without-gtk --without-gtkglext
+.endif
+
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+=--with-threads=pthreads
+.else
+CONFIGURE_ARGS+=--with-threads=single
+.endif
+
.include <bsd.port.post.mk>
diff --git a/graphics/bugle/distinfo b/graphics/bugle/distinfo
index ada1e7ea169f..a18dc6c58f65 100644
--- a/graphics/bugle/distinfo
+++ b/graphics/bugle/distinfo
@@ -1,3 +1,3 @@
-MD5 (bugle-0.0.20060429.tar.gz) = 8419b994aba8df4ec6c6a834b1e5abc0
-SHA256 (bugle-0.0.20060429.tar.gz) = 6489fc1c83f4c6a20aa971f05083a1f98a9ccfd52587f37567b666815542fd39
-SIZE (bugle-0.0.20060429.tar.gz) = 1293343
+MD5 (bugle-0.0.20060528.tar.gz) = f197fcb3eae8e870daeb6f32251e8c4b
+SHA256 (bugle-0.0.20060528.tar.gz) = 0c4b1597022237d7e50b74433029846453b08a6ba52e88edf716298b45468ae9
+SIZE (bugle-0.0.20060528.tar.gz) = 1313650