aboutsummaryrefslogtreecommitdiff
path: root/graphics/bugle
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-11-22 17:14:57 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-11-22 17:14:57 +0000
commitf6234381e38753e5b8dcf218ed9e8e50b85f4113 (patch)
treece5d9ac02bd790755cdd79b9d253251df4268afb /graphics/bugle
parenta0b2cbbb87f775c0d53b82c0559cf935b5d4629e (diff)
downloadports-f6234381e38753e5b8dcf218ed9e8e50b85f4113.tar.gz
ports-f6234381e38753e5b8dcf218ed9e8e50b85f4113.zip
Notes
Diffstat (limited to 'graphics/bugle')
-rw-r--r--graphics/bugle/Makefile20
-rw-r--r--graphics/bugle/files/patch-configure13
-rw-r--r--graphics/bugle/pkg-plist88
3 files changed, 86 insertions, 35 deletions
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
index bafba7619b71..8bc3df6fb646 100644
--- a/graphics/bugle/Makefile
+++ b/graphics/bugle/Makefile
@@ -28,14 +28,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
GL_LIBS="-L${LOCALBASE}/lib"
-BROKEN= does not compile
-
-MAN1= gldb.1
+MAN1= gldb.1 gldb-gui.1
MAN3= bugle.3
-MAN7= bugle-camera.7 bugle-checks.7 bugle-eps.7 bugle-error.7 \
- bugle-extoverride.7 bugle-frontbuffer.7 bugle-log.7 bugle-logstats.7 \
- bugle-screenshot.7 bugle-showerror.7 bugle-showextensions.7 \
- bugle-showstats.7 bugle-stats_basic.7 bugle-stats_fragments.7 \
+MAN5= bugle-statistics.5
+MAN7= bugle-camera.7 bugle-checks.7 bugle-eps.7 bugle-error.7 \
+ bugle-exe.7 bugle-extoverride.7 bugle-frontbuffer.7 bugle-log.7 \
+ bugle-logstats.7 bugle-screenshot.7 bugle-showerror.7 \
+ bugle-showextensions.7 bugle-showstats.7 bugle-stats_basic.7 \
+ bugle-stats_calls.7 bugle-stats_calltimes.7 bugle-stats_fragments.7 \
bugle-stats_nv.7 bugle-stats_primitives.7 bugle-trace.7 \
bugle-unwindstack.7 bugle-wireframe.7
@@ -72,4 +72,10 @@ BROKEN= Fails to link
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' ${WRKSRC}/gengl/find_header.perl
+post-install:
+ @${RM} -f ${PREFIX}/lib/*.la ${PREFIX}/lib/bugle/*.la \
+ ${PREFIX}/lib/pkgconfig/bugle.pc
+ @-${RMDIR} ${PREFIX}/lib/pkgconfig
+ @${RM} -rf ${PREFIX}/share/doc/bugle
+
.include <bsd.port.post.mk>
diff --git a/graphics/bugle/files/patch-configure b/graphics/bugle/files/patch-configure
index 1be399f9493c..784ed8f883b5 100644
--- a/graphics/bugle/files/patch-configure
+++ b/graphics/bugle/files/patch-configure
@@ -1,16 +1,3 @@
---- configure.ac.orig 2009-10-26 20:12:49.000000000 +0100
-+++ configure.ac 2009-11-01 15:23:46.000000000 +0100
-@@ -228,8 +228,8 @@
- [test $withval = no && HAVE_GTK=0], [])
- GLDB=gldb/gldb$EXEEXT
- GLDB_GUI=gldb/gldb-gui$EXEEXT
--test $HAVE_GTK == 1 || GLDB_GUI=""
--test $BUGLE_OSAPI == "BUGLE_OSAPI_POSIX" || GLDB=""
-+test $HAVE_GTK = 1 || GLDB_GUI=""
-+test $BUGLE_OSAPI = "BUGLE_OSAPI_POSIX" || GLDB=""
- AC_SUBST(GLDB)
- AC_SUBST(GLDB_GUI)
-
--- configure.orig 2009-10-26 20:17:02.000000000 +0100
+++ configure 2009-11-01 15:33:48.000000000 +0100
@@ -37159,8 +37159,8 @@
diff --git a/graphics/bugle/pkg-plist b/graphics/bugle/pkg-plist
index 0977ba9493fe..56b6f58dde64 100644
--- a/graphics/bugle/pkg-plist
+++ b/graphics/bugle/pkg-plist
@@ -1,31 +1,89 @@
bin/gldb
-lib/bugle/capture.a
-lib/bugle/capture.la
-lib/bugle/capture.so
+include/bugle/budgie/addresses.h
+include/bugle/budgie/basictypes.h
+include/bugle/budgie/call.h
+include/bugle/budgie/macros.h
+include/bugle/budgie/reflect.h
+include/bugle/budgie/types.h
+include/bugle/budgie/types2.h
+include/bugle/bugle/apireflect.h
+include/bugle/bugle/filters.h
+include/bugle/bugle/gl/glbeginend.h
+include/bugle/bugle/gl/gldisplaylist.h
+include/bugle/bugle/gl/gldump.h
+include/bugle/bugle/gl/glextensions.h
+include/bugle/bugle/gl/glheaders.h
+include/bugle/bugle/gl/globjects.h
+include/bugle/bugle/gl/glsl.h
+include/bugle/bugle/gl/glstate.h
+include/bugle/bugle/gl/gltypes.h
+include/bugle/bugle/gl/glutils.h
+include/bugle/bugle/gl/overrides.h
+include/bugle/bugle/glwin/glwin.h
+include/bugle/bugle/glwin/glwintypes.h
+include/bugle/bugle/glwin/trackcontext.h
+include/bugle/bugle/glx/glxdump.h
+include/bugle/bugle/glx/overrides.h
+include/bugle/bugle/hashtable.h
+include/bugle/bugle/input.h
+include/bugle/bugle/linkedlist.h
+include/bugle/bugle/log.h
+include/bugle/bugle/misc.h
+include/bugle/bugle/objects.h
+include/bugle/bugle/porting.h
+include/bugle/bugle/stats.h
+lib/bugle/camera.a
+lib/bugle/camera.so
+lib/bugle/checks.a
+lib/bugle/checks.so
lib/bugle/common.a
-lib/bugle/common.la
lib/bugle/common.so
lib/bugle/debugger.a
-lib/bugle/debugger.la
lib/bugle/debugger.so
+lib/bugle/eps.a
+lib/bugle/eps.so
+lib/bugle/exe.a
+lib/bugle/exe.so
+lib/bugle/extoverride.a
+lib/bugle/extoverride.so
+lib/bugle/logstats.a
+lib/bugle/logstats.so
lib/bugle/modify.a
-lib/bugle/modify.la
lib/bugle/modify.so
-lib/bugle/stats.a
-lib/bugle/stats.la
-lib/bugle/stats.so
+lib/bugle/screenshot.a
+lib/bugle/screenshot.so
+lib/bugle/showextensions.a
+lib/bugle/showextensions.so
+lib/bugle/showstats.a
+lib/bugle/showstats.so
+lib/bugle/stats_basic.a
+lib/bugle/stats_basic.so
+lib/bugle/stats_calls.a
+lib/bugle/stats_calls.so
+lib/bugle/stats_calltimes.a
+lib/bugle/stats_calltimes.so
+lib/bugle/stats_fragments.a
+lib/bugle/stats_fragments.so
+lib/bugle/stats_nv.a
+lib/bugle/stats_nv.so
+lib/bugle/stats_primitives.a
+lib/bugle/stats_primitives.so
lib/bugle/trace.a
-lib/bugle/trace.la
lib/bugle/trace.so
+lib/bugle/unwindstack.a
+lib/bugle/unwindstack.so
lib/bugle/validate.a
-lib/bugle/validate.la
lib/bugle/validate.so
lib/libbugle.a
-lib/libbugle.la
lib/libbugle.so
-lib/libbugle.so.3
+lib/libbugle.so.8
lib/libbugleutils.a
-lib/libbugleutils.la
lib/libbugleutils.so
-lib/libbugleutils.so.3
+lib/libbugleutils.so.7
+@dirrm include/bugle/bugle/glx
+@dirrm include/bugle/bugle/glwin
+@dirrm include/bugle/bugle/gl
+@dirrm include/bugle/bugle
+@dirrm include/bugle/budgie
+@dirrm include/bugle
@dirrm lib/bugle