aboutsummaryrefslogtreecommitdiff
path: root/graphics/bugle
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-12-03 06:37:40 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-12-03 06:37:40 +0000
commit1c7ac185bb767032253cbf9c0fb1004c02b1b72d (patch)
treeb4b3f5121adad7f12681986a95b5de39a858a40f /graphics/bugle
parent667c5f7c5078eb6b9e437833a0226ec80390948e (diff)
downloadports-1c7ac185bb767032253cbf9c0fb1004c02b1b72d.tar.gz
ports-1c7ac185bb767032253cbf9c0fb1004c02b1b72d.zip
Notes
Diffstat (limited to 'graphics/bugle')
-rw-r--r--graphics/bugle/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
index 9d8ff0c66a5e..a04d16e5a881 100644
--- a/graphics/bugle/Makefile
+++ b/graphics/bugle/Makefile
@@ -28,7 +28,8 @@ USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/${PORTNAME}
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS=--enable-ltdl-install=no
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
- LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
+ LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
+ GL_LIBS="-L${X11BASE}/lib"
MAN1= gldb.1
MAN3= bugle.3
@@ -69,4 +70,7 @@ CONFIGURE_ARGS+=--with-threads=pthreads
CONFIGURE_ARGS+=--with-threads=single
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/gentokens/find_header.perl
+
.include <bsd.port.post.mk>